股票下载网共有股票软件:7218 个 | 股票公式:32535 个 | 文章:3812 篇 | 总容量:71.001 G | 总下载:7443379 次 | 今日更新:0

10天内连续出现的信号 缠论飘带 荆州量学金融终端主图六 通达信指标 源码 贴图

简介:DA1:=IF(130>TOTALBARSCOUNT,TOTALBARSCOUNT,130);DA:=IF(CURRBARSCOUNT>DA1,0,DA1);HI:=REFDATE(HHV(H,DA),DATE);LO:=REF
标签:10天内连续出现的信号 缠论飘带 荆州量学金融终端主图六 通达信指标 源码 贴图
  来源:www.gpxiazai.com   发布时间:2018-08-03 点击:

DA1:=IF(130>TOTALBARSCOUNT,TOTALBARSCOUNT,130);

DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
LO:=REFDATE(LLV(L,DA),DATE);
C1001:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/10);
LH1:=SUM(IF(C1001>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1001>=(HI/POW(GZ,2)) AND C1001<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1001>=(HI/POW(GZ,3)) AND C1001<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1001>=(HI/POW(GZ,4)) AND C1001<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1001>=(HI/POW(GZ,5)) AND C1001<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1001>=(HI/POW(GZ,6)) AND C1001<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1001>=(HI/POW(GZ,7)) AND C1001<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1001>=(HI/POW(GZ,8)) AND C1001<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1001>=(LO*GZ) AND C1001<LO*POW(GZ,2),V,0),DA);
LH10:=SUM(IF(C1001>=LO AND C1001<LO*GZ,V,0),DA);
L1001:=REFDATE(HHV(LH1,DA),DATE),LINETHICK0;
L2001:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;
L3001:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;
L4001:=REFDATE(HHV(LH4,DA),DATE);
L5001:=REFDATE(HHV(LH5,DA),DATE);
L6001:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
SSS:=(L1001+L2001+L3001+L4001+L5001+L6001+L7+L8+L9+L10);
VAR121:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR141:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR161:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR181:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
卖:=(VAR121+VAR141+VAR161+VAR181),LINETHICK2;
STICKLINE(CEILING(DA*L2001/SSS)*3>=CURRBARSCOUNT AND BARSCOUNT(C)>100 AND 显示筹码=1,HI/POW(GZ,1)*99/100,HI/POW(GZ,2),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L3001/SSS)*3>=CURRBARSCOUNT AND BARSCOUNT(C)>100 AND 显示筹码=1,HI/POW(GZ,2)*99/100,HI/POW(GZ,3),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L4001/SSS)*3>=CURRBARSCOUNT AND BARSCOUNT(C)>100 AND 显示筹码=1,HI/POW(GZ,3)*99/100,HI/POW(GZ,4),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L5001/SSS)*3>=CURRBARSCOUNT AND BARSCOUNT(C)>100 AND 显示筹码=1,HI/POW(GZ,4)*99/100,HI/POW(GZ,5),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L6001/SSS)*3>=CURRBARSCOUNT AND BARSCOUNT(C)>100 AND 显示筹码=1,HI/POW(GZ,5)*99/100,HI/POW(GZ,6),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L7/SSS)*3>=CURRBARSCOUNT AND BARSCOUNT(C)>100 AND 显示筹码=1,HI/POW(GZ,6)*99/100,HI/POW(GZ,7),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L8/SSS)*3>=CURRBARSCOUNT AND BARSCOUNT(C)>100 AND 显示筹码=1,LO*POW(GZ,2),LO*POW(GZ,3)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L9/SSS)*3>=CURRBARSCOUNT AND BARSCOUNT(C)>100 AND 显示筹码=1,LO*POW(GZ,1),LO*POW(GZ,2)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L10/SSS)*3>=CURRBARSCOUNT AND BARSCOUNT(C)>100 AND 显示筹码=1,LO,LO*POW(GZ,1)*99/100,9,0)COLOR3C3C3A,LINETHICK3;

STICKLINE(CEILING(DA*L1001/SSS)*3>=CURRBARSCOUNT AND BARSCOUNT(C)>100 AND 显示筹码=1,HI*99/100,HI/GZ,9,0)COLOR3C3C3A,LINETHICK3;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

上榜:=SIGNALS_USER(300, 0), NODRAW; {上榜金额>1,则表示上榜了,这个是上榜总金额}
净买入:=SIGNALS_USER(299, 0), NODRAW;
DRAWICON(上榜>=1 AND 净买入>=0 AND 显示龙虎标志=1,L*0.995,38);
DRAWICON(上榜>=1 AND 净买入<0 AND 显示龙虎标志=1,L*0.995,39);
NAME_299 := '↖ 龙';
OUTTEXT_299:=VARCAT(VARCAT(NAME_299, ' '), VAR2STR(净买入, 0)), NODRAW;
DRAWTEXT((上榜>=1) AND 显示龙虎=1,-LOW*0.01+LOW,OUTTEXT_299),COLORLIRED;
N:=(1,100,8);
KK:=(0,2,0);
TYP := (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,6));
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;
AAAB:=(3*C+H+L+O)/6;
VVAR1:=(8*AAAB+7*REF(AAAB,1)+6*REF(AAAB,2)+5*REF(AAAB,3)+4*REF(AAAB,4)+3*REF(AAAB,5)+2*REF(AAAB,6)+REF(AAAB,8))/36;
VVAR6:=(LLV(VVAR1,2)+LLV(VVAR1,4)+LLV(VVAR1,6))/3;
短线:IF(KK=0 AND 显示飘带=1, VVAR1, DRAWNULL),COLORWHITE;
中线1:IF(KK=0 AND 显示飘带=1,VVAR6, DRAWNULL),COLORYELLOW;
DRAWBAND(短线,RGB(200,10,10),中线1,RGB(10,200,10));
DRAWKLINE(H,O,L,C);
下跌:IF(KK=0 AND VVAR1=VVAR6,VVAR6, DRAWNULL),COLORGREEN;
中:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
上轨:IF(KK=1,中+3*STD(中,10),DRAWNULL),COLOR000088,LINETHICK1;
IF(KK=1,2*MA(上轨,12)-MA(C,21),DRAWNULL),COLOR666666;
N1:=(1,100,10);
N2:=(1,100,10);
DISP:=(1,3,2);
K:=IF(PERIOD=5,1,{日}
IF(PERIOD=6,1,{周}
IF(PERIOD=7,1,{月}
IF(PERIOD=8,1,{多分钟}
IF(PERIOD=9,1,{多日}
IF(PERIOD=10,1,{季}
IF(PERIOD=11,2,{年}
IF(PERIOD=4,1,{60F}
IF(PERIOD=3,1,{30F}
IF(PERIOD=2,1,{15F}
IF(PERIOD=1,1{5F},1{1F})))))))))))/10;
P1:=PEAK(1,K*N1,1);
P2:=PEAK(1,K*N1,2);
WP1:=PEAKBARS(1,K*N1,1);
WP2:=PEAKBARS(1,K*N1,2);
T1:=TROUGH(2,K*N2,1);
T2:=TROUGH(2,K*N2,2);
WT1:=TROUGHBARS(2,K*N2,1);
WT2:=TROUGHBARS(2,K*N2,2);
TJ1:=P1>T1 AND P2>T2 ;
ZD:=MAX(T1,T2);
ZG:=MIN(P1,P2);
LL:=MIN(T1,T2);
HH:=MAX(P1,P2);
TJ2:=FILTER(ZG>ZD,2);
TJ3:=ZG=REF(ZG,BARSLAST(TJ2)) OR ZD=REF(ZD,BARSLAST(TJ2));
TJ4:=TJ1&&TJ2&&NOT(TJ3);
TJ5:=BETWEEN(ZD,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
TJ6:=BETWEEN(ZG,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
TJ7:=ZG>REF(ZG,REF(BARSLAST(TJ4),1))&&ZD<REF(ZD,REF(BARSLAST(TJ4),1));
TJ8:=TJ4&&NOT(TJ5 OR TJ6 OR TJ7);
ZSD:=IF(TJ8,ZD,DRAWNULL);
ZSG:=IF(TJ8,ZG,DRAWNULL);
ZSH:=IF(TJ8,HH,DRAWNULL);
ZSL:=IF(TJ8,LL,DRAWNULL);
STICKLINE(TJ8,ZSH,ZSL,0,-1),COLORMAGENTA;
STICKLINE(TJ8,ZSD,ZSG,IF(DISP=1,3,0),1),COLORMAGENTA;
DRAWTEXT(DISP=2,ZSH,'中枢'),COLORWHITE;
中枢高:PLOYLINE(DISP=2,REF(ZSD,BARSLAST(TJ8))),CIRCLEDOT,COLORLIRED;
中枢低:PLOYLINE(DISP=2,REF(ZSG,BARSLAST(TJ8))),CIRCLEDOT,COLORLIGREEN;
中枢最高:PLOYLINE(DISP=2,REF(ZSH,BARSLAST(TJ8))),POINTDOT,COLORRED;
中枢最低:PLOYLINE(DISP=2,REF(ZSL,BARSLAST(TJ8))),POINTDOT,COLORGREEN;
趋势高:PLOYLINE(DISP=3,ZIG(1,K*N1)),COLORLIBLUE;
趋势低:PLOYLINE(DISP=3,ZIG(2,K*N2)),COLORLIBLUE;
局部低点预选A:=BACKSET(LLV(L,5)<REF(LLV(L,4),1),4);
局部低点预选B:=BACKSET(局部低点预选A=0 AND REF(局部低点预选A,1)=1,2);
局部低点预选C:=IF(局部低点预选B=1 AND REF(局部低点预选B,1)=0,-1,0);
局部高点预选A:=BACKSET(HHV(H,5)>REF(HHV(H,4),1),4);
局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);
局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);
缺口判断:=IF(L>REF(H,1),1,IF(H<REF(L,1),-1,0));
距前高天:=BARSLAST(局部高点预选C=1);
距前低天:=BARSLAST(局部低点预选C=-1);
小值周期:=LOWRANGE(L);
大值周期:=TOPRANGE(H);
低保留AA:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
低保留AB:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR LLV(L,距前低天+2)<REF(LLV(L,距前低天+1),1)),-1,0);
低保留S:=IF((低保留AA=-1 OR 低保留AB=-1) AND L<REF(H,距前高天+1),-1,0);
预判:=IF((距前低天<4 AND HHV(缺口判断,距前低天)!=1) OR REF(低保留S,距前低天)=0,1,0);
判断:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND 预判=1 AND 大值周期>REF(小值周期,距前低天+1) AND 大值周期
>REF(小值周期,距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);
高保留A:=IF(局部高点预选C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);
高保留B:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND REF(低保留S,距前低天)=-1 AND (距前低天>=4 OR HHV(缺口判断,距前低天)=1),1,0);
高保留:=IF((高保留A=1 OR 高保留B=1 OR 判断=1) AND H>REF(L,距前低天+1),1,0);
预判A:=IF((距前高天<4 AND HHV(缺口判断,距前高天)!=1) OR REF(高保留,距前高天)=0,1,0);
判断A:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND 预判A=1 AND 小值周期>REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);
低保留A:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
低保留B:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR 判断A=-
1),-1,0);
低保留:=IF((低保留A=-1 OR 低保留B=-1) AND L<REF(H,距前高天+1),-1,0);
距前高天A:=BARSLAST(高保留=1);
距前低天A:=BARSLAST(低保留=-1);
预判X:=IF((距前低天A<4 AND HHV(缺口判断,距前低天A)!=1) OR REF(低保留,距前低天A)=0,1,0);
判断X:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND 预判X=1 AND 大值周期>REF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);
高保留XA:=IF(局部高点预选C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(HHV(H,距前低天A+1),1),1,0);
高保留XB:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND REF(低保留,距前低天A)=-1 AND (距前低天A>=4 OR HHV(缺口判断,距前低天A)=1),1,0);
高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判断X=1) AND H>REF(L,距前低天A+1),1,0);
预判XA:=IF((距前高天A<4 AND HHV(缺口判断,距前高天A)!=1) OR REF(高保留XA,距前高天A)=0,1,0);
判断XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND 预判XA=1 AND 小值周期>REF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);
低保留XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)<REF(LLV(L,距前高天A+1),1),-1,0);
低保留XB:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND (距前高天A>=4 OR LLV(缺口判断,距前高天A)=-1 OR 判断XA=-1),-1,0);
低保留X:=IF((低保留XA=-1 OR 低保留XB=-1) AND L<REF(H,距前高天A+1),-1,0);
距前高天YA:=BARSLAST(高保留X=1);
距前低天YA:=BARSLAST(低保留X=-1);
预判YX:=IF((距前低天YA<4 AND HHV(缺口判断,距前低天YA)!=1) OR REF(低保留X,距前低天YA)=0,1,0);
判断YX:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND 预判YX=1 AND 大值周期>REF(小值周期,距前低天YA+1) AND
大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,0);
高保留YXA:=IF(局部高点预选C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);
高保留YXB:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND REF(低保留X,距前低天YA)=-1 AND (距前低天YA>=4 OR
HHV(缺口判断,距前低天YA)=1),1,0);
高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判断YX=1) AND H>REF(L,距前低天YA+1),1,0);
预判YXA:=IF((距前高天YA<4 AND HHV(缺口判断,距前高天YA)!=1) OR REF(高保留YXA,距前高天YA)=0,1,0);
判断YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND 预判YXA=1 AND 小值周期>REF(大值周期,距前高天YA+1)
AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);
低保留YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)<REF(LLV(L,距前高天YA+1),1),-
1,0);
低保留YXB:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND (距前高天YA>=4 OR LLV(缺口判断,距前高天YA)=-1 OR
判断YXA=-1),-1,0);
低保留YX:=IF((低保留YXA=-1 OR 低保留YXB=-1) AND L<REF(H,距前高天YA+1),-1,0);
AAAD:=IF(高保留YX=1 AND 低保留YX=-1 AND H>REF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND L<REF(L,REF(距前低天YA,1)+2),-1,0));
极点保留:=IF(AAAD=0,高保留YX+低保留YX,AAAD);
局部极点:IF(极点保留=-1,L,IF(极点保留=1,H,DRAWNULL)) CIRCLEDOT COLORYELLOW;
STICKLINE(C>REF(C,1)*1.099,C,O,2.7,0)COLORRED,LINETHICK2;
STICKLINE(C<REF(C,1)*0.901,C,O,2.7,0)COLORGREEN,LINETHICK2;
DRAWLINE(极点保留=-1,局部极点,极点保留=1,局部极点,0),COLORRED;
DRAWLINE(极点保留=1,局部极点,极点保留=-1,局部极点,0),COLORGREEN;
DD1:=BARSLAST(ABS(极点保留)!=1);
DRAWICON(极点保留=1,局部极点,2);
DRAWICON(极点保留=-1,局部极点,1);
{MA5:MA(CLOSE,5),COLORMAGENTA,LINETHICK1;
判:IF(MA5<REF(MA5,1),MA5,DRAWNULL),COLORCYAN,LINETHICK1;};
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(V2>=1,O,C,1,0),COLORYELLOW;
TY:=C;{收盘价}
A1:=REF(TY,10)=HHV(TY,2*10+1);{10日前收盘价等于21天内最高价}
VB1:=FILTER(A1,10);{当出现A1条件时,过滤10天后连续出现的信号}
C1:=BACKSET(VB1,10+1);{将当前位置到11天前的位置设为1}
HD:=FILTER(C1,10);{将当前位置到10天后的位置设为1}
A2:=REF(TY,10)=LLV(TY,2*10+1);{10天前的收盘价等于21天内最低价}
VB2:=FILTER(A2,10); {过滤10天内连续出现的信号}
C2:=BACKSET(VB2,10+1);{将当前位置到11天前的位置设为1}
LD:=FILTER(C2,10);{当出现C2后,10天后的数据不予记录}
A:=REF(C,BARSLAST(HD));{设值上次高点位置}
B:=REF(C,BARSLAST(LD));{设值上次低点位置}
T11:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD);{上升波段回调不创新低没新高}
T21:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);{下降波段反弹不创新高没新低}
波峰:IF(T11,A,A),COLORFF00FF,POINTDOT;{符合T1条件,高位线为紫色点状线}
STICKLINE(T11,A,A,9,0),COLORFF00FF;{高位画横线}
波谷:IF(T21,B,B),COLOR80FF00,POINTDOT;{符合T2条件,高位线为绿色点状线}
STICKLINE(T21,B,B,9,0),COLOR80FF00;{低位画横线};
{假阳真阴}
均价:=AMOUNT/VOL/100;
假阳:=C>O AND REF(C,1)>均价 AND C>均价 AND C<300 ;
STICKLINE(假阳,O,C,1,0)COLORLICYAN;
标志阴:=REF(C,1)/C>1.04;
STICKLINE(标志阴,O,C,1,0)COLORWHITE;

{假阴真阳}
假阴:=O>C AND 均价>REF(C,1) AND C>MA(C,5);
STICKLINE(假阴,O,C,1,0),COLORRED;

平量:=V>REF(V,1)*0.95 AND V<REF(V,1)*1.05 ;
无量平量穿越:=WINNER(C)-WINNER(O)>=0.2 AND 平量;
STICKLINE(无量平量穿越,O,C,1,0)COLORBLUE;
倍阴柱:=VOL>=REF(V,1)*1.9 AND C<REF(C,1) ;
STICKLINE(倍阴柱,O,C,1,0)COLORBROWN;
{涨跌停价格显示};
AA:=(C-REF(C,1))/REF(C,1)*100;
ZS:=(NAMELIKE('ST') OR NAMELIKE('*ST') OR NAMELIKE('S')) AND AA>=4.945;
DS:=(NAMELIKE('ST') OR NAMELIKE('*ST') OR NAMELIKE('S')) AND AA<=-4.945;
涨停价:IF(ZS,REF(C,1)*1.05,REF(C,1)*1.1),NODRAW,COLORRED;
跌停价:IF(DS,REF(C,1)*0.95,REF(C,1)*0.9),NODRAW,COLORGREEN;
第一组:=REF(H-REF(L,1),1);
第二组:=REF(REF(H,1)-REF(L,2),1);
第三组:=REF(REF(H,2)-REF(L,3),1);
平均值:=(第一组+第二组+第三组)/3;
上线:=平均值+REF(L,1),NODRAW;
平均波动:=REF(((H-L)+(REF(H,1)-REF(L,1))+(REF(H,2)-REF(L,2)))/3,1);
下线:=上线-平均波动,NODRAW;
中线:=(上线+下线)/2,NODRAW;
D_2R3_ZQ1:=CURRBARSCOUNT<2;
D_2R3_ZQ2:=CURRBARSCOUNT<13;
D_2R3X1:=IF(D_2R3_ZQ1, 上线, DRAWNULL);
D_2R3X2:=IF(D_2R3_ZQ1, 中线, DRAWNULL);
D_2R3X3:=IF(D_2R3_ZQ1, 下线, DRAWNULL);
D_2R3X11:IF(D_2R3_ZQ2,D_2R3X1,DRAWNULL);
D_2R3X12:IF(D_2R3_ZQ2,D_2R3X2,DRAWNULL);
D_2R3X13:IF(D_2R3_ZQ2,D_2R3X3,DRAWNULL);
STICKLINE(D_2R3_ZQ2 ,D_2R3X11,D_2R3X11,20,-1),COLORLIBLUE;
STICKLINE(D_2R3_ZQ2 ,D_2R3X12,D_2R3X12,20,-1),COLORYELLOW;
STICKLINE(D_2R3_ZQ2 ,D_2R3X13,D_2R3X13,20,-1),COLORWHITE;
DRAWTEXT(D_2R3_ZQ1,D_2R3X11,' 上线'),COLORLIBLUE;
DRAWTEXT(D_2R3_ZQ1,D_2R3X12,' 中线'),COLORMAGENTA;
DRAWTEXT(D_2R3_ZQ1,D_2R3X13,' 下线'),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND C<上线 AND C>中线 AND C<=O,0.85,0.95,0,'【高不过,必回落】'),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND C<中线 AND C>下线 AND C<=O,0.85,0.95,0,'【中线破,快逃脱】'),COLORWHITE;
DRAWTEXT_FIX( ISLASTBAR AND C<下线 , 0.85,0.95,0,'【下线破,把路夺】'),COLORWHITE;
DRAWTEXT_FIX( ISLASTBAR AND C>上线 AND C>O , 0.85,0.95,0,'【上线过,可做多】'),COLORWHITE;
DRAWTEXT_FIX( ISLASTBAR AND C>中线 AND C<上线 AND C>O, 0.85,0.95,0,'【中线过,分强弱】'),COLORWHITE;
DRAWTEXT_FIX( ISLASTBAR AND C>下线 AND C<中线 AND C>O, 0.85,0.95,0,'【中线下,走势弱】'),COLORWHITE;
{涨跌停K线标识};
ST:=NAMELIKE('ST')=1 OR NAMELIKE('*ST')=1 OR NAMELIKE('SST')=1
OR NAMELIKE('S*ST')=1 OR NAMELIKE('S ST')=1;
涨停:=C=ZTPRICE(REF(CLOSE,1),0.1) OR (C/REF(C,1)>1.0495 AND ST);
跌停:=REF(C,1)/C>1.0995 OR (REF(C,1)/C>1.0495 AND ST);
STICKLINE(涨停,C,O,3,0),COLORMAGENTA;
STICKLINE(跌停,C,O,3,0),COLORGREEN;
DRAWICON(H=ZTPRICE(REF(CLOSE,1),0.1) AND C!=H,L*0.965,15);
STICKLINE(C/REF(C,1)>=1.04 OR C/REF(C,1)<=0.96,(C+O)/2,(C+O)/2,2,1),COLORLIBLUE;{中分线};
STICKLINE(C/REF(C,1)>=1.04 OR C/REF(C,1)<=0.96,(MAX(O,C)-MIN(O,C))*2/3+MIN(O,C),(MAX(O,C)-MIN(O,C))*2/3+MIN(O,C),2,1),COLORLIBLUE;{上三一线};
STICKLINE(C/REF(C,1)>=1.04 OR C/REF(C,1)<=0.96,(MAX(O,C)-MIN(O,C))/3+MIN(O,C),(MAX(O,C)-MIN(O,C))/3+MIN(O,C),2,1),COLORLIBLUE;{下三一线};

缠论飘带 荆州量学金融终端主图六 通达信指标 源码 贴图

点击下载缠论飘带 荆州量学金融终端主图六 通达信指标 源码 贴图

  • 股票公式精品推荐
  • 03-02精品指标喜欢的下 波段抓妖 通达信主图
  • 03-02金钻指标 特殊MACD源码 通达信副图指标
  • 03-02精品实战指标 精准短线出击 通达信副图
  • 03-02精准指标 精准提前必涨停3 通达信副图+
  • 03-02希望大家能抓到大牛 寻牛 通达信副图/选
  • 03-02修改后通达信版本《通达信三角洲预测》
  • 03-02指标可叠加于任何主图 限售股解禁公式
  • 03-02捕捉到的黑马很多 铁血教官之小样还藏+
  • 03-02获取短线暴利 绝对原创——极速反转短线
  • 03-02逢低买入 等待拉升 强庄主图标识代码 通
  • 03-02在网上找到的指标 一战成名 通达信主图
  • 03-01金钻指标原创不喜勿下 又见金底 通达信
  • 03-01让你坐上头等舱 K线发射成功 通达信主图
  • 03-01及时坐上头等仓 K线发射成功 通达信选股
  • 03-01这个指标需要较高的操作技术 配套指标,
  • 03-01实战指标 【高抛低吸T+0】 精准背离 通
  • 03-01今天借花献佛 公开这个公式源码 爆涨公
  • 02-28狗年旺旺旺 暴力杀庄 通达信副图指标 源
  • 02-28股市没烦恼!量价指标 通达信副图指标
  • 02-28精准提前抄底指标 成交量提前预警抓涨停
  • 02-28指标挺好的 吊打止损优化公式 通达信主
  • 02-28获取短线暴利 原创——急速反转买 通达
  • 02-28恭喜、恭喜、赢钱笑微微 跟你,明日就有
  • 02-28祝投资顺利 跟你,明日就有起!通达信选
  • 02-28二个选股公式源码 超级大黑马选股公式
  • 02-28用了你才知道好 一线游资建仓指标公式
  • 02-27真正的高手都是买在阴线 卖在阳线 阴线
  • 02-27金钻指标 【牛、妖股`主升浪利器】薛斯
  • 02-27以投资的角度出发 黄蓝带主图 大局掌控
  • 02-27具体交易要结合大盘和个股情况来看 一个
  • 学了还要学
    股票公式火热下载榜
    看了还想看