»查看更多分类股票软件

大智慧强势暴涨暴跌画线显示斜率值主图指标 源码 贴图

发布时间:2021-10-04 08:57:00  点击:

大智慧强势暴涨暴跌画线显示斜率值主图指标 源码 贴图

大智慧强势暴涨暴跌画线显示斜率值主图指标 源码 贴图

大智慧强势暴涨暴跌画线显示斜率值主图指标 源码 贴图


INPUT: 起点(5,1,9999,1),终点(1,0,9999,1);
ma(c,5);
A1:=backset(barstatus=2,起点); {原作者:奉然}
A2:=backset(barstatus=2,终点);
H1:VERTLINE(CROSS(A1 ,0.5 ) , 1),Color000fff;
H2:VERTLINE(CROSS(A2 ,0.5 ) , 1),Color00ff00;
{幅度:=(c-REF(c ,BARSLAST( CROSS(A1 ,0.5 )) ))/REF(c ,BARSLAST( CROSS(A1 ,0.5 )) )*100;}
幅度:=(REF(c ,BARSLAST( CROSS(A2 ,0.5 )) )-REF(c ,BARSLAST( CROSS(A1 ,0.5 )) ))/REF(c ,BARSLAST( CROSS(A1 ,0.5 )) )*100;{www.gpxiazai.com}
斜率:=ATAN(幅度/((起点-终点) ))*180/3.1416;
斜边:=SQRT(POW(幅度 ,2 )+POW(起点-终点 ,2 ) );
伸长:=SUM(幅度 ,0 );
震荡率:=伸长/斜边;
强势暴张:=斜率>60 ;
B1:=REF(H ,BARSLAST(CROSS(起点+(起点-终点)/2 ,0.5 ) ) );
A5:=backset(barstatus=2,起点);
A6:=backset(barstatus=2,终点);
DRAWLINE(a5,ma(c,5) ,a6 AND CROSS(A2 ,0.5 ) ,ma(c,5),1),Color000fff,linethick2;
DRAWTEXTABS(250,10,'斜率:'+NUMTOSTRN(斜率,2)),Color000fff,linethick5;
DRAWTEXT(斜率>=60 AND CROSS(A2 ,0.5 ),H*1.01 ,'强势暴张' );
DRAWTEXT(斜率>=45 AND 斜率<60 AND CROSS(A2 ,0.5 ),H*1.01 ,'强势大涨' );
DRAWTEXT(斜率<=-40 AND CROSS(A2 ,0.5 ),H*1.01 ,'弱势暴跌' );
DRAWTEXT(斜率<=-20 AND 斜率>-40 AND CROSS(A2 ,0.5 ),H*1.01 ,'弱势大跌' );

 
0

本站提示:股市有风险,入市请慎重,资料由股票下载网整理收集

下载必看(为了保障您的权益,请在下载资源前看清楚相关说明)

  • ›› 指标不属于投资资讯产品和推股软件,指标旨在辅助大家提高投资胜率参考而研发,仅供参考学习研究之用,不构成投资建议或未来保证,依此操作买卖,盈亏自负。
  • ›› 指标页面宣传的收益仅代表指标信号成立后的历史收益,收益具有不确定性,不保证未来达到同等收益。
  • ›› 您所下载的软件由股票下载网网络收集发布,不保证提供的下载资源的准确性、安全性和完整性。请自行谨慎甄别软件相关描述后再下载,股票下载网不保障和承担使用该软件投资带来的一切损失。
  • ›› 该软件仅供学习和研究使用,不得用于商业或者非法用途。本站对于提供下载的指标、软件、资讯等不拥有任何权利,其版权归该下载资源的合法拥有者所有,如有侵犯您的版权,请查看《股票下载网的侵权处理流程》,本站将于五个工作日内移除相关内容,同时要求用户在23小时内删除从本站下载的文件。
  • ›› 如果您发现下载链接错误,请点击报告错误谢谢!

找不到你要的公式?给我们建议