股票下载网共有股票软件:7218 个 | 股票公式:32745 个 | 文章:3812 篇 | 总容量:71.001 G | 总下载:7554631 次 | 今日更新:0

大卫均线 大智慧指标 源码 贴图 值得拥有的指标

简介: DRAWGBKLAST(v>1,STRIP(RGB(0,0,205),RGB(60,179,113),0));DRAWTEXTREL(10,50,'大卫均线决策系统 '),linethick1,colorWhite;
标签:  来源:www.gpxiazai.com   发布时间:2018-09-13 点击:

 DRAWGBKLAST(v>1,STRIP(RGB(0,0,205),RGB(60,179,113),0));

DRAWTEXTREL(10,50,'大卫均线决策系统 '),linethick1,colorWhite;
DRAWTEXTREL(10,10,'所属板块:'+BKNAME),COLORFF00FF;
四53:eMA(CLOSE,453),LINETHICK2, ColorD9D919 ;
压l:(SMA(HIGH,21,2) * 1.05),LINETHICK2,colorFFFFFF;
支c:(SMA(LOW,21,2) * 0.95),LINETHICK2,color00FF00;
贰②:=MA(CLOSE,26);
压:贰② + 2*STD(CLOSE,26),colorwhite,POINTDOT,linethick3;
支:贰② - 2*STD(CLOSE,26),colorwhite,POINTDOT,linethick3;
M17:eMA(CLOSE,17),colorred,linethick2;
生命:eMA(CLOSE,453), Colorwhite ;
九九:eMA(CLOSE,99),colorred;
M144:eMA(CLOSE,144),LINETHICK2,Coloryellow ;

EMA6:MA(C,6),COLORyellow;
EMA18:=MA(C,18);

张嘉仪线:=WMA(CLOSE,14);
ma34:=ma(c,34);
ma55:=ma(c,55);
多空50:eMA(CLOSE,50),colorwhite;
强弱:ema(cost(60),10),COLOR428899;

半年:MA(C,120),CIRCLEDOT,colorgreen;

张嘉仪线:=WMA(CLOSE,14);
ma34:=ma(c,34);
ma55:=ma(c,55);

STICKLINE(close>open,O,C,9,0 ),COLOr6666cc;
STICKLINE(close>open,O,C,6 ,0 ),COLOR7777dd;
STICKLINE(close>open,O,C,2.4 ,0 ),COLOR8888ee;
STICKLINE(close>open,O,C,1.1 ,0 ),COLOR9999ff;
STICKLINE(close>open,open,low,0.5,0 ),COLOR1199ff;
STICKLINE(close>open,close,HIGH,0.5 ,0 ),COLOR1199ff;
STICKLINE(open>=close,close,low,0.5 ,0 ),COLORcccccc;
STICKLINE(open>=close,open,HIGH,0.5 ,0 ),COLORcccccc;

STICKLINE(cross(ma(c,1),ma(c,9)),CLOSE,OPEN,8,0),colorred;
STICKLINE(cross(ma(c,1),ma(c,9)),HIGH,LOW,0.8,0),COLORred;
STICKLINE(cross(ma(c,1),ma(c,55)),CLOSE,OPEN,6,0),COLORred;
STICKLINE(cross(ma(c,1),ma(c,55)),HIGH,LOW,0.6,0),COLORred;
STICKLINE(cross(ma(c,1),ma(c,23.5)),CLOSE,OPEN,7,0),COLORyellow;
STICKLINE(cross(ma(c,1),ma(c,23.5)),HIGH,LOW,0.7,0),COLORyellow;
STICKLINE(cross(ma(c,1),ma(c,120)),CLOSE,OPEN,5,0),COLORMAGENTA;
STICKLINE(cross(ma(c,1),ma(c,120)),HIGH,LOW,0.5,0),COLORMAGENTA;
中线a:=COUNT(CLOSE<EMA18,5)=4 AND CLOSE/EMA18>1.004 AND CROSS(CLOSE,EMA18) AND EMA18>=REF(EMA18,1);

DRAWTEXT(中线a,LOW*0.858,'18均买'),ALIGN1,COLORRED;

股价平台1:=IF(CLOSE>10,1.004,0);
股价平台2:=IF(CLOSE>8 AND CLOSE<=10,1.006,0);
股价平台3:=IF(CLOSE>6 AND CLOSE<=8,1.008,0);
股价平台4:=IF(CLOSE>4 AND CLOSE<=6,1.010,0);
股价平台5:=IF(CLOSE>2 AND CLOSE<=4,1.012,0);
股价平台6:=IF(CLOSE<=2,1.015,0);
股价平台:=股价平台1+股价平台2+股价平台3+股价平台4+股价平台5+股价平台6;
中线b:=(CLOSE-REF(CLOSE,18))/18+EMA18*股价平台;
DRAWTEXT((CROSS(CLOSE,中线b) AND BARSLAST(中线b)<89 AND BARSLAST(中线b)>5 AND CLOSE>REF(CLOSE,BARSLAST(中线b))),LOW*0.985,'加码】'),align1,coloryellow;

短线6:=EMA18>=REF(EMA18,1) AND CROSS(CLOSE,EMA6) AND CLOSE/EMA6>1.004;

DRAWTEXT(短线6,LOW*0.89,'6均买'),ALIGN1,COLORWHITE;

暴大量:=CLOSE>REF(CLOSE,2);
暴大量买入:=FILTER(暴大量,5);
超短:=暴大量买入 and EMA18>=REF(EMA18,1) and EMA6>=REF(EMA6,1);

DRAWTEXT(超短,LOW*0.93,'超短'),align1,COLORYELLOW;

EMA13:=EMA(C,13);

MA18:=MA(CLOSE,18);

EMA34:=EMA(C,34);
EMA55:=EMA(C,55);
EMA89:=EMA(C,89);

EMA120:=EMA(C,120);

AR1:=EMA55>EMA34 AND EMA34>EMA13;
AR2:=BARSLAST((C-EMA13)/EMA13*100<-6);
AR3:=EMA13>=REF(EMA13,2);
AR4:=COUNT(CROSS(C,EMA13),AR2)=1;
AR5:=AR1 AND AR2 AND AR3 AND AR4;
AR6:=AR5 AND FILTER(AR5,10);
DRAWTEXT(AR6,L-0.309,'启动'),ALIGN1,COLORYELLOW;
STICKLINE(AR6,O,C,6,1),LINETHICK2,COLORYELLOW;
BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;
BR2:=ABS((EMA13-EMA34)+(EMA34-EMA55))/C<0.2;
BR3:=C>EMA55 AND (REF(C,1)<REF(EMA55,1) OR REF(C,2)<REF(EMA55,2) OR REF(C,3)<REF(EMA55,3) OR REF(C,4)<REF(EMA55,4) OR REF(C,5)<REF(EMA55,5));
BR4:=BR1 AND BR2 AND BR3;
DRAWTEXT(BR4 AND FILTER(BR4,10),L-0.09,'上升'),ALIGN1,COLOR00C5FF;
STICKLINE(BR4 AND FILTER(BR4,10),O,C,6,1),LINETHICK2,COLOR00C5FF;
CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;
CR2:=V>MA(V,5)*0.6;
CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;
CR4:=ABS(EMA34-EMA55)/EMA55<0.03;
CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);
CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);
STICKLINE(CR6,O,C,6,1),LINETHICK2,COLORF00FF0;
DRAWTEXT(CR6,L-0.09,'涨升'),ALIGN1,COLORF00FF0;
DR1:=EMA13>EMA34 AND EMA34<EMA55;
DR2:=BARSLAST(CROSS(C,EMA55) );
DR3:=H=HHV(H,DR2);
DR4:=BARSLAST(DR3);
DR5:=COUNT(O>C AND C<REF(C,1) AND C>EMA55 AND BETWEEN((C-EMA55)/EMA55,0,0.02),DR4)=1;
DR6:=C>REF(C,1) ;
DR7:= DR1 AND DR5 AND DR6 ;
DR8:=DR7 AND FILTER(DR7 ,10);
DRAWTEXT(DR8,L-0.09,'出击'),ALIGN1,COLORwhite;{
STICKLINE(DR8,O,C,6,1),LINETHICK2,COLORD6BA63;}
ER:=BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55);
DRAWTEXT(ER,L-0.09,'金叉'),ALIGN1,COLOR0099FF;{
STICKLINE(ER,O,C,6,1),LINETHICK2,COLOR0099FF;}
FR:=BARSLAST(REF(CROSS(EMA34,EMA13),1)) AND CROSS(EMA13,EMA34);
DRAWTEXT(FR,L-0.09,'加仓'),ALIGN1,COLORWHITE;{
STICKLINE(FR,O,C,6,1),LINETHICK2,COLORWHITE;};
HR2:=EMA13>=REF(EMA13,3) AND EMA34>=REF(EMA34,1) AND EMA55>=REF(EMA55,1) AND CROSS(C,EMA13) AND CROSS(C,EMA34) AND CROSS(C,EMA55);
DRAWTEXT(HR2 AND FILTER(HR2,10),L-0.01,'推进'),ALIGN1,COLORred;

bbg:=MA(LOW,5)*(1-5/100);
a11g:=(HHv(bbg,5)+llv(bbg,5))/2;
DRAWICON(cross(a11g,l) and a11g>ref(a11g,1) ,l*0.95,1),ALIGN1;
{多空密码}
Var2ed:=(3*CLOSE+LOW+OPEN+HIGH)/6;
Var3ed:=(20*Var2ed+19*REF(Var2ed,1)+18*REF(Var2ed,2)+17*REF(Var2ed,3)+16*REF(Var2ed,4)+15*REF(Var2ed,5)+14*REF(Var2ed,6)+13*REF(Var2ed,7)+12*REF(Var2ed,8)+11*REF(Var2ed,9)+10*REF(Var2ed,10)+9*REF(Var2ed,11)+8*REF(Var2ed,12)+7*REF(Var2ed,13)+6*REF(Var2ed,14)+5*REF(Var2ed,15)+4*REF(Var2ed,16)+3*REF(Var2ed,17)+2*REF(Var2ed,18)+REF(Var2ed,20))/210;
Var4ed:=MA(Var3ed,13);
Var5ed:=EMA(MA(CLOSE,3),34);
DRAWTEXT(FILTER(IF(Var3ed<Var5ed,Var3ed<=1.015*Var4ed,Var3ed<=1.005*Var4ed),10),(Var3ed+Var4ed)/2,'空'),ALIGN1,colorred;

{古币均线}

rVAR2:=(HIGH+LOW+CLOSE*2)/4;
rVAR3:=EMA(rVAR2,21);
rVAR4:=STD(rVAR2,21);
rVAR5:=((rVAR2-rVAR3)/rVAR4*100+200)/4;
rVAR6:=(EMA(rVAR5,5)-25)*1.56;
AK:=EMA(rVAR6,2)*1.22;
AD:=EMA(AK,2);
AJ:=3*AK-2*AD;
买进:DRAWICON(CROSS(AK,AD),L*0.995,7),ALIGN1;

DRAWTEXT(CROSS(张嘉仪线,C) AND INDEXC>MA(INDEXC,13) AND 张嘉仪线>REF(张嘉仪线 ,1) AND V<REF(V,1) AND 张嘉仪线>ma34 ,L*0.97,'买入'),align1,COLORRED;
LCg:=REF(CLOSE,1);
RSIg:=SMA(MAX(CLOSE-LCg,0),6,1)/SMA(ABS(CLOSE-LCg),6,1)*100;
低吸:=CROSS(RSIg,11);

DRAWTEXT(低吸,l-0.05,'低吸'),colorwhite;
varg7:=ema(amount/vol/100,3);
varg8:=ema(varg7,88);
varg9:=ema(varg7,88)*0.85;
vara:=varg9*0.87;
varb:=low<vara and close>ref(close,1)*1.02;
drawtext(filter(varb,6),l-0.6,'关注'),align1,colorff00ff;

VarF:=(2*CLOSE+HIGH+LOW)/4;
Va4:=LLV(LOW,34);
Va5:=HHV(HIGH,34);
Va6:=EMA((VarF-Va4)/(Va5-Va4)*100,6);
Va7:=EMA(0.667*REF(Va6,1)+0.333*Va6,4);

DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(Va6>Va7,3) AND REF(LOW,1)=LLV(LOW,120) AND
CLOSE>OPEN,1,0),L-0.06,'小鱼'),align1,COLORYELLOW;
VARg12:=(HIGH - LOW);
VARg3:=ABS((OPEN - CLOSE));
VARg4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VARg5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VARg6:=((VARg3 / VARg12) * VOL);
DRAWTEXT((((((VARg6 > (MA(VOL,5) * 2)) AND 张嘉仪线>REF(张嘉仪线 ,1) AND (VARg6 >= VARg7)) AND (VARg6 >= VARg8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB)) ,L*0.90,'主力入'),align1,COLORYELLOW;
a:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*a+19*REF(a,1)+18*REF(a,2)+17*REF(a,3)+16*REF(a,4)+15*REF(a,5)+14*REF(a,6)
+13*REF(a,7)+12*REF(a,8)+11*REF(a,9)+10*REF(a,10)+9*REF(a,11)+8*REF(a,12)
+7*REF(a,13)+6*REF(a,14)+5*REF(a,15)+4*REF(a,16)+3*REF(a,17)+2*REF(a,18)+
REF(a,20))/211;
D2:=EMA(D1,2);
D3:=EMA(D2,2);
K1:=EMA(D3,2);
DRAWTEXT(CROSS(D1,K1),l-0.55,'大卫'),align1,colorwhite;

VARg1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;

DRAWTEXT(VARg1>9 AND V<REF(V,1) AND FILTER(VARg1<REF(VARg1,1),5),H*1.05,'洗盘'),align1,COLORYELLOW;
DRAWTEXT(VARg1>9 AND V>REF(V,1) AND FILTER(VARg1<REF(VARg1,1),5),H*1.04,'减仓'),align1,COLORGREEN;
DRAWTEXT(VARg1>20 AND FILTER(VARg1<REF(VARg1,1),5),H*1.03,'卖出'),align1,COLORYELLOW;

VARg2:=HHV(VARg1>20,10);
DRAWTEXT(FILTER(VARg1<-9 AND VARg1>REF(VARg1,1),18) AND V>REF(V,1),L*1.1,'反1弹'),align1,COLORRED;
DRAWTEXT(VARg1<-20 AND FILTER(VARg1> REF(VARg1,1),5),L*0.95,'抄1底'),align1,COLORYELLOW;
DRAWTEXT(VARg2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),H*1.1,'危险'),align1,COLORYELLOW;
A1:= WMA(CLOSE,22);
年线:=WMA(CLOSE,250);
B:= 张嘉仪线>A1 AND A1>ma55 AND ma55>ma34;
B1:= COUNT(B,2)=1 AND REF(ma55,1)<=REF(ma34,1);
VV2:= REF(CLOSE,1);
VV3:= SMA(CLOSE-VV2,6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;
DRAWTEXT(REF(VV3,1)>81 AND VV3<80,HIGH,'闪↓'),align1,COLOR00FFFF;

MAd5:=MA(C,6);
MAd20:=MA(C,21);
MAd90:=MA(C,89);
Y1:=BARSLAST(CROSS(MAd5,MAd20)) AND MAd5>MAd20;

Y2:=Y1 AND BARSLAST(CROSS(MAd5,MAd90));
Y3:=Y2 AND CROSS(MAd20,MAd90);


DRAWTEXT(Y3,L-0.45,'均穿1'),COLORWHITE,ALIGN1;


F0:=BARSLAST(CROSS(MA(C,5),MA(C,90)));
F1:=F0 AND
BARSLAST(CROSS(MA(C,20),MA(C,90)));
F2:=F1 AND CROSS(MA(C,5),MA(C,20)) AND
MA(C,20)>MA(C,90);
DRAWTEXT(F2,L-0.45,'均穿2'),COLORFF00FF,ALIGN1;


Vart10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);
增减力度:=Vart10*5;
DRAWTEXT(cross(0,增减力度),h*1.052,'涨啦'),align1,Colorwhite;

DRAWTEXT(CROSS(MA(CLOSE,13),C) AND INDEXC>MA(INDEXC,13) AND MA(CLOSE,13)>REF(MA(CLOSE,13) ,1) AND V<REF(V,1) AND MA(CLOSE,13)>MA(CLOSE,55) ,L*0.95,'17买'),ALIGN1,COLORRED,LINETHICK2;
DRAWTEXT(CROSS(CLOSE,(((C-REF(MA(CLOSE,20),1))/20+MA(CLOSE,13))*1.20)) AND MA(CLOSE,13)>REF(MA(CLOSE,13) ,1),H*1.04,'减仓'),ALIGN1,COLORGREEN,LINETHICK1;
VAR011:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;

VAR012:=HHV(VAR011>20,10);
DRAWTEXT(FILTER(VAR011<-9 AND VAR011>REF(VAR011,1),18),L*0.95,'反@弹'),align1,COLORRED;
DRAWTEXT(VAR011<-20 AND INDEXC<MA(INDEXC,13) AND FILTER(VAR011> REF(VAR011,1),5),L*0.93,'抄底'),COLORYELLOW,LINETHICK2;
DRAWTEXT(VAR011>9 AND FILTER(VAR011<REF(VAR011,1),5),H*1.06,'洗PA'),COLORGREEN,LINETHICK0;

VAR013:=IF(MA(CLOSE,13)>REF(MA(CLOSE,13),1),MA(CLOSE,13),0);
DRAWTEXT((IF(CLOSE>MA(CLOSE,13) AND OPEN<CLOSE,-0.1,0))AND((C-REF(C,1))/(REF(C,1))>0.061)AND (MA(CLOSE,13)=VAR013) AND (MA(CLOSE,1)>MA(CLOSE,13)) AND (VOL>REF(HHV(VOL,3),1)*2),L*0.98,'主力入'),ALIGN1,COLORWHITE;
LLX:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),68);
LLY:=EMA(CLOSE,10);
DRAWTEXT(CROSS(LLX,LLY),(LOW * 0.96),'回买'),ALIGN1,COLORWHITE;

mMA20:=MA(CLOSE,20);
mMA120:=MA(CLOSE,120);
mMA30:=MA(CLOSE,37);
mMAP:=MA(CLOSE,8);
mAA5:=MA(CLOSE,21);
MAA10:=MA(CLOSE,8);
MAA12:=MA(CLOSE,12);
MBB10:=((ATAN((MAA10 - REF(MAA10,1))) * 3.1416) * 10);
MBB12:=((ATAN((MAA12 - REF(MAA12,1))) * 3.1416) * 10);
MMA13:=MA(CLOSE,13);
MMVAR01:=((((OPEN + LOW) + HIGH) + CLOSE) / 4);
M中期大底:=LLV(LOW,30);
M短期底部0:=LLV(HIGH,30);
M短底:=EMA(MMVAR01,5);
MM支撑:=HHV(M短底,60);
M压力1:=HHV(LOW,20);
M压力:=SMA(LOW,5,1);
M中线:=MA(CLOSE,3);
DRAWTEXT(FILTER(((((HIGH > MM支撑) AND (CLOSE < MM支撑)) AND ((CLOSE / OPEN) > (0 - 1.06))) AND (CLOSE < OPEN)),5),(HIGH + 0.02),'逃'),COLORFFFF00;
M中轨道:=(MA(HIGH,15) * 1.05);
M天:=(MA(LOW,15) * 0.985);
M人:=(MA(LOW,15) * 0.96);
M地:=(((HIGH + LOW) + CLOSE) / 3);
MB1:=HHV(M地,(4 * 15));
MB6:=LLV(M地,(4 * 15));
MB7:=(MB1 - MB6);
MB8:=(MA(((M地 - MB6) / MB7),2) * 80);
MMVAR1:=(((CLOSE - LLV(LOW,100)) / (HHV(HIGH,100) - LLV(LOW,100))) * 200);
M飞龙顶底线1:=SMA(MMVAR1,3,1);
MMVAR2:=SMA(M飞龙顶底线1,3,1);
MMVAR3:=((3 * M飞龙顶底线1) - (2 * MMVAR2));
MMVAR4:=LLV(LOW,5);
MMVAR5:=HHV(HIGH,5);
MVAR6:=(EMA((((CLOSE - MMVAR4) / (MMVAR5 - MMVAR4)) * 100),4) * 2);
MVAR7:=EMA(((0.667 * REF(MVAR6,1)) + (0.333 * MVAR6)),2);
MVAR8:=((3 * MVAR6) - (2 * MVAR7));
MVAR9:=(POW(MA(CLOSE,5),2) + MA(CLOSE,5));
MVARA:=(POW(MA(LOW,5),2) + MA(LOW,5));
MVARB:=(POW(MA(HIGH,5),2) + MA(HIGH,5));
MVARC:=(((((MVAR9 - LLV(MVARA,64)) / (HHV(MVARB,64) - LLV(MVARA,64))) * 150) + 65) - 10);
MVARD:=((SMA(MVARC,3,1) * 1.5) - 100);
MVARE:=SMA(MVARD,3,1);
MVARF:=((3 * MVARD) - (2 * MVARE));
MVAR10:=(((HIGH + LOW) + (CLOSE * 2)) / 4);
MVAR11:=EMA(MVAR10,13);
MVAR12:=STD(MVAR10,13);
MVAR13:=(((MVAR10 - MVAR11) * 100) / MVAR12);
MVAR14:=EMA(MVAR13,5);
MVAR15:=EMA(MVAR14,13);
MVAR16:=((EMA(MVAR14,13) + 200) - 100);
MVAR17:=EMA(MVAR16,10);
MVAR18:=((3 * MVAR16) - (2 * MVAR17));
MVAR19:=(((M飞龙顶底线1 + MVAR6) + MVARD) + MVAR16);
MVAR1A:=(((MMVAR2 + MVAR7) + MVARE) + MVAR17);
MVAR1B:=(((MMVAR3 + MVAR8) + MVARF) + MVAR18);
MVAR1C:=(((HIGH + LOW) + CLOSE) / 3);
MVAR1D:=((AMOUNT / VOL) / 100);
MVAR1E:=((SUM(AMOUNT,5) / SUM(VOL,5)) / 100);
MVAR1F:=((MVAR1C - MA(MVAR1C,34)) / (0.015 * AVEDEV(MVAR1C,34)));
MVAR21:=((((HIGH + LOW) + CLOSE) + MVAR1C) / 4);
MVAR22:=EMA(MVAR21,24);
MVAR23:=STD(MVAR21,24);
MVAR24:=(((MVAR21 - MVAR22) / MVAR23) * 100);
MVAR25:=((MVAR1C - MA(MVAR1C,24)) / (0.015 * AVEDEV(MVAR1C,24)));
MVAR26:=EMA(MVAR24,5);
MVAR27:=((MVAR1D - MA(MVAR1D,21)) / (0.015 * AVEDEV(MVAR1D,21)));
MVAR28:=((MVAR1E - MA(MVAR1E,90)) / (0.015 * AVEDEV(MVAR1E,90)));
MVAR29:=(((((((MVAR28 + MVAR27) + MVAR26) + MVAR25) + MVAR1F) / 5) + 165) / 4);
MVAR2A:=(((((MVAR19 + MVAR1A) + (MVAR1B * 30)) / 32) / 5) - 15);
MVAR2B:=(((MVAR29 + MVAR2A) / 2) / 1.1);
MVAR2C:=MVAR2B;
M短线:=MA(MVAR2C,26);
MMID:=(M短线 + (2 * STD(MVAR2C,26)));
MUPPER:=(M短线 - (2 * STD(MVAR2C,26)));
MLOWER:=IF((MVAR2C > M短线),M短线,MVAR2C);
MXY:=MA(CLOSE,5);
MA5:=MA(CLOSE,80);
M短期底部:=(LLV(HIGH,30) * 0.93);
MA80:=LLV(HIGH,30);
M短期底部2:=SMA(CLOSE,2,1);
M趋势:=(MA(LOW,10) * 0.96);
M趋:=(EMA(OPEN,107) * 0.897);
M超跌位2:=MA(CLOSE,15);
MGF:=MA(CLOSE,10);
MMAN:=(SMA(HIGH,21,2) * 1.05);
M上1:=(HHV(M短底,60) * 0.92);
M压力2:=(SMA(HIGH,21,2) * 1.035);
M阻挡线:=(SMA(LOW,21,2) * 0.96);
M下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
MRSV:=SMA(M下档线,3,1);
MK:=SMA(MRSV,3,1);
MD:=((3 * MRSV) - (2 * MK));
MJ:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
MVAR2P:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
MVAR3P:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
MVAR4P:=(((MJ + (2 * MVAR2P)) + (3 * MVAR3P)) / 6);
MVAR5P:=MA(MVAR4P,3);
MVAR6P:=(((CLOSE - LLV(LOW,34)) / (HHV(HIGH,34) - LLV(LOW,34))) * 100);
MRSV12:=SMA(MVAR6P,3,1);
MK12:=SMA(MRSV12,3,1);
MD12:=((3 * MRSV12) - (2 * MK12));
MJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
MRSV24:=SMA(MJ12,3,1);
MK24:=SMA(MRSV24,3,1);
MD24:=((3 * MRSV24) - (2 * MK24));
MJ24:=IF(CROSS(MD,MD24),LOW,REF(LOW,BARSLAST(CROSS(MD,MD24))));
M压力位:=IF(CROSS(MD24,MD),HIGH,REF(HIGH,BARSLAST(CROSS(MD24,MD))));
MM支撑位:=IF((CLOSE >= MA(CLOSE,20)),80,50);
MU2L:=IF((CLOSE >= MA(CLOSE,20)),50,20);
ML2L:=IF(((MD < MM支撑位) AND (REF(MD,1) >= MM支撑位)),HHV(REF(HIGH,1),(BARSLAST(((MD >= MM支撑位) AND (REF(MD,1) < MM支撑位))) - 1)),REF(HHV(REF(HIGH,1),(BARSLAST(((MD >= MM支撑位) AND (REF(MD,1) < MM支撑位))) - 1)),BARSLAST(((MD < MM支撑位) AND REF(MD,1)))));
MRH1:=IF((HIGH > ML2L),LOW,REF(LOW,BARSLAST((HIGH > ML2L))));
MRH4:=IF((HIGH > ML2L),MD,REF(MD,BARSLAST((HIGH > ML2L))));
MRH42:=IF((((HIGH > MRH1) AND (MD < MRH4)) AND (MD < MD24)),HIGH,REF(HIGH,BARSLAST((((HIGH > MRH1) AND (MD < MRH4)) AND (MD < MD24)))));
MRH5:=IF(((MD > MU2L) AND (REF(MD,1) <= MU2L)),LLV(REF(LOW,1),(BARSLAST(((MD <= MU2L) AND (REF(MD,1) > MU2L))) - 1)),REF(LLV(REF(LOW,1),(BARSLAST(((MD <= MU2L) AND (REF(MD,1) > MU2L))) - 1)),BARSLAST(((MD > MU2L) AND REF(MD,1)))));
MRL1:=IF((LOW < MRH5),HIGH,REF(HIGH,BARSLAST((LOW < MRH5))));
MRL4:=IF((LOW < MRH5),MD,REF(MD,BARSLAST((LOW < MRH5))));
MRL42:=IF((((LOW < MRL1) AND (MD > MRL4)) AND (MD > MD24)),LOW,REF(LOW,BARSLAST((((LOW < MRL1) AND (MD > MRL4)) AND (MD > MD24)))));
M长期底部:=LLV(HIGH,30);
DRAWTEXT(FILTER(((((MRL42 = MJ24) AND (CLOSE > OPEN)) AND (CLOSE > M长期底部)) AND (LOW <= MJ24)),20),(LOW - 0.12),'底成'),COLOR0EABFF;
MRL5:=(SMA(HIGH,5,2) * 1.05);
M上:=(SMA(LOW,5,2) * 0.96);
M下:=SMA(LOW,2,1);
M中:=(((((3 * CLOSE) + HIGH) + LOW) + OPEN) / 6);
MX1:=EMA(M中,10);
MX2:=REF(MX1,1);
MX3:=((REF(HIGH,1) + REF(LOW,1)) / 2);
MX4:=(MA(CLOSE,21) + (2 * STD(CLOSE,21)));
MX5:=REF(CLOSE,1);
MX6:=((SMA(MAX((CLOSE - MX5),0),7,1) / SMA(ABS((CLOSE - MX5)),7,1)) * 100);
MX7:=CROSS(79,MX6);
MX8:=FILTER(MX7,4);
MX9:=MA(CLOSE,115);
MVAR001:=EMA(CLOSE,8);
M飞龙顶底线:=EMA(MVAR001,20);
MVAR002:=CROSS(MVAR001,M飞龙顶底线);
MVAR003:=(MVAR001 < MA(CLOSE,20));
MVAR004:=(((HHV(HIGH,36) - CLOSE) / (HHV(HIGH,36) - LLV(LOW,36))) * 100);
MVAR005:=SMA(MVAR004,5,1);
MVAR006:=SMA(MVAR005,8,1);
MVAR007:=(CROSS(MVAR005,MVAR006) AND (MVAR006 < 5));
MVAR008:=((CLOSE > (LLV(CLOSE,60) + (0.3 * LLV(CLOSE,60)))) AND MVAR007);
MVAR009:=IF((CLOSE > 1000),MVAR007,MVAR008);
MVAR00F:=CROSS(MX1,MX2);
MA115:=MVAR00F;
M低买:=(MVAR002 AND MVAR003);
黑马起步:=MVAR009;
DRAWTEXT(MX8,(HIGH * 1.03),'出货'),align1,COLOR9000F5;
DRAWTEXT((黑马起步 > 0),(HIGH * 1.04),'逃命'),align1,COLORFF0000;
逃遁:=(SMA(HIGH,21,2) * 1.05);
阻挡:=(SMA(LOW,21,2) * 0.94);
黑马:=M低买 > 0 AND (MX1 - REF(MX1,1)) > 0 AND HIGH < M压力位 AND HIGH < MX9 AND (MX2 - REF(MX2,1)) > 0;

DRAWTEXT(FILTER(((((((((CLOSE / OPEN) > 1.03) AND ((M超跌位2 - REF(M超跌位2,1)) > 0)) AND ((CLOSE - REF(CLOSE,1)) > 0)) AND (HIGH < M压力1)) AND (CLOSE < M压力1)) AND ((M压力2 - REF(M压力2,1)) > 0)) AND (CLOSE < MMAN)),3),LOW,'击T'),align1,COLORwhite;
DRAWTEXT((((((M低买 > 0) AND ((MX1 - REF(MX1,1)) > 0)) AND (HIGH < M压力位)) AND (HIGH < MX9)) AND ((MX2 - REF(MX2,1)) > 0)),LOW,'黑马'),align1,COLOR00FF00;
DRAWTEXT(FILTER((((((((MMA20 - REF(MMA20,1)) > 0) AND (HIGH < MM支撑)) AND ((MAA10 - REF(MAA10,1)) > 0)) AND (HIGH < M压力1)) AND (VOL >= REF(VOL,1))) AND CROSS(CLOSE,MMA20)),57),LOW,'突破生命线'),align1,COLOR0000FF;
DRAWTEXT((((((((CROSS(CLOSE,MMA20) AND (HIGH < M压力位)) AND (OPEN < MMA20)) AND (HIGH < MM支撑)) AND ((MMAN - REF(MMAN,1)) > 0)) AND ((MX1 - REF(MX1,1)) > 0)) AND (MD < 63)) AND ((MMA20 - REF(MMA20,1)) > 0)),(high+0.105),'大●牛'),align1,COLORred;

DRAWTEXT((((((CROSS(MVAR2C,M短线) AND ((CLOSE - REF(HIGH,1)) > 0)) AND ((M中线 - REF(M中线,1)) > 0)) AND (HIGH <= M压力1)) AND (CLOSE < MMA20)) AND (LOW <= M中线)),(LOW - 0.06),'关注'),COLOR00FF00;
DRAWTEXT((((CROSS(MVAR2C,MUPPER) AND (HIGH < M压力1)) AND ((MXY - REF(MXY,1)) > 0)) AND (HIGH < MM支撑)),LOW,'买'),COLORFFFFFF;

DRAWTEXT(((((LOW <= M上) AND (HIGH >= M短期底部)) AND (CLOSE >= M长期底部)) AND ((CLOSE / OPEN) > 1.03)),(LOW - 0.08),'抄★底'),align1,COLOR0000FF;
DRAWTEXT(FILTER((((((LOW <= M阻挡线) AND ((MMA20 - REF(MMA20,1)) > 0)) AND (OPEN <= M上1)) AND (HIGH > M上1)) AND (CLOSE > M阻挡线)),5),high,'涨10%'),align1,COLORFFFFFF;
DRAWTEXT(FILTER((((((MB8 <= 1) AND (LOW <= 阻挡)) AND (CLOSE > OPEN)) AND (LOW <= M中期大底)) AND (CLOSE >= M长期底部)),3),(LOW - 0.08),'短抄E'),align1,COLORA100FF;
DRAWTEXT((((CROSS(MD,0) AND (HIGH < M压力位)) AND (MVAR5P <= (0 - 7))) AND (CLOSE < MXY)),(LOW - 0.11),'半仓'),align1,COLORFFFF00;
DRAWTEXT(FILTER((((CROSS(M趋势,M趋) AND (HIGH < MA5)) AND (HIGH < M压力1)) AND LLV(LOW,0)),10),LOW,'果断买'),align1,COLOR668800;

DRAWTEXT(FILTER(((CROSS(M中线,M人) AND (LOW <= M人)) AND (CLOSE >= M人)),4),(LOW - 0.06),'买M'),COLORwhite;
DRAWTEXT(FILTER(((((LOW <= MA80) AND (CLOSE > MA80)) AND (CLOSE > OPEN)) AND (M短期底部2 <= MA80)),8),LOW,'底'),align1,COLORwhite;
DRAWTEXT(FILTER((((((MA115 AND (CLOSE < M压力位)) AND ((M人 - REF(M人,1)) > 0)) AND ((MX1 - REF(MX1,1)) > 0)) AND (HIGH < M上1)) AND ((CLOSE / OPEN) > 1.03)),5),LOW,'●买'),align1,COLOR93EE7D;

DRAWTEXT(((CROSS(MMA20,M压力位) AND (LOW <= MMA20)) AND ((MMA20 - REF(MMA20,1)) > 0.02)),(LOW - 0.03),'绝●佳'),align1,COLORWHITE;
DRAWTEXT(FILTER(((((((LOW <= M天) AND (CLOSE >= MMA20)) AND (HIGH < M压力1)) AND ((M天 - REF(M天,1)) > 0)) AND (CLOSE < M压力1)) AND ((MMA20 - REF(MMA20,1)) > 0)),6),(LOW - 0.12),'全仓'),align1,COLOR00FFFF;
ta:=BARSCOUNT(c); tah:=hhv(h,72); tal:=llv(l,72);

ta0:=(tah-tal)/21; tb1:=l-ta0;
drawtext((ta+0)/13=FLOOR((ta+0)/13),tb1-2.5*ta0,'时窗'),align1,COLORWHITE;

主力j:=EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3)*4800,2);
散户j:=EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*4800,7);
DRAWTEXT(CROSS(主力j,散户j) AND 主力j<0 AND 散户j<0,LOW,'底?'),align1,COLORRED;


RSV:=(((HHV(HIGH,13) - CLOSE) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
LWR1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,5,1);

VAR3AA:=IF((CLOSE > REF(CLOSE,1)),88,0);
VAR4AA:=IF(((((CLOSE / REF(CLOSE,1)) > 1.05) AND ((HIGH / CLOSE) < 1.01)) AND (VAR3AA > 0)),91,0);

DRAWTEXT(FILTER((VAR4AA > 90),34),(LOW * 0.99),'▲M'),ALIGN1,color99FFFF;
EMA30:=EMA(CLOSE,30);
EMA60:=EMA(CLOSE,60);
EMA90:=EMA(CLOSE,90);
EMA120:=EMA(CLOSE,120);
SS:=((((((CROSS(EMA30,EMA60) AND (CLOSE > OPEN)) AND (CLOSE > REF(CLOSE,1))) AND ((CLOSE / REF(CLOSE,1)) >= 1.018)) OR (((CROSS(EMA30,EMA120) AND (CLOSE > OPEN)) AND (CLOSE > REF(CLOSE,1))) AND ((CLOSE / REF(CLOSE,1)) >= 1.018))) OR (((CROSS(EMA60,EMA90) AND (CLOSE > OPEN)) AND (CLOSE > REF(CLOSE,1))) AND ((CLOSE / REF(CLOSE,1)) >= 1.018))) OR (((CROSS(EMA30,EMA90) AND (CLOSE > OPEN)) AND (CLOSE > REF(CLOSE,1))) AND ((CLOSE / REF(CLOSE,1)) >= 1.018)));
DRAWICON(SS,(LOW - 0.04),1),ALIGN1;
FA:=(BARSLAST(CROSS(MA(CLOSE,60),MA(CLOSE,20))) AND CROSS(MA(CLOSE,20),MA(CLOSE,60)));

DRAWTEXT(FA,(MA(CLOSE,20) - 0.13),'握↑手'),ALIGN1,colorFFFFFF;
TT1:=((CROSS(MA(CLOSE,20),MA(CLOSE,120)) AND CROSS(MA(CLOSE,20),MA(CLOSE,250))) AND (VOL > REF(VOL,1)));
TT2:=(((MA(CLOSE,20) > REF(MA(CLOSE,20),2)) AND (VOL > REF(VOL,1))) AND CROSS(CLOSE,MA(CLOSE,20)));
DRAWTEXT(TT1,(LOW - 0.13),'买B'),colorRED;

DRAWTEXT(TT2,HIGH*1.02,'买A'),ALIGN1,colorRED;

map1:=ma(close,8);
map2:=ma(close,13);
map3:=ma(close,21);
map4:=ma(close,34);
map5:=ma(close,20);
fff:=(low<=map1 and low<=map2 and low<=map3 and close>=map1 and
close>=map2 and close>=map3 and close>ref(close,1));
drawtext(fff,low*0.98,'阳拐'),align1,colorwhite;

大卫均线 大智慧指标 源码 贴图 点击下载大卫均线 大智慧指标 源码 贴图 

  • 股票公式精品推荐
  • 03-02精品指标喜欢的下 波段抓妖 通达信主图
  • 03-02金钻指标 特殊MACD源码 通达信副图指标
  • 03-02精品实战指标 精准短线出击 通达信副图
  • 03-02精准指标 精准提前必涨停3 通达信副图+
  • 03-02希望大家能抓到大牛 寻牛 通达信副图/选
  • 03-02修改后通达信版本《通达信三角洲预测》
  • 03-02指标可叠加于任何主图 限售股解禁公式
  • 03-02捕捉到的黑马很多 铁血教官之小样还藏+
  • 03-02获取短线暴利 绝对原创——极速反转短线
  • 03-02逢低买入 等待拉升 强庄主图标识代码 通
  • 03-02在网上找到的指标 一战成名 通达信主图
  • 03-01金钻指标原创不喜勿下 又见金底 通达信
  • 03-01让你坐上头等舱 K线发射成功 通达信主图
  • 03-01及时坐上头等仓 K线发射成功 通达信选股
  • 03-01这个指标需要较高的操作技术 配套指标,
  • 03-01实战指标 【高抛低吸T+0】 精准背离 通
  • 03-01今天借花献佛 公开这个公式源码 爆涨公
  • 02-28狗年旺旺旺 暴力杀庄 通达信副图指标 源
  • 02-28股市没烦恼!量价指标 通达信副图指标
  • 02-28精准提前抄底指标 成交量提前预警抓涨停
  • 02-28指标挺好的 吊打止损优化公式 通达信主
  • 02-28获取短线暴利 原创——急速反转买 通达
  • 02-28恭喜、恭喜、赢钱笑微微 跟你,明日就有
  • 02-28祝投资顺利 跟你,明日就有起!通达信选
  • 02-28二个选股公式源码 超级大黑马选股公式
  • 02-28用了你才知道好 一线游资建仓指标公式
  • 02-27真正的高手都是买在阴线 卖在阳线 阴线
  • 02-27金钻指标 【牛、妖股`主升浪利器】薛斯
  • 02-27以投资的角度出发 黄蓝带主图 大局掌控
  • 02-27具体交易要结合大盘和个股情况来看 一个
  • 学了还要学
    股票公式火热下载榜
    看了还想看