股票下载网 股票软件7311 个 ┆ 股票公式33754 个 ┆ 炒股知识3863
首 页炒股知识股票软件股票公式技术指标设为首页  加入收藏  放到桌面本站分类
当前位置:股票下载网股票公式通达信公式
日期:2018-04-16 09:48:00  来源:本站整理

源码开放 压力支撑LK 通达信指标 源码 贴图

源码开放 压力支撑LK 通达信指标 源码 贴图

压力支撑LK 通达信指标 源码 贴图

点击下载压力支撑LK 通达信指标 源码 贴图


XG:OPEN=HIGH;
XG12:CLOSE=LOW;
HJ_1:=IF(CLOSE>=XG AND REF(CLOSE,1)>XG,1,0);
HJ_2:=IF(CLOSE>=XG AND BETWEEN(XG,CLOSE,OPEN)=0 AND REF(CLOSE,1)>XG,1,0);
DRAWICON(FILTER(XG=1,1),LOW*0.988,2);
DRAWICON(FILTER(XG12=1,1),LOW*0.988,3);
HJ_3:=COST(50.099998);
HJ_4:=COST(30.1);
HJ_5:=LLVBARS(LOW,60);
HJ_6:=BARSLAST(CURRBARSCOUNT=CONST(HJ_5)+1);
HJ_7:=FINDHIGHBARS(OPEN,HJ_5+1,60,1);
压力A:DRAWLINE(CURRBARSCOUNT=CONST(HJ_7)+1,OPEN,ISLASTBAR,REF(OPEN,HJ_7),0),COLORRED;
HJ_8:=LLVBARS(LOW,30);
HJ_9:=BARSLAST(CURRBARSCOUNT=CONST(HJ_8)+1);
HJ_10:=FINDHIGHBARS(OPEN,HJ_8+1,30,1);
压力B:DRAWLINE(CURRBARSCOUNT=CONST(HJ_10)+1,OPEN,ISLASTBAR,REF(OPEN,HJ_10),0),COLORYELLOW;
HJ_11:=LLVBARS(LOW,10);
HJ_12:=BARSLAST(CURRBARSCOUNT=CONST(HJ_11)+1);
HJ_13:=FINDHIGHBARS(OPEN,HJ_11+1,10,1);
压力C:DRAWLINE(CURRBARSCOUNT=CONST(HJ_13)+1,OPEN,ISLASTBAR,REF(OPEN,HJ_13),0),COLORGREEN;
HJ_14:=LLVBARS(LOW,5);
HJ_15:=BARSLAST(CURRBARSCOUNT=CONST(HJ_14)+1);
HJ_16:=FINDHIGHBARS(OPEN,HJ_14+1,5,1);
压力D:DRAWLINE(CURRBARSCOUNT=CONST(HJ_16)+1,OPEN,ISLASTBAR,REF(OPEN,HJ_16),0),COLORWHITE;
HJ_17:=CURRBARSCOUNT=5-4;
DRAWNUMBER(HJ_17 AND 压力D,压力D,压力D),COLORYELLOW;
HJ_18:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
HJ_19:=IF(DATE<1170111 AND DATE>900101,1,0);
DRAWTEXT_FIX(ISLASTBAR,0.5,0.05,0,CODE),COLORYELLOW;
HJ_20:=STRCAT(HYBLOCK,1);
HJ_21:=STRCAT(HJ_20,FGBLOCK);
HJ_22:=STRCAT(HJ_21,DYBLOCK);
HJ_23:=STRCAT(HJ_22,1);
DRAWTEXT_FIX(1,0,0,0,STRCAT(HJ_23,GNBLOCK)),COLORYELLOW;
HJ_24:=10;
HJ_25:=10;
HJ_26:=0;
HJ_27:=0;
HJ_28:=0;
HJ_29:=0;
HJ_30:=REF(HIGH,HJ_24)=HHV(HIGH,2*HJ_24+1)*HJ_19;
HJ_31:=BACKSET(HJ_30,HJ_24+1);
HJ_32:=FILTER(HJ_31,HJ_24) AND HIGH=HHV(HIGH,HJ_24+1);
DRAWICON(HJ_32,HIGH*1.02,2);
HJ_33:=BARSLAST(HJ_32);
HJ_34:=IF(HJ_32,CURRBARSCOUNT,0);
HJ_35:=IF(HJ_33,REF(HIGH,HJ_33),HIGH);
HJ_36:=IF(HJ_33,REF(HJ_34,HJ_33),HJ_34);
HJ_37:=REF(HJ_35,HJ_33+1);
HJ_38:=CONST(HJ_36);
HJ_39:=REF(HJ_36,HJ_33+1);
HJ_40:=CONST(HJ_39);
HJ_41:=REF(HJ_37,HJ_33+1);
HJ_42:=IF(CURRBARSCOUNT>HJ_40,0,1);
高点压力:DRAWLINE(CURRBARSCOUNT=HJ_40,HIGH,CURRBARSCOUNT=HJ_38,HIGH,1)*HJ_19,DOTLINE,COLORGREEN;
A:DRAWLINE(CURRBARSCOUNT=HJ_40,HIGH,ISLASTBAR,REF(HIGH,HJ_40-1),1),POINTDOT,COLOR0055FF;
B:DRAWLINE(CURRBARSCOUNT=HJ_38,HIGH,ISLASTBAR,REF(HIGH,HJ_38-1),1),POINTDOT,COLORYELLOW;
HJ_43:=CURRBARSCOUNT=5-4;
DRAWNUMBER(HJ_43 AND A,A,A),COLORYELLOW;
HJ_44:=CURRBARSCOUNT=5-4;
DRAWNUMBER(HJ_44 AND 高点压力,高点压力,高点压力),COLORYELLOW;
DRAWNUMBER(HJ_44 AND B,B,B),COLORYELLOW;
HJ_45:=REF(LOW,HJ_25)=LLV(LOW,2*HJ_25+1)*HJ_19;
HJ_46:=BACKSET(HJ_45,HJ_25+1);
HJ_47:=FILTER(HJ_46,HJ_25) AND LOW=LLV(LOW,HJ_25+1)*HJ_19;
DRAWICON(HJ_47,LOW*0.98,1);
HJ_48:=BARSLAST(HJ_47);
HJ_49:=IF(HJ_47,CURRBARSCOUNT,0);
HJ_50:=IF(HJ_48,REF(LOW,HJ_48),LOW);
HJ_51:=IF(HJ_48,REF(HJ_49,HJ_48),HJ_49);
HJ_52:=CONST(HJ_51);
HJ_53:=REF(HJ_50,HJ_48+1);
HJ_54:=REF(HJ_51,HJ_48+1);
HJ_55:=CONST(HJ_54);
低点支撑:DRAWLINE(CURRBARSCOUNT=HJ_55,LOW,CURRBARSCOUNT=HJ_52,LOW,1)*HJ_19,DOTLINE,COLORRED;
HJ_56:=CURRBARSCOUNT=5-4;
DRAWNUMBER(HJ_56 AND 低点支撑,低点支撑,低点支撑)*HJ_19,COLORYELLOW;
HJ_57:=(高点压力+低点支撑)/2;
HJ_58:=CONST((高点压力+低点支撑)/2);
HJ_59:=IF(HJ_55<HJ_40,HJ_55,HJ_40);
中轨:DRAWLINE(CURRBARSCOUNT=HJ_59,HJ_57,ISLASTBAR,HJ_58,1),DOTLINE,COLORFF55BB;
DRAWLINE(CURRBARSCOUNT=HJ_52,LOW,ISLASTBAR,REF(LOW,HJ_52-1),1),POINTDOT,COLORMAGENTA;
DRAWLINE(CURRBARSCOUNT=HJ_55,LOW,ISLASTBAR,REF(LOW,HJ_55-1),1),POINTDOT,COLORCYAN;
HJ_60:=BACKSET(REF(HIGH,2)=HHV(HIGH,3),3);
HJ_61:=CROSS(HJ_60,0.9);
HJ_62:=BACKSET(REF(LOW,2)=LLV(LOW,3),3);
HJ_63:=CROSS(HJ_62,0.9);
HJ_64:=REF(HIGH,BARSLAST(HJ_61))*HJ_19;
HJ_65:=REF(LOW,BARSLAST(HJ_63));
HJ_66:=REF(LOW,1)=LLV(LOW,2*1+1);
HJ_67:=BACKSET(HJ_66,1+1);
HJ_68:=FILTER(HJ_67,1) AND LOW=LLV(LOW,1+1);
HJ_69:=BARSLAST(HJ_68);
HJ_70:=IF(HJ_68,CURRBARSCOUNT,0);
HJ_71:=IF(HJ_69,REF(HJ_70,HJ_69),HJ_70);
HJ_72:=CONST(HJ_71);
HJ_73:=CONST(REF(HIGH,HJ_72-1));
HJ_74:=BACKSET(ISLASTBAR,HJ_72);
HJ_74;
HJ_73;
C111:HJ_73*HJ_19,NODRAW,COLORRED;
STICKLINE(HJ_74,HJ_73,HJ_73,4,0)*HJ_19,COLORWHITE,LINETHICK2;
HJ_75:=REF(LOW,2)=LLV(LOW,2*2+1);
HJ_76:=FILTER(HJ_75,2);
HJ_77:=BACKSET(HJ_76,2+1);
HJ_78:=FILTER(HJ_77,2);
HJ_79:=BACKSET(ISLASTBAR,BARSLAST(HJ_78)+2);
HJ_80:=HJ_79>REF(HJ_79,2);
ZC:DRAWLINE(HJ_78,LOW,HJ_80,LOW,2),DOTLINE,COLORWHITE;
HJ_81:=CURRBARSCOUNT=5-4;
DRAWNUMBER(HJ_81 AND ZC,ZC,ZC),COLORYELLOW;
STICKLINE(CLOSE/REF(CLOSE,1)>=1.09,OPEN,CLOSE,0.5,0),COLORYELLOW;
STICKLINE((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100<(-9.8),CLOSE,OPEN,0.8,0),COLORLICYAN;
HJ_82:=(CLOSE/REF(CLOSE,1)-1)*100>9.5;
HJ_83:=BARSLAST((CLOSE/REF(CLOSE,1)-1)*100>9.5);
最后涨停距今数:HJ_83,NODRAW,COLORWHITE;
HJ_84:=BARSLAST(HJ_82);
HJ_85:=REF(HIGH,HJ_84)-REF(LOW,HJ_84);
STICKLINE(CLOSE,REF(LOW,HJ_84)+HJ_85*0.5,REF(LOW,HJ_84)+HJ_85*0.5,7,0),COLORLIGRAY;
HJ_86:=REF(HIGH,5)=HHV(HIGH,2*5+1);
HJ_87:=BARSLAST(HJ_47);
HJ_88:=IF(HJ_47,CURRBARSCOUNT,0);
HJ_89:=CONST(HJ_39);
HJ_90:=CONST(REF(HIGH,HJ_89-1));
HJ_91:=BACKSET(ISLASTBAR,HJ_89);
HJ_91;
HJ_90;
C11:HJ_90,NODRAW,COLORRED;
STICKLINE(HJ_91,HJ_90,HJ_90,2,0),COLORYELLOW;
HJ_92:=DRAWLINE(CURRBARSCOUNT=CONST(HJ_89)+1,OPEN,ISLASTBAR,REF(OPEN,HJ_90),0);
HJ_93:=MA(CLOSE,5);
HJ_94:=STICKLINE(ISLASTBAR,HHV(CLOSE,5)*0.95,HHV(CLOSE,5)*0.95,20,2);
HJ_95:=HIGH*0.95;
HJ_96:=HHV(HIGH,19);
HJ_97:=CLOSE/REF(CLOSE,1);
HJ_98:=BARSLAST(HJ_97);
HJ_99:=REF(HIGH,HJ_98)-REF(LOW,HJ_98);
STICKLINE(CLOSE,REF(LOW,HJ_98)+HJ_99*0.5,REF(LOW,HJ_98)+HJ_99*0.5,3,0),COLORGRAY;
HJ_100:=FILTER(BACKSET(REF(HIGH,2)=HHV(HIGH,5),3),2);
HJ_101:=FILTER(BACKSET(REF(LOW,2)=LLV(LOW,5),3),2);
STICKLINE(HJ_101,LOW,LOW,1,0),COLORYELLOW;
HJ_102:=FILTER(BACKSET(REF(HIGH,2)=HHV(HIGH,5),3),2);
HJ_103:=FILTER(BACKSET(REF(LOW,2)=LLV(LOW,5),3),2);
HJ_104:=SIGNALS_USER(92,0)+SIGNALS_USER(93,0);
HJ_105:=SIGNALS_USER(93,0)/10000;
DRAWTEXT(HJ_105>0 AND HJ_105<10000,HIGH*0.95,VARCAT(VARCAT(2,VAR2STR(HJ_105,0)),3)),COLORGREEN;
DRAWTEXT(HJ_105>10000,HIGH*0.95,VARCAT(VARCAT(2,VAR2STR(HJ_105/10000,2)),4)),COLORGREEN;
DRAWTEXT(HJ_105<0 AND HJ_105>(-10000),HIGH*0.95,VARCAT(VARCAT(2,VAR2STR(HJ_105,0)),3)),COLORGREEN;
DRAWTEXT(HJ_105<(-10000),HIGH*0.95,VARCAT(VARCAT(2,VAR2STR(HJ_105/10000,2)),4)),COLORGREEN;
{-----------------------------------}

 
源码开放 压力支撑LK 通达信指标 源码 贴图
打开微信扫一扫,一键复制指标源码,
轻松快捷粘贴至手机通达信APP中。

Tags:

作者:佚名

公式评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论
Copyright © 2009-2019 GPxiazai.com. All Rights Reserved .
备案号: 苏ICP备12020055号-2 苏公网安备 32058302001104号
声明:本站所有信息免费,广告收费行为均与本站无关. 侵权请联系QQ929946094进行处理.
若本站收录的软件无意侵犯了贵司版权,请联系QQ929946094进行处理,谢谢!