股票下载网共有股票软件:7233 个 | 股票公式:32892 个 | 文章:3812 篇 | 总容量:71.075 G | 总下载:7650751 次 | 今日更新:0

斐波那契时间周期画线主图指标 (源码)

简介:input: N(5,1,100);EMA13:=EMA(C,13);ma30:=ma(c,30);ma72:=ma(c,72);{地心引力:(ma30+ma72)/2,POINTDOT,ColorFF7F93,LINETHICK3;上引力
标签:  来源:www.gpxiazai.com   发布时间:2012-01-14 点击:

input: N(5,1,100);
EMA13:=EMA(C,13);
ma30:=ma(c,30);
ma72:=ma(c,72);
{地心引力:(ma30+ma72)/2,POINTDOT,ColorFF7F93,LINETHICK3;
上引力:(ma30+ma72)/2*0.9,POINTDOT,ColorFF7F93,LINETHICK3;
下引力:(ma30+ma72)/2*1.1,POINTDOT,ColorFF7F93,LINETHICK3;}
{DRAWGBKLAST(CLOSE>0,STRIP(RGB(95,95,95),RGB(0,0,0),0));}
ema17:=ema(c,17);
主筹估算:=EMA(WINNER(c)*70,3);
散筹估算:=EMA((WINNER((c)*1.1)-WINNER((c)*0.9))*70,3);
筹码锁定:=散筹估算-主筹估算 ;
动态底部:=EMA(IF(L<= LLV(l,60),SMA(ABS(L-REF(L,1)),60,1)/SMA(MAX(L-REF(l,1),0),99,1),0)*5,3);
涨:=CROSS(主筹估算,筹码锁定);
强:=CROSS(主筹估算,散筹估算);
STICKLINE(涨,O,C,8,0),COLORYELLOW;
STICKLINE(涨,O,H,0,0),COLORYELLOW;
STICKLINE(涨,L,C,0,0),COLORYELLOW;
STICKLINE(强, O,C,8,0),colormagenta;
STICKLINE(强,O,H,0,0),colormagenta;
STICKLINE(强,L,C,0,0),colormagenta;
{黄金分割线}
lhnh:=BARSLAST(DISPSTATUS=1)+1;
nnl:=DISPSTATUS=2;
Al:=BACKSET(nnl,hhvBARS(h,lhnh)+1);
Bl:=Al>REF(Al,1);
Al2:=BACKSET(nnl,LLVBARS(L,lhnh)+1);
Bl2:=Al2>REF(Al2,1);
前高:REF(H,BARSLAST(bl)),PRECIS2,COLORff00ff,LINETHICK2;
DRAWTEXT(nnl,前高,'前高:'+前高),ALIGN2,COLORGREEN;
前低:REF(L,BARSLAST(Bl2)),PRECIS2,COLORGREEN,LINETHICK2;
DRAWTEXT(nnl,前低*1.009,'前低: '+前低),ALIGN2,COLORGREEN;
Fl1:((前高-前低)*0.191)+前低,POINTDOT,ColorFF7F93,LINETHICK3;
DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2) and nnl,Fl1,'0.236: '+Fl1),Color938C93;
Fl2:((前高-前低)*0.382)+前低,POINTDOT,Color5E8C93,LINETHICK3;
DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2) and nnl,Fl2,'0.382: '+Fl2),ALIGN2,COLORGREEN;
Fl3:((前高-前低)*0.5)+前低,POINTDOT,COLOR00ffff,LINETHICK4;
DRAWTEXT(nnl,Fl3,'0.5:'+Fl3),ALIGN2,Color918C93;
Fl4:((前高-前低)*0.618)+前低,POINTDOT,Color918C93,LINETHICK3;
DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2)and nnl,Fl4,'0.618: '+Fl4),ALIGN2,COLORGREEN;
Fl5:((前高-前低)*0.809)+前低,POINTDOT,Color918C67,LINETHICK3;
{www.gpxiazai.com 股票软件下载网_最新股票指标公式}
DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2) and nnl,Fl5,'0.764: '+Fl5),ALIGN2,COLORGREEN;
pp:=MAX( BARSLAST(bl),BARSLAST(Bl2))+1;
k1:=pp-1;
k2:=pp-3;
k3:=pp-5;
k4:=pp-8;
k5:=pp-13;
k6:=pp-21;
k7:=pp-34;
k8:=pp-55;
k9:=pp-89;
k10:=pp-144;
k11:=pp-233;
VERTLINE(FILTER(c=ref(c,k1),0) ,1 );
VERTLINE(FILTER(c=ref(c,k2),0) ,1 );
VERTLINE(FILTER(c=ref(c,k3),0),1 );
VERTLINE(FILTER(c=ref(c,k4),0) ,1 );
VERTLINE(FILTER(c=ref(c,k5),0) ,1 );
VERTLINE(FILTER( c=ref(c,k6),0),1 );
VERTLINE(FILTER( c=ref(c,k7),0),1 );
VERTLINE(FILTER(c=ref(c,k8),0),1 );
VERTLINE(FILTER(c=ref(c,k9),0),1 );
VERTLINE(FILTER(c=ref(c,k10),0),1 );
VERTLINE(FILTER(c=ref(c,k11),0),1 );
DRAWTEXT(FILTER(c=ref(c,k1),0),(HHV( h,80 )+LLV(l ,80 ))/2,'1'),COLORred,LINETHICK6;
DRAWTEXT(FILTER( c=ref(c,k2),0),(HHV( h,80 )+LLV(l ,80 ))/2,'3'),COLORred,LINETHICK6;
DRAWTEXT(FILTER(c=ref(c,k3),0),(HHV( h,80 )+LLV(l ,80 ))/2,'5'),COLORGREEN,LINETHICK6;
DRAWTEXT(FILTER(c=ref(c,k4),0),(HHV( h,80 )+LLV(l ,80 ))/2,'8'),COLORred,LINETHICK6;
DRAWTEXT(FILTER(c=ref(c,k5),0),(HHV( h,80 )+LLV(l ,80 ))/2,'13'),COLORred,LINETHICK6;
DRAWTEXT(FILTER(c=ref(c,k6),0),(HHV( h,80 )+LLV(l ,80 ))/2,'21转'),COLORGREEN,LINETHICK6;
DRAWTEXT(FILTER(c=ref(c,k7),0),(HHV( h,80 )+LLV(l ,80 ))/2,'34'),COLORred,LINETHICK6;
DRAWTEXT(FILTER(c=ref(c,k8),0),(HHV( h,80 )+LLV(l ,80 ))/2,'55'),COLORred,LINETHICK6;
DRAWTEXT(FILTER(c=ref(c,k9),0),(HHV( h,80 )+LLV(l ,80 ))/2,'89'),COLORGREEN,LINETHICK6;
DRAWTEXT(FILTER(c=ref(c,k10),0),(HHV( h,80 )+LLV(l ,80 ))/2,'144'),COLORred,LINETHICK6;
DRAWTEXT(FILTER(c=ref(c,k11),0),(HHV( h,80 )+LLV(l ,80 ))/2,'233'),COLORGREEN,LINETHICK6;
A1:=ref(h,N)=hhv(h,2*N+1);
B1:=filter(A1,N);
C1:=backset(B1,N+1);
D1:=filter(C1,n) or BARSTATUS=2;{高点}
A2:=ref(l,N)=llv(l,2*N+1);
B2:=filter(A2,N);
C2:=backset(B2,N+1);
D2:=filter(C2,N);{低点}
E1:=(ref(llv(l,2*N),1)+ref(hhv(h,2*N),1))/2; E2:=(h+l)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND not(D2 AND E1>=E2)) OR barstatus=2 OR barscount(c)=1;
L1:=(D2 AND not(D1 AND E1<E2)); H2:=D1 AND not(D2 AND E1>=E2);
X1:=ref(barslast(H1),1)+1; F1:=backset(H1 AND count(L1,X1)>0,llvbars
(if(L1,l,10000),X1));
G1:=F1>ref(F1,1); I1:=backset(G1,2); LD:=I1>ref(I1,1);{过滤后低点}
L2:=LD OR barstatus=2 OR barscount(c)=1;
X2:=ref(barslast(L2),1)+1; F2:=backset(L2 AND count(H2,X2)>0,hhvbars
(if(H2,h,0),X2));
G2:=F2>ref(F2,1); I2:=backset(G2,2); HD:=I2>ref(I2,1);{过滤后高点}
R1:=backset(barstatus=2,barslast(HD)+1); S1:=R1>ref(R1,1); {前一高}
T1:=backset(barstatus=2,barslast(LD)+1); U1:=T1>ref(T1,1); {前一低}
R2:=backset(S1,ref(barslast(HD),1)+2); S2:=R2>ref(R2,1); {前二高}
T2:=backset(U1,ref(barslast(LD),1)+2); U2:=T2>ref(T2,1); {前二低}
T3:=backset(U2,ref(barslast(LD),1)+2); U3:=T3>ref(T3,1); {前三低}
T4:=backset(U3,ref(barslast(LD),1)+2); U4:=T4>ref(T4,1); {前四低}
R3:=backset(S2,ref(barslast(HD),1)+2); S3:=R3>ref(R3,1); {前三高}
R4:=backset(S3,ref(barslast(HD),1)+2); S4:=R4>ref(R4,1); {前四高}
短期压力:drawline(S2,h,S1,h,1),Colorred,LINETHICK2;
短期支撑:drawline(U2,l,U1,l,1),Colorgreen,LINETHICK2;
中期压力:drawline(S3,h,S2,h,1),Coloryellow,LINETHICK2;
中期支撑:drawline(U3,l,U2,l,0),Colorgreen,LINETHICK2;
长期压力:drawline(S4,h,S3,h,1),COLORwhite,LINETHICK2;
长期支撑:drawline(U4,l,U3,l,0),Colorgreen,LINETHICK2;
DRAWICON(S1,H,10);
DRAWICON(S2,H,10);
DRAWICON(S3,H,10);
DRAWICON(S4,H,10);

大智慧斐波那契时间周期画线主图指标公式

  • 股票公式精品推荐
  • 03-02精品指标喜欢的下 波段抓妖 通达信主图
  • 03-02金钻指标 特殊MACD源码 通达信副图指标
  • 03-02精品实战指标 精准短线出击 通达信副图
  • 03-02精准指标 精准提前必涨停3 通达信副图+
  • 03-02希望大家能抓到大牛 寻牛 通达信副图/选
  • 03-02修改后通达信版本《通达信三角洲预测》
  • 03-02指标可叠加于任何主图 限售股解禁公式
  • 03-02捕捉到的黑马很多 铁血教官之小样还藏+
  • 03-02获取短线暴利 绝对原创——极速反转短线
  • 03-02逢低买入 等待拉升 强庄主图标识代码 通
  • 03-02在网上找到的指标 一战成名 通达信主图
  • 03-01金钻指标原创不喜勿下 又见金底 通达信
  • 03-01让你坐上头等舱 K线发射成功 通达信主图
  • 03-01及时坐上头等仓 K线发射成功 通达信选股
  • 03-01这个指标需要较高的操作技术 配套指标,
  • 03-01实战指标 【高抛低吸T+0】 精准背离 通
  • 03-01今天借花献佛 公开这个公式源码 爆涨公
  • 02-28狗年旺旺旺 暴力杀庄 通达信副图指标 源
  • 02-28股市没烦恼!量价指标 通达信副图指标
  • 02-28精准提前抄底指标 成交量提前预警抓涨停
  • 02-28指标挺好的 吊打止损优化公式 通达信主
  • 02-28获取短线暴利 原创——急速反转买 通达
  • 02-28恭喜、恭喜、赢钱笑微微 跟你,明日就有
  • 02-28祝投资顺利 跟你,明日就有起!通达信选
  • 02-28二个选股公式源码 超级大黑马选股公式
  • 02-28用了你才知道好 一线游资建仓指标公式
  • 02-27真正的高手都是买在阴线 卖在阳线 阴线
  • 02-27金钻指标 【牛、妖股`主升浪利器】薛斯
  • 02-27以投资的角度出发 黄蓝带主图 大局掌控
  • 02-27具体交易要结合大盘和个股情况来看 一个
  • 学了还要学
    股票公式火热下载榜
    看了还想看