»查看更多分类股票软件

通达信红绿灯主图指标 量学看盘系统主图指标 源码 贴图

发布时间:2021-09-15 09:29:00  点击:

红绿灯

量学看盘系统主图一
这是类似黄金分割的一个指标

通达信红绿灯主图指标 量学看盘系统主图指标 源码 贴图

通达信红绿灯主图指标 量学看盘系统主图指标 源码 贴图


X_1:=HHV(VOL,10);
X_2:=BARSLAST(X_1=VOL);
X_3:=CROSS(REF(MAX(CLOSE,OPEN),X_2),CLOSE);
STICKLINE(X_3,MAX(CLOSE,OPEN)*1.02,MIN(CLOSE,OPEN)*0.98,0,1),COLORRED;
STICKLINE(X_3,(OPEN+CLOSE)/2,(OPEN+CLOSE)/2,10,0),COLORRED;
X_4:=1.3;
X_5:=1;
X_6:=0;
X_7:=MA(CLOSE,5);
X_8:=MA(CLOSE,10);
X_9:=MA(CLOSE,20);
X_10:=X_7>REF(X_7,1) AND X_8<REF(X_8,1) AND X_9<REF(X_9,1);
X_11:=REF(VOL,1);
X_12:=REF(VOL,2);
X_13:=REF(VOL,3);
X_14:=REF(CLOSE,1);
X_15:=REF(CLOSE,2);
X_16:=REF(CLOSE,3);
X_17:=REF(CLOSE,4);
X_18:=REF(OPEN,1);
X_19:=REF(OPEN,2);
X_20:=REF(OPEN,3);
X_21:=REF(OPEN,4);
X_22:=CLOSE>=X_16 AND X_14>=X_16 AND X_15>=X_16;
X_23:=LOW>X_20 AND REF(LOW,1)>X_20 AND REF(LOW,2)>X_20;
X_24:=AMOUNT/VOL/100;
X_25:=REF(X_24,1);
X_26:=REF(X_24,2);
X_27:=CLOSE>=OPEN OR (CLOSE<OPEN AND X_24>X_14);
X_28:=COUNT(X_27,3)>=2;
X_29:=X_16>X_20;
X_30:=X_24>=X_25 OR CLOSE>X_14 AND (X_25>=X_26 OR X_14>=X_15);
X_31:=(CLOSE+X_14+X_15)/3>X_16;
X_32:=VOL>X_11 AND X_11>X_12;
X_33:=VOL<=X_11 AND X_11<=X_12;
X_34:=(VOL+X_11+X_12)/3<=X_13 AND NOT(X_32);
X_35:=CLOSE/VOL;
X_36:=X_35>=REF(X_35,1) AND REF(X_35,1)>=REF(X_35,2);
X_37:=(CLOSE+X_14+X_15)/3/X_16;
X_38:=(VOL+X_11+X_12)/3/X_13;
X_39:=X_4*X_37/X_38>1;
X_40:=X_20>X_17 AND X_17>X_21;
X_41:=X_29 AND X_30 AND X_33 AND X_22 AND X_23 AND X_40;
X_42:=BACKSET(X_41,5);
X_43:=FILTER(X_42,4);
X_44:=X_29 AND X_30 AND X_33 AND X_22 AND X_23;
X_45:=BACKSET(X_44,4);
X_46:=FILTER(X_45,3);
X_47:=X_44 AND REF(X_44,1);
X_48:=BACKSET(X_47,4);
X_49:=FILTER(X_48,3);
X_50:=X_44 AND REF(X_44,2);
X_51:=BACKSET(X_50,4);
X_52:=FILTER(X_51,3);
X_53:=X_44 AND REF(X_44,3);
X_54:=BACKSET(X_53,4);
X_55:=FILTER(X_54,3);
X_56:=X_29 AND X_30 AND X_34 AND NOT(X_32) AND X_22 AND X_23 AND X_40 AND NOT(X_44) AND NOT(X_41);
X_57:=BACKSET(X_56,5);
X_58:=FILTER(X_57,4);
X_59:=X_29 AND X_30 AND X_34 AND NOT(X_32) AND X_22 AND X_23 AND NOT(X_44) AND NOT(X_41);
X_60:=BACKSET(X_59,4);
X_61:=FILTER(X_60,3);
X_62:=X_59 AND REF(X_59,1);
X_63:=BACKSET(X_62,4);
X_64:=FILTER(X_63,3);
X_65:=X_59 AND REF(X_59,2);
X_66:=BACKSET(X_65,4);
X_67:=FILTER(X_66,3);
X_68:=X_59 AND REF(X_59,3);
X_69:=BACKSET(X_68,4);
X_70:=FILTER(X_69,3);
X_71:=X_29 AND X_31 AND X_33 AND X_22 AND X_23 AND X_40 AND NOT(X_44) AND NOT(X_59) AND NOT(X_41) AND NOT(X_56);
X_72:=BACKSET(X_71,5);
X_73:=FILTER(X_72,4);
X_74:=X_29 AND X_31 AND X_33 AND X_22 AND X_23 AND NOT(X_44) AND NOT(X_59) AND NOT(X_41) AND NOT(X_56);
X_75:=BACKSET(X_74,4);
X_76:=FILTER(X_75,3);
X_77:=X_74 AND REF(X_74,1);
X_78:=BACKSET(X_77,4);
X_79:=FILTER(X_78,3);
X_80:=X_74 AND REF(X_74,2);
X_81:=BACKSET(X_80,4);
X_82:=FILTER(X_81,3);
X_83:=X_74 AND REF(X_74,3);
X_84:=BACKSET(X_83,4);
X_85:=FILTER(X_84,3);
X_86:=X_29 AND X_31 AND X_34 AND X_22 AND X_23 AND X_40 AND NOT(X_44) AND NOT(X_41) AND NOT(X_59) AND NOT(X_56) AND NOT(X_74) AND NOT(X_71);
X_87:=BACKSET(X_86,5);
X_88:=FILTER(X_87,4);
X_89:=X_29 AND X_31 AND X_34 AND X_22 AND X_23 AND NOT(X_44) AND NOT(X_59) AND NOT(X_74) AND NOT(X_41) AND NOT(X_56) AND NOT(X_71);
X_90:=BACKSET(X_89,4);
X_91:=FILTER(X_90,3);
X_92:=X_89 AND REF(X_89,1);
X_93:=BACKSET(X_92,4);
X_94:=FILTER(X_93,3);
X_95:=X_89 AND REF(X_89,2);
X_96:=BACKSET(X_95,4);
X_97:=FILTER(X_96,3);
X_98:=X_89 AND REF(X_89,3);
X_99:=BACKSET(X_98,4);
X_100:=FILTER(X_99,3);
X_101:=X_29 AND X_31 AND X_39 AND X_22 AND X_23 AND X_40 AND NOT(X_44) AND NOT(X_59) AND NOT(X_74) AND NOT(X_89) AND NOT(X_41) AND NOT(X_56) AND NOT(X_71) AND NOT(X_86);
X_102:=BACKSET(X_101,5);
X_103:=FILTER(X_102,4);
X_104:=X_29 AND X_31 AND X_39 AND X_22 AND X_23 AND NOT(X_44) AND NOT(X_59) AND NOT(X_74) AND NOT(X_89) AND NOT(X_41) AND NOT(X_56) AND NOT(X_71) AND NOT(X_86);
X_105:=BACKSET(X_104,4);
X_106:=FILTER(X_105,3);
X_107:=X_104 AND REF(X_104,1);
X_108:=BACKSET(X_107,4);
X_109:=FILTER(X_108,3);
X_110:=X_104 AND REF(X_104,2);
X_111:=BACKSET(X_110,4);
X_112:=FILTER(X_111,3);
X_113:=X_104 AND REF(X_104,3);
X_114:=BACKSET(X_113,4);
X_115:=FILTER(X_114,3);
X_116:=X_29 AND X_31 AND X_36 AND X_22 AND X_23 AND X_40 AND NOT(X_44) AND NOT(X_59) AND NOT(X_74) AND NOT(X_89) AND NOT(X_104) AND NOT(X_41) AND NOT(X_56) AND NOT(X_71) AND NOT(X_86) AND NOT(X_101);
X_117:=BACKSET(X_116,5);
X_118:=FILTER(X_117,4);
X_119:=X_29 AND X_31 AND X_36 AND X_22 AND X_23 AND NOT(X_44) AND NOT(X_59) AND NOT(X_74) AND NOT(X_89) AND NOT(X_104) AND NOT(X_41) AND NOT(X_56) AND NOT(X_71) AND NOT(X_86) AND NOT(X_101);
X_120:=BACKSET(X_119,4);
X_121:=FILTER(X_120,3);
X_122:=X_119 AND REF(X_119,1);
X_123:=BACKSET(X_122,4);
X_124:=FILTER(X_123,3);
X_125:=X_119 AND REF(X_119,2);
X_126:=BACKSET(X_125,4);
X_127:=FILTER(X_126,3);
X_128:=X_119 AND REF(X_119,3);
X_129:=BACKSET(X_128,4);
X_130:=FILTER(X_129,3);
X_131:=X_46 AND NOT(REF(X_46,4)) OR (X_49 AND NOT(REF(X_49,4))) OR (X_52 AND NOT(REF(X_52,4))) OR (X_55 AND NOT(REF(X_55,4)));
X_132:=X_61 AND NOT(REF(X_61,4)) OR (X_64 AND NOT(REF(X_64,4))) OR (X_67 AND NOT(REF(X_67,4))) OR (X_70 AND NOT(REF(X_70,4)));
X_133:=X_76 AND NOT(REF(X_76,4)) OR (X_79 AND NOT(REF(X_79,4))) OR (X_82 AND NOT(REF(X_82,4))) OR (X_85 AND NOT(REF(X_85,4)));
X_134:=X_91 AND NOT(REF(X_91,4)) OR (X_94 AND NOT(REF(X_94,4))) OR (X_97 AND NOT(REF(X_97,4))) OR (X_100 AND NOT(REF(X_100,4)));
X_135:=X_106 AND NOT(REF(X_106,4)) OR (X_109 AND NOT(REF(X_109,4))) OR (X_112 AND NOT(REF(X_112,4))) OR (X_115 AND NOT(REF(X_115,4)));
X_136:=X_121 AND NOT(REF(X_121,4)) OR (X_124 AND NOT(REF(X_124,4))) OR (X_127 AND NOT(REF(X_127,4))) OR (X_130 AND NOT(REF(X_130,4)));
X_137:=X_131 OR X_132 OR X_133 OR X_134 OR X_135 OR X_136;
STICKLINE(X_137 AND NOT(REF(X_137,4)),OPEN,CLOSE,1,0),COLOR0099FF;
X_138:=SUMBARS(X_137,1);
X_139:=X_43 AND NOT(REF(X_43,5));
X_140:=X_58 AND NOT(REF(X_58,5));
X_141:=X_73 AND NOT(REF(X_73,5));
X_142:=X_88 AND NOT(REF(X_88,5));
X_143:=X_103 AND NOT(REF(X_103,5));
X_144:=X_118 AND NOT(REF(X_118,5));
X_145:=X_139 OR X_140 OR X_141 OR X_142 OR X_143 OR X_144;
STICKLINE(X_145 AND NOT(REF(X_145,5)),OPEN,CLOSE,1,0),COLORRED;
X_146:=SUMBARS(X_145,1);
X_147:=X_44 OR X_59 OR X_74 OR X_89 OR X_104 OR X_119 AND X_10 AND X_6;
X_148:=BACKSET(X_147,4);
X_149:=FILTER(X_148,3);
STICKLINE(X_149 AND NOT(REF(X_149,4)),OPEN,CLOSE,1,0),COLOR0099FF;
X_150:=X_41 OR X_56 OR X_71 OR X_86 OR X_101 OR X_116 AND X_10 AND X_6;
X_151:=BACKSET(X_150,5);
X_152:=FILTER(X_151,5);
STICKLINE(X_152 AND NOT(REF(X_152,4)),OPEN,CLOSE,1,0),COLOR0099FF;
X_153:=X_44 OR X_59 OR X_74 OR X_89 OR X_104 OR X_119 AND NOT(DYNAINFO(4)=0) AND CLOSE=HHV(CLOSE,3);
X_154:=X_153 AND REF(CLOSE,4)<REF(CLOSE,5) AND REF(CLOSE,4)<REF(OPEN,4) AND REF(OPEN,3)>=REF(OPEN,4);
X_155:=FILTER(BACKSET(X_154,5),5);
STICKLINE(X_155,LOW,HIGH,0.5,0),COLORMAGENTA;
X_156:=AMOUNT/VOL/100;
X_157:=CLOSE>OPEN AND REF(CLOSE,1)>X_156 AND CLOSE>X_156 AND CLOSE<300;
STICKLINE(X_157,OPEN,CLOSE,1,0),COLORLICYAN;
X_158:=OPEN>CLOSE AND CLOSE<X_156 AND X_156>REF(CLOSE,1);
STICKLINE(X_158,OPEN,CLOSE,1,0),COLORRED;
X_159:=VOL>REF(VOL,1)*0.95 AND VOL<REF(VOL,1)*1.05;
X_160:=WINNER(CLOSE)-WINNER(OPEN)>=0.2 AND X_159;
STICKLINE(X_160,OPEN,CLOSE,1,0),COLORBLUE;
X_161:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_162:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND X_161>=4.945;
X_163:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND X_161<=(-4.945);
涨停价:IF(X_162,REF(CLOSE,1)*1.05,REF(CLOSE,1)*1.1),NODRAW,COLORRED;
跌停价:IF(X_163,REF(CLOSE,1)*0.95,REF(CLOSE,1)*0.9),NODRAW,COLORGREEN;
X_164:=REF(CLOSE,1);
X_165:=CLOSE=ZTPRICE(REF(CLOSE,1),0.1);
STICKLINE(X_165,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(X_165,OPEN,CLOSE,1,0),COLORMAGENTA;
X_166:=CLOSE=DTPRICE(REF(CLOSE,1),0.1);
STICKLINE(X_166,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(X_166,HIGH,LOW,0,1),COLORGREEN;
X_167:=CONST(HHV(REF(HIGH,1),240));
X_168:=CONST(LLV(REF(LOW,1),240));
X_169:=X_167-X_168;
X_170:=LOW-X_169*0.03;
X_171:=HIGH+X_169*0.03;
X_172:=CLOSE>500;
X_173:=MAX(CLOSE,OPEN);
X_174:=MIN(CLOSE,OPEN);
X_175:=0;
X_176:=1;
X_177:=IF(X_172,HIGH,X_173);
X_178:=IF(X_172,LOW,X_174);
X_179:=IF(CLOSE>OPEN,IF(X_176=0,LOW,X_178),IF(X_176=0,HIGH,X_177));
X_180:=2/1000;
X_181:=CURRBARSCOUNT;
X_182:=120;
X_183:=X_181<=X_182;
X_184:=LOW;
X_185:=IF(X_175=0,X_184,REF(X_175,X_175));
基准价:IF(X_183,CONST(X_185),DRAWNULL),DOTLINE,COLORRED;
X_186:=基准价;
X_187:=X_186*X_180;
X_188:=ABS(LOW-X_186)<=X_187;
X_189:=ABS(OPEN-X_186)<=X_187;
X_190:=ABS(CLOSE-X_186)<=X_187;
X_191:=ABS(HIGH-X_186)<=X_187;
X_192:=X_188 OR X_189 OR X_190 OR X_191 AND X_183 AND X_181!=1;
X_193:=COUNT(X_192,X_182);
精准点个数:IF(X_193>0,X_193+1,0),NODRAW,COLORRED;
X_194:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));
X_195:=DYNAINFO(5)<0.01 OR DYNAINFO(6)<0.01;
X_196:=IF(X_195,1,X_194<DYNAINFO(5)+0.01 AND X_194>DYNAINFO(6)-0.01);
X_197:=IF(X_196,0.01*EMA(AMOUNT,35)/EMA(VOL,35),EMA((HIGH+LOW+CLOSE)/3,35));
操盘线:MA(CLOSE,5),COLORMAGENTA,LINETHICK2;
牛熊分界:X_197,COLORRED,LINETHICK2;
IF(CLOSE<操盘线,操盘线,DRAWNULL),COLORLICYAN,LINETHICK2;
IF(CLOSE<牛熊分界,牛熊分界,DRAWNULL),COLORGREEN,LINETHICK2;
流通市值:FINANCE(40)/100000000,NODRAW;
MA5角度:ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*180/3.142,NODRAW,COLORRED;
循环年位置:(CLOSE-LLV(CLOSE,225))/(HHV(CLOSE,225)-LLV(CLOSE,225))*100,NODRAW,COLORGREEN;
X_198:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5);
X_199:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2) AND REFX(CLOSE,7)<REFX(CLOSE,3) AND REFX(CLOSE,8)<REFX(CLOSE,4);
X_200:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6);
X_201:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2) AND REFX(CLOSE,7)<REFX(CLOSE,3);
X_202:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7);
X_203:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2);
X_204:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8);
X_205:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1);
X_206:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9);
X_207:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE;
X_208:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10);
X_209:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1);
X_210:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11);
X_211:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2);
X_212:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11) AND REF(CLOSE,8)>REF(CLOSE,12);
X_213:=REFX(CLOSE,1)<REF(CLOSE,3);
X_214:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11) AND REF(CLOSE,8)<REF(CLOSE,12) AND REF(CLOSE,9)>REF(CLOSE,13);
X_215:=IF(PERIOD<4,LOW*(1-(PERIOD+1)/10*0.01),LOW*0.98);
X_216:=IF(PERIOD<4,HIGH*(1+(PERIOD+1)/10*0.01),HIGH*1.05);
X_217:=CURRBARSCOUNT-1;{WWW.GPXIAZAI.COM}
DRAWNUMBER(X_198 AND (X_199 OR X_217=0 OR (X_217=1 AND X_213) OR (X_217=2 AND X_211) OR (X_217=3 AND X_209) OR (X_217=4 AND X_207) OR (X_217=5 AND X_205) OR (X_217=6 AND X_203) OR (X_217=7 AND X_201)),X_215,1),COLORMAGENTA;
DRAWNUMBER(X_200 AND (X_201 OR X_217=0 OR (X_217=1 AND X_213) OR (X_217=2 AND X_211) OR (X_217=3 AND X_209) OR (X_217=4 AND X_207) OR (X_217=5 AND X_205) OR (X_217=6 AND X_203)),X_215,2),COLORMAGENTA;
DRAWNUMBER(X_202 AND (X_203 OR X_217=0 OR (X_217=1 AND X_213) OR (X_217=2 AND X_211) OR (X_217=3 AND X_209) OR (X_217=4 AND X_207) OR (X_217=5 AND X_205)),X_215,3),COLORMAGENTA;
DRAWNUMBER(X_204 AND (X_205 OR X_217=0 OR (X_217=1 AND X_213) OR (X_217=2 AND X_211) OR (X_217=3 AND X_209) OR (X_217=4 AND X_207)),X_215,4),COLORMAGENTA;
DRAWNUMBER(X_206 AND (X_207 OR X_217=0 OR (X_217=1 AND X_213) OR (X_217=2 AND X_211) OR (X_217=3 AND X_209)),X_215,5),COLORMAGENTA;
DRAWNUMBER(X_208 AND (X_209 OR X_217=0 OR (X_217=1 AND X_213) OR (X_217=2 AND X_211)),X_215,6),COLORMAGENTA;
DRAWNUMBER(X_210 AND (X_211 OR X_217=0 OR (X_217=1 AND X_213)),X_215,7),COLORMAGENTA;
DRAWNUMBER(X_212 AND (X_213 OR X_217<1),X_215,8),COLORMAGENTA;
DRAWNUMBER(X_214,X_215,9),COLORGREEN;
X_218:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5);
X_219:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2) AND REFX(CLOSE,7)>REFX(CLOSE,3) AND REFX(CLOSE,8)>REFX(CLOSE,4);
X_220:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6);
X_221:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2) AND REFX(CLOSE,7)>REFX(CLOSE,3);
X_222:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7);
X_223:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2);
X_224:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8);
X_225:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1);
X_226:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9);
X_227:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE;
X_228:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10);
X_229:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1);
X_230:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11);
X_231:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2);
X_232:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11) AND REF(CLOSE,8)<REF(CLOSE,12);
X_233:=REFX(CLOSE,1)>REF(CLOSE,3);
X_234:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11) AND REF(CLOSE,8)>REF(CLOSE,12) AND REF(CLOSE,9)<REF(CLOSE,13);
DRAWNUMBER(X_218 AND (X_219 OR X_217=0 OR (X_217=1 AND X_233) OR (X_217=2 AND X_231) OR (X_217=3 AND X_229) OR (X_217=4 AND X_227) OR (X_217=5 AND X_225) OR (X_217=6 AND X_223) OR (X_217=7 AND X_221)),X_216,1),COLORMAGENTA;
DRAWNUMBER(X_220 AND (X_221 OR X_217=0 OR (X_217=1 AND X_233) OR (X_217=2 AND X_231) OR (X_217=3 AND X_229) OR (X_217=4 AND X_227) OR (X_217=5 AND X_225) OR (X_217=6 AND X_223)),X_216,2),COLORMAGENTA;
DRAWNUMBER(X_222 AND (X_223 OR X_217=0 OR (X_217=1 AND X_233) OR (X_217=2 AND X_231) OR (X_217=3 AND X_229) OR (X_217=4 AND X_227) OR (X_217=5 AND X_225)),X_216,3),COLORMAGENTA;
DRAWNUMBER(X_224 AND (X_225 OR X_217=0 OR (X_217=1 AND X_233) OR (X_217=2 AND X_231) OR (X_217=3 AND X_229) OR (X_217=4 AND X_227)),X_216,4),COLORMAGENTA;
DRAWNUMBER(X_226 AND (X_227 OR X_217=0 OR (X_217=1 AND X_233) OR (X_217=2 AND X_231) OR (X_217=3 AND X_229)),X_216,5),COLORMAGENTA;
DRAWNUMBER(X_228 AND (X_229 OR X_217=0 OR (X_217=1 AND X_233) OR (X_217=2 AND X_231)),X_216,6),COLORMAGENTA;
DRAWNUMBER(X_230 AND (X_231 OR X_217=0 OR (X_217=1 AND X_233)),X_216,7),COLORMAGENTA;
DRAWNUMBER(X_232 AND (X_233 OR X_217<1),X_216,8),COLORMAGENTA;
DRAWNUMBER(X_234,X_216,9),COLORGREEN;
X_235:=REF(CLOSE,1);
X_236:=SMA(MAX(CLOSE-X_235,0),3,1)/SMA(ABS(CLOSE-X_235),3,1)*100;
X_237:=EMA(CLOSE,3);
X_238:=EMA(CLOSE,21);
X_239:=150;
X_240:=3;
X_241:=REF(HHV(HIGH,X_239),X_240);
X_242:=REF(LLV(LOW,X_239),X_240);
X_243:=X_241-(X_241-X_242)*0.191;
X_244:=X_241-(X_241-X_242)*0.382;
X_245:=X_241-(X_241-X_242)*0.5;
X_246:=X_241-(X_241-X_242)*0.618;
X_247:=X_241-(X_241-X_242)*0.809;
顶:REFDATE(X_241,DATE),COLORRED;
一0809:REFDATE(X_243,DATE),COLORYELLOW;
二0618:REFDATE(X_244,DATE),COLORMAGENTA;
三0500:REFDATE(X_245,DATE),COLORWHITE;
四0382:REFDATE(X_246,DATE),COLORGREEN;
五0191:REFDATE(X_247,DATE),COLORYELLOW;
低:REFDATE(X_242,DATE),COLORRED;

 
0

本站提示:股市有风险,入市请慎重,资料由股票下载网整理收集

下载必看(为了保障您的权益,请在下载资源前看清楚相关说明)

  • ›› 指标不属于投资资讯产品和推股软件,指标旨在辅助大家提高投资胜率参考而研发,仅供参考学习研究之用,不构成投资建议或未来保证,依此操作买卖,盈亏自负。
  • ›› 指标页面宣传的收益仅代表指标信号成立后的历史收益,收益具有不确定性,不保证未来达到同等收益。
  • ›› 您所下载的软件由股票下载网网络收集发布,不保证提供的下载资源的准确性、安全性和完整性。请自行谨慎甄别软件相关描述后再下载,股票下载网不保障和承担使用该软件投资带来的一切损失。
  • ›› 该软件仅供学习和研究使用,不得用于商业或者非法用途。本站对于提供下载的指标、软件、资讯等不拥有任何权利,其版权归该下载资源的合法拥有者所有,如有侵犯您的版权,请查看《股票下载网的侵权处理流程》,本站将于五个工作日内移除相关内容,同时要求用户在23小时内删除从本站下载的文件。
  • ›› 如果您发现下载链接错误,请点击报告错误谢谢!

找不到你要的公式?给我们建议