»查看更多分类股票软件

麟龙决策 通达信副图指标 源码 贴图

发布时间:2021-02-13 09:43:00  点击:

麟龙决策 通达信副图指标 源码 贴图


1、周期的选择以30分钟半小时线使用。

2、中间4个横线的数值分别是36、44、56、71.分别代表决策曲线的运行在71以上的高位风险区、56-71强势区、44-56弱势区、36以下的超跌区

3、8日均线(辅助线)向上运行,决策曲线向上金叉买入,死叉可以考虑卖出或者部分卖出;8日均线向下运行金叉只是反弹,谨慎买入,死叉坚决卖出。

4、按30分钟的周期选择,决策曲线运行到36一下可以开始建仓,运行到71以上可以考虑部分卖出规避风险。

麟龙决策 通达信副图指标 源码 贴图
 


DRAWGBK(CLOSE>OPEN,RGB(1,0,0),RGB(0,0,0),1,2,0);

0,COLORGRAY;
100,COLORGRAY;

{吸筹}
动态底部:EMA(IF(L<= LLV(L,30),SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(L,1),0),30,1),0),3)*3;
DRAWBAND(动态底部,RGB(6,199,183),0,RGB(0,100,0));

{筹码突破}
DP1:=REF(LOW,1);
DP2:=SMA(ABS(LOW-DP1),3,1)/SMA(MAX(LOW-DP1,0),3,1)*100;
DP3:=EMA(IF(CLOSE*1.2,DP2*10,DP2/10),3);
DP4:=LLV(LOW,38);
DP5:=HHV(DP3,38);
DP6:=IF(LLV(LOW,90),1,0);
DIF0:=EMA(IF(LOW<=DP4,(DP3+DP5*2)/2,0),3)/618*DP6,COLORRED;
XG:=CROSS(REF(DIF0,1),DIF0),LINETHICK0;
STICKLINE(DIF0>REF(DIF0,1),0,2,0.9,0),COLORYELLOW;
STICKLINE(XG,0,6,0.9,0),COLORYELLOW;

HE1:=55;
HE2:=21;
散户筹码:100*(HHV(HIGH,HE1)-CLOSE)/(HHV(HIGH,HE1)-LLV(LOW,HE1)),COLORGRAY,DOTLINE;
HE16:=(CLOSE-LLV(LOW,HE2))/(HHV(HIGH,HE2)-LLV(LOW,HE2))*100;
HE17:=SMA(HE16,3,1);
HE18:=SMA(HE17,3,1);
HE19:=3*HE17-2*HE18;
主力筹码:EMA(HE19,5),COLORGRAY;

获利比例%:=WINNER(C)*100,COLORLIBLUE;
IF(获利比例%>=0 AND 获利比例%<6,获利比例%,DRAWNULL),CIRCLEDOT,COLORWHITE;
IF(获利比例%<20 AND 获利比例%>=6,获利比例%,DRAWNULL),CIRCLEDOT,COLOR0099FF;
IF(获利比例%<50 AND 获利比例%>=20,获利比例%,DRAWNULL),CIRCLEDOT,COLORFF9933;
IF(获利比例%<80 AND 获利比例%>=50,获利比例%,DRAWNULL),CIRCLEDOT,COLORFF00FF;
IF(获利比例%<=100 AND 获利比例%>=80,获利比例%,DRAWNULL),CIRCLEDOT,COLORGREEN;

MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
P01:=IF(MA1>MA2,1,IF(MA2>MA1,-1,0));
MA3:=MA(CLOSE,3);
MA4:=MA(CLOSE,5);
P02:=IF(MA3>MA4,1,IF(MA4>MA3,-1,0));
MA5:=MA(CLOSE,12);
MA6:=MA(CLOSE,50);
P03:=IF(MA5>MA6,1,IF(MA6>MA5,-1,0));
{KDJ}
RSV9:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
K9:=EMA(RSV9,3);
D9:=EMA(K9,3);
P04:=IF(K9>D9,1,IF(D9>K9,-1,0));
{MACD}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD9:=(DIF-DEA)*2;
P05:=IF(DIF>DEA,1,IF(DEA>DIF,-1,0));
{TRIX}
TR2:=EMA(EMA(EMA(CLOSE,12),12),12);
TRIX:=(TR-REF(TR,1))/REF(TR,1)*100;
MATRIX:=MA(TRIX,9) ;
P06:=IF(TRIX>MATRIX,1,IF(MATRIX>TRIX,-1,0));
{DMI}
TR19:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),7);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP9:=EMA(IF(HD>0 AND HD>LD,HD,0),7);
DMM9:=EMA(IF(LD>0 AND LD>HD,LD,0),7);
PDI:= DMP9*100/TR;
MDI:= DMM9*100/TR;
ADX9:= EMA(ABS(MDI-PDI)/(MDI+PDI)*100,7);
ADXR9:=EMA(ADX9,7);
P07:=IF(PDI>MDI AND ADX9>PDI AND ADX9>50,3,
IF(PDI<MDI AND ADX9>MDI AND ADX9>50,-3,0));{9}
{RSI}
LC9:=REF(CLOSE,1);
RSI1:=EMA(MAX(CLOSE-LC9,0),5)/EMA(ABS(CLOSE-LC9),5)*100;{10}
P08:=IF(RSI1>80,1,IF(RSI1<20,-1,0));{10}

{CCI}
TYP9:=(HIGH+LOW+CLOSE)/3;
CCI9:=(TYP9-MA(TYP9,8))/(0.015*AVEDEV(TYP9,8));
P09:=IF(CCI9>180,2,IF(CCI9<-180,-2,0));{12}
{W%R}
WR1:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;
P10:= IF(WR1>80,1,IF(WR1<20,-1,0));{13}
{OSC}
OSC:=100*(CLOSE-MA(CLOSE,20));
P11:=IF(OSC>0,1,IF(OSC<0,-1,0));{14}
{MTM}
MOM:=CLOSE-REF(CLOSE,7);
P12:=IF(MOM>0,1,IF(MOM<0,-1,0));{15}
{DPO}
DPO:=CLOSE-REF(MA(CLOSE,11),11/2+1);
P13:=IF(DPO>0,1,IF(DPO<0,-1,0));{16}
{布林线}
MB:=MA(CLOSE,12);
R:=(CLOSE-MB)*(CLOSE-MB);
X1:=MA(R,12);
X2:=SQRT(X1);
D1:=1;
UPPER:=MB+(D1*X2);
LOWER:=MB-(D1*X2);
P14:=IF(CLOSE>UPPER,2,IF(CLOSE<LOWER,-2,0));{18}
{BRAR}
BR9:=SUM(MAX(0,HIGH-REF(CLOSE,1)),14)/SUM(MAX(0,REF(CLOSE,1)-LOW),14)*100;
AR9:=SUM(HIGH-OPEN,14)/SUM(OPEN-LOW,14)*100;
P15:=IF(BR9>350 OR AR9>180,3,IF(BR9<45 OR AR9<45,-3,0));{21}
{VR}
TH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),14);
TL:=SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),14);
TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),14);
VR:=0100*(TH*2+TQ)/(TL*2+TQ);
P16:=IF(VR>350,3,IF(VR<45,-3,0));{24}
{WVAD}


WVAD:=SUM((CLOSE-OPEN)/(HIGH-LOW)*VOL,6)/10000;
P17:=IF(WVAD>0,1,IF(WVAD<0,-1,0));{25}
{EMV}
VOLUME:=MA(VOL,4)/VOL;
MID:=100*(HIGH+LOW-REF(HIGH+LOW,1))/(HIGH+LOW);
EMV:=MA(MID*VOLUME*(HIGH-LOW)/MA(HIGH-LOW,4),4);
P18:=IF(EMV>0,1,IF(EMV<0,-1,0));{26}
{OBV}
VA9:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV9:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA9),0);
MAOBV9:=EMA(OBV9,24);
P19:=IF(OBV>MAOBV9,1,IF(OBV<MAOBV9,-1,0));{27}
{PVI}
PVI:= PVI,COLORWHITE;
MPVI:=EMA(PVI,24),COLORYELLOW;
P20:=IF(PVI>MPVI,1,IF(PVI<MPVI,-1,0));{28}
{NVI}
NVI:=NVI,COLORWHITE;
MNVI:=EMA(NVI,24),COLORYELLOW;
P21:=IF(NVI>MNVI,2,IF(NVI<MNVI,-2,0));{30}
{MASS}
MASS:=SUM(MA(HIGH-LOW,9)/MA(MA(HIGH-LOW,9),9),25);
MA7:=MA(CLOSE,9);
P22:=IF(MA7>REF(MA7,1) AND MASS>26.5,2,IF(MA7<REF(MA7,1)
AND MASS<26.5,-2,0));{32}
{VHF}
NUM:=ABS(HHV(HIGH,15)-LLV(LOW,15));
DEN:=SUM(ABS(CLOSE-REF(CLOSE,1)),15);
VHF:=IF(DEN=0,0,NUM/DEN);
VHF1:=EMA(VHF,240);
P23:=IF(VHF>VHF1,1,IF(VHF<VHF1,-1,0));{33}
{PUCU}
PU:=MA(CLOSE,13);
CU:=MA(VOL,13);
PU1:=(PU-REF(PU,1))/REF(PU,1)*100;
CU1:=(CU-REF(CU,1))/REF(CU,1)*100;

逆时针曲线:=PU1+CU1;
P24:=IF(逆时针曲线>REF(逆时针曲线,1),1,IF(逆时针曲线<REF(逆时针曲线,1),-1,0));
{ASI}
LC2:=REF(CLOSE,1);
AA9:=ABS(HIGH-LC2);
BB:=ABS(LOW-LC2);
CC:=ABS(HIGH-REF(LOW,1));
DD:=ABS(LC2-REF(OPEN,1));
R2:=IF(AA9>BB AND AA9>CC,AA9+BB/2+DD/4,IF(BB>CC AND BB>AA9,BB+AA9/2+DD/4,CC+DD/4));
X01:=(CLOSE-LC2+(CLOSE-OPEN)/2+LC2-REF(OPEN,1));
SI:=16*X01/R2*MAX(AA9,BB);
ASI:=SUM(SI,0),COLORWHITE;
MASI:=MA(ASI,6),COLORYELLOW;
P25:=IF(CLOSE<HHV(CLOSE,13) AND ASI=HHV(ASI,13),1,IF(CLOSE>LLV(CLOSE,13) AND ASI=LLV(ASI,13),-1,0));
{BIAS}
BIAS19 :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
P26:=IF(BIAS19>10,1,IF(BIAS19<-10,-1,0));
决策曲线: (36+P01+P02+P03+P04+P05+P06+P07+P08+P09+P10+P11+P12+P13+P14+P15+P16+
P17+P18+P19+P20+P21+P22+P23+P24+P25+P26)*1.36,,LINETHICK1,COLORYELLOW;
决策辅助线:MA(决策曲线,8),COLORYELLOW,DOTLINE;
STICKLINE(C>0,36,36,0.01,0),COLORGRAY;
STICKLINE(C>0,71,71,0.01,0),COLORGRAY;
DRAWTEXT(CROSS(决策曲线,36) AND REF(决策曲线,1)<36,36,'▲'),COLORRED;


{筹码进出}
VUR0:=(2*O+H+L+3*C)/7;
VUR1:=CAPITAL*VUR0;
VUR2:=SMA(AMOUNT,10,1)/1000;
VUR3:=MA(C*3,5);
VUR4:=VUR2*C*3/VUR3*1/10;
VUR5:=VUR2*O*3/VUR3*1/10;
VUR6:=VUR2*H*3/VUR3*1/10;
VUR7:=VUR2*L*3/VUR3*1/10;
VUR8:=(2*VUR5+VUR6+VUR7+3*VUR4)/7;
VUR9:=DMA(EMA(VUR4,2),SUM(V,1)*VUR8);
VUR10:=EMA(VUR9,2);
VURA:=VUR9>VUR10;
VURB:=EMA(VUR1-VUR9,1);
VURC:=REF(VURB,1);
VURD:=VURB>VURC;
VURS:=VURD AND C>O;
VURE:=(VURB-VURC)*15;
VURF:=(VUR9-VUR10)*15000;
VURG:=(VURC-VURB)*(-1);
VURH:=IF(VURB>VURC,VURE/1000,0);
VURN:=IF(VURB<VURC,VURE/1000,0);
VURT:=IF(VURA AND VURS,VURF/10000,0);
VURL:=IF(VURA AND VURB<VURC,VURE/1000,0);
吸进量:=VURH,POINTDOT,COLORRED;
吐出量:=VURN,POINTDOT,COLORGREEN;
买进强烈:=VURT,POINTDOT,COLORYELLOW;
减筹打压:=VURL,POINTDOT,COLORFFF516;
STICKLINE(VURB>VURC,0,-4,2,1),COLORRED;
STICKLINE(VURB<VURC,0,-4,2,0),COLORGREEN;
STICKLINE(VURA AND VURS,-4,-2,2,0),COLORYELLOW;
STICKLINE(VURA AND VURB<VURC,0,-4,2,0),COLORFFF516;

{反转}
VARF1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VARF2:=REF(VARF1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARF3:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARF4:=REF(VARF3,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF5:=REF(VARF3 OR VARF4,1) AND VARF1;
VARF6:=VARF5 AND CLOSE>OPEN;
VARF7:=REF(VARF1,1) AND VARF3 AND NOT(REF(C,3)=LLV(C,4));
VARF8:=(REF(VARF1 OR VARF2,1)) AND VARF3;
VARF9:=IF(C>MA(C,4),1,0)+IF(C<MA(C,4),-1,0)+IF(MA(C,5)>REF(MA(C,5),1),1,0)+IF(MA(C,5)<REF(MA(C,5),1),-1,0);
VARF10:=VARF9=-2 AND C>O;
VARF11:= EMA((CLOSE*2+HIGH+LOW)/4,13)-EMA((CLOSE*2+HIGH+LOW)/4,73);
VARF12:=(CROSS(VARF11,EMA(VARF11,2)) AND VARF11<=0.05 AND (C/REF(C,1)>0.035));
VARF13:=IF(C>MA(C,4),1,0);
VARF14:=IF(C<MA(C,4),-1,0);
VARF15:=IF(MA(C,5)>REF(MA(C,5),1),1,0);
VARF16:=IF(MA(C,5)<REF(MA(C,5),1),-1,0);
VARF17:=VARF13+VARF14+VARF15+VARF16;
VARF18:=VARF17=2 AND C<O;
VARF19:=VARF12 AND NOT(VARF18);
VARF20:=VARF6 AND VARF10=0 AND VARF19=0;
VARF21:=(CLOSE/OPEN)>1.04 AND CLOSE<SMA(HIGH,19,3) AND C>REF(C,1) AND VARF10=0;
MA10:=MA(C,10);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
VARF22:=(MAX(C,O)-MIN(C,O))/MIN(C,O)*100;
VARF23:=(H-MAX(C,O))/MAX(C,O)*100;
VARF24:=(MIN(C,O)-L)/L*100;
VARF25:=MAX(MA30,MAX(MA60,MA120));
VARF26:=MIN(MA30,MIN(MA60,MA120));
VARF261:=(VARF25-VARF26)/VARF26*100;
VARF27:=MA(REF(LLV(C,30),1),2);
VARF28:=MA30>MA60 AND MA60>MA120;
VARF29:=(REF(MIN(C,O),1)-MAX(C,O))/MAX(C,O)*100;
VARF30:=BARSLASTCOUNT(OPEN=REF(C,1))=2 AND BARSLASTCOUNT(OPEN>C AND VARF22>1.3)=3;
VARF31:=VARF30 AND VARF22<5;
VARF32:=COUNT(OPEN>C AND VARF22>2.5,3)>=2 AND C<VARF26 AND MA60=VARF25;
VARF33:=COUNT(VARF31,4)>=1 AND COUNT(VARF32,4)>=1 AND VARF10 AND C>REF(C,1) AND REF(C<OPEN,1) AND VARF261<12;
VARF34:=COUNT(VARF29>5,3)>=1 AND MA120=VARF25;
VARF35:=COUNT(VARF30,5)>=1 AND COUNT(VARF34,4)>=1 AND VARF10 AND C>REF(C,1);
VARF36:=COUNT(VARF24>7.4,2)>=1 AND C<VARF26;
VARF37:=COUNT(VARF30,5)>=1 AND VARF36 AND (VARF10 OR VARF19);
VARF38:=REF(VARF10 OR VARF20,1) AND C>OPEN;
VARF39:=REF(VARF30,2) AND VARF38 AND REF(C>VARF26 AND C<VARF25,1) AND REF(VARF18 OR VARF7,4) AND REF(CROSS(C,MA10)=0,1) AND REF(CROSS(C,VARF27)=0,1);
VARF40:=REF(VARF20,1) AND REF(C<VARF26,1) AND COUNT(VARF18,10)=0 AND COUNT(VARF7,9)=0 AND COUNT(VARF21,9)=0;
VARF41:=COUNT(VARF30,4)>=1 AND VARF40 AND REF(CROSS(C,VARF27),1) AND C>OPEN AND REF(VARF23,1)<1;
VARF42:=REF(VARF22<1,1) AND REF(MAX(C,OPEN),1)>REF(C,2) AND VARF20 AND VARF22<1.5 AND C>REF(C,1) AND C>VARF25 AND VARF28;
VARF43:=REF(VARF30,2) AND VARF42;
VARF44:=REF(C<OPEN AND VARF22<1 AND VARF22*2<VARF23,1) AND C<OPEN AND BARSLASTCOUNT(MAX(OPEN,C)>REF(MIN(OPEN,C),1))>=2 AND REF(OPEN,1)<VARF26;
VARF45:=COUNT(VARF30,4)>=1 AND REF(VARF44,1) AND VARF20 AND C>REF(C,1);
反转2:VARF33 OR VARF35 OR VARF37 OR VARF39 OR VARF41 OR VARF43 OR VARF45;
DRAWICON(反转2,3,38);
DRAWTEXT(反转2,5,'反转'),COLORYELLOW;

{顶底背离}
K值:="KDJ.K";
DD1:=C=LLV(C,60);{60日最低点}
DDSJ:=BARSLAST(REF(DD1,1));{上一低点时间}
DDGJ:=REF(CLOSE,DDSJ+1)>CLOSE;{股价趋势}
KDZB:=REF(K值,DDSJ+1)<K值;{KDJ.K指标趋势}
K底背离:=DDGJ AND KDZB;
GD:=C=HHV(C,60);{60日最高点}
GDSJ:=BARSLAST(REF(GD,1));{上一高点时间}
GDGJ:=REF(CLOSE,GDSJ+1)<CLOSE;{股价趋势}
KGZB:=REF(K值,GDSJ+1)>K值;
K顶背离:=GDGJ AND KGZB;
MACD1:="MACD.MACD";
MDZB:=REF(MACD1,DDSJ+1)<MACD1;{MACD指标趋势}
M底背离:=DDGJ AND MDZB;
MGZB:=REF(MACD1,GDSJ+1)>MACD1;
M顶背离:=GDGJ AND MGZB;
RSI11:="RSI.RSI1";
RDZB:=REF(RSI11,DDSJ+1)<RSI;{RSI指标趋势}
R底背离:=DDGJ AND RDZB;
RGZB:=REF(RSI,GDSJ+1)>RSI;
R顶背离:=GDGJ AND RGZB;
TYP:=(HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
CDZB:=REF(CCI,DDSJ+1)<CCI;{CCI指标趋势}
C底背离:=DDGJ AND CDZB;
CGZB:=REF(CCI,GDSJ+1)>CCI;
C顶背离:=GDGJ AND CGZB;
DRAWTEXT(K顶背离,102,'-'),COLORGREEN;
DRAWTEXT(K底背离,102,'-'),COLORRED;
DRAWTEXT(M顶背离,103,'-'),COLORGREEN,;
DRAWTEXT(M底背离,103,'-'),COLORRED;
DRAWTEXT(R顶背离,104,'-'),COLORGREEN;
DRAWTEXT(R底背离,104,'-'),COLORRED;
DRAWTEXT(C顶背离,105,'-'),COLORGREEN,;
DRAWTEXT(C底背离,105,'-'),COLORRED;
LC:=REF(CLOSE,1);
RSI111:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RS:=LLV(L,55)<REF(LLV(L,55),1) AND RSI111>(REF(LLV(RSI111,55),1)+2) AND RSI111>REF(RSI111,1);
DRAWTEXT(RS,100,'R'),COLORRED;

{买1}
MA51:=EMA(C,5);
VARC:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1);
准备建仓:=EMA(IF(L<= LLV(L,30),VARC,0),3),COLORFF00FF,LINETHICK2;
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
建仓区:=IF((VARO7<10),80,100) ,COLORFFFF00,LINETHICK3;

买1:=IF(CROSS(3*SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1),3,1),10),38,0),COLORYELLOW,NODRAW;


{买2}
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS31:=(C-MA(C,24))/MA(C,24)*100;
BIAS0:=(BIAS1+2*BIAS2+3*BIAS31)/6;
乖离1:=MA(BIAS0,3);
乖离:=CROSS(BIAS0,乖离1) AND 乖离1<-9;
买2:=IF(CROSS(BIAS0,乖离1) AND 乖离1<-9,18,0),COLORRED,NODRAW;


{买3}
TRJ:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),5);
HD1:=(HIGH - REF(HIGH,1));
LD1:=(REF(LOW,1) - LOW);
DMP:=(SUM(IF(((HD1 > 0) AND (HD1 > LD1)),HD1,0),5) );
DMM:=SUM(IF(((LD1 > 0) AND (LD1 > HD1)),LD1,0),5);
神偷线:=(((DMP ) * 100) / TRJ);
辅助线:=((DMM * 100) / TRJ);
动向趋势线:=(MA(((ABS((辅助线 - 神偷线)) / (辅助线 + 神偷线)) * 100),3));
ADXR:=((动向趋势线 + REF(动向趋势线,3)) / 2);
VAR33:=MA(CLOSE,2);
VAR71:=REF(VAR33,1);
强弱:=((SMA(MAX((VAR33 - VAR71),0),5,1) / SMA(ABS((VAR33 - VAR71)),5,1)) * 100);
VAR31:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR32:=8;{www.gpxiazai.com}
CC3:=CROSS(VAR31,VAR32);
买3:=( IF(((动向趋势线 > 88) AND (神偷线 < 5.8)),68,0)) AND CC3,COLORFF00FF,NODRAW;

{买4}
VAR10:=(CLOSE*2+HIGH+LOW)/4;
SK:= EMA(VAR10,13)-EMA(VAR10,73);
SD:= EMA(SK,2);
V1:=(CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03)
OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05
AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035));
买4:=V1,COLORBLUE,NODRAW;

{买5}

FX1:=MA(CLOSE,1);
FX2:=(LOW+HIGH+CLOSE)/3;
FX3:= MA(FX2,5);
FX4:=LLV(FX3,10);
买5:=LLV((FX1<FX4),5);


{买6}
A311:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A411:=SMA(A311,3,1);
A511:=SMA(A411,3,1);
A611:=3*A411-2*A511;
A711:=C-REF(C,1);
A811:=100*EMA(EMA(A711,6),6)/EMA(EMA(ABS(A711),6),6);
MAI1:=LLV(A811,2)=LLV(A811,7) AND COUNT(A811<0,2) AND CROSS(A811,MA(A811,2));
AR1:=3*SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1)-2*SMA(SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1),3,1);
MAI2:=CROSS(AR1,REF(AR1+0.01,1)) AND LLV(AR1,2)=LLV(AR1,8) AND AR1<20;
买6:=MAI1 AND MAI2;

{买7}
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
AA10:=MA(C,10);
AA20:=MA(C,20);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击选股:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买7:=IF(FILTER(MR,10),30,0),COLORYELLOW,NODRAW;


{买8}
LC8:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC8),0),5,1) / SMA(ABS((CLOSE - LC8)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD8:=(HIGH - REF(HIGH,1));
LD8:=(REF(LOW,1) - LOW);
DMP8:=SUM(IF(((HD8 > 0) AND (HD8 > LD8)),HD8,0),10);
DMM8:=SUM(IF(((LD8 > 0) AND (LD8 > HD8)),LD8,0),10);
PDI8:=((DMP8 * 100) / TR1);
MDI8:=((DMM8 * 100) / TR1);
ADX:=MA(((ABS((MDI8 - PDI8)) / (MDI8 + PDI8)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
最佳买入选股:=IF(CROSS(最佳买入,0),1,0),STICK,COLORRED;
VARM1:=SMA(最佳买入选股,3,1);
VARM2:=SMA(VARM1,3,1),COLOR0000FF;
VARM3:=SMA(VARM2,3,1),COLOR00FFFF;
买8:=IF(CROSS(VARM2,VARM3) AND (VARM2<40),5,0*10000),COLOR0000FF,NODRAW;

{买9}
AR1A:=3*SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1)-2*SMA(SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1),3,1);
短买:=CROSS(AR1A,REF(AR1A+0.01,1)) AND LLV(AR1A,2)=LLV(AR1A,8) AND AR1A<20,COLORCYAN,NODRAW;
买9:=短买;

XG11:=买1 AND 买2;
XG12:=买1 AND 买3;
XG13:=买1 AND 买4;
XG14:=买1 AND 买5;
XG15:=买2 AND 买3;
XG16:=买2 AND 买4;
XG17:=买2 AND 买5;
XG18:=买3 AND 买4;
XG19:=买3 AND 买5;
XG110:=买4 AND 买5;
XG01:=买6,COLORRED,NODRAW;
XG2:=买9,COLORGREEN,NODRAW;
XG3:=买8=5,COLORMAGENTA,NODRAW;
XG4:=买7,COLORCYAN,NODRAW;
XG5:=XG11 OR XG12 OR XG13 OR XG14 OR XG15 OR XG16 OR XG17 OR XG18 OR XG19 OR XG110,COLORYELLOW,NODRAW;
STICKLINE(XG2,91,92,1,0),COLORRED;
STICKLINE(XG5,92,93,1,0),COLORYELLOW;
STICKLINE(XG3,93,94,1,0),COLORMAGENTA;
STICKLINE(XG4,94,95,1,0),COLORCYAN;
STICKLINE(XG01,95,96,1,0),COLORGREEN;

N:=20;M1:=4;M2:=2;Q1:=30;
VAR2:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
VAR3:=SMA(VAR2,M1,1);
VAR4:=SMA(VAR3,M2,1);
VAR5:=VOL/CAPITAL*100;
VAR6:=REF(VAR5,1);
机构建仓: (VAR4<14.5 AND VAR3<11)*10,COLORRED,LINETHICK2;
机构减仓: (VAR4>82 AND VAR3>89)*10,COLORGREEN,LINETHICK2;
A:=REF(C,1);
RSI:=SMA(MAX(C-A,0),6,1)/SMA(ABS(C-A),6,1)*100;
A1:=C-MA(C,5)/MA(C,5)*100<1;
A2:=C-MA(C,13)/MA(C,13)*100<-10;
A3:=C-MA(C,34)/MA(C,34)*100<-15;
A4:=RSI<18;
A5:=CCI<-120;
组合底部:(A1 AND A2 AND A3 AND A4 AND A5)*10,COLORGRAY,LINETHICK2;
0,COLORGRAY,LINETHICK2;


 
麟龙决策 通达信副图指标 源码 贴图
打开微信扫一扫,一键复制指标源码,
轻松快捷粘贴至手机通达信APP中。
0

本站提示:股市有风险,入市请慎重,资料由股票下载网整理收集

找不到你要的公式?给我们建议

  1. 股票软件
    股票分析软件
    股票交易软件
    股票行情软件
    指标股票池
    手机炒股软件
    书籍教程
    数据软件
    工具补丁
    大智慧
    通达信
    飞狐
    东方财富通
    操盘手
    指南针
    分析家
    同花顺
    钱龙
    证券之星
    券商股票软件
    特色行情软件
    迷你行情软件
    金融界软件
    美股外盘软件
    大智慧股票池
    通达信股票池
    大智慧L2公式
    通达信公式
    飞狐公式
    同花顺公式
    股票书藉
    视频教程
    金融书籍
    其他书籍
    资讯评测软件
    资金分析软件
    数据接口软件
    江恩波浪软件
    数据下载软件
    软件数据投资
    选股软件
    登录补丁
    其他应用
    股软教程
  2. 股票公式
    通达信公式
    大智慧公式
    飞狐公式
    同花顺公式
    东方财富通公式
    金字塔指标公式
    文华指标公式
    MT4指标
    博易大师指标
    公式教程答疑
  3. 炒股知识
    短线技巧
    软件公式
    炒股视频
    股票入门
    股市实战信息交流
    炒股技巧
    股票基础知识
    技术分析
    炒股一招先
    基本面分析
    股票视频教程
    股票买卖技巧
    k线图分析
    胡立阳教你买股票
    短线炒股技巧
    天狼之眼
    波浪理论技术讲解
    股市赢家杨百万
    股票理论、T0缠论、知识
    经典指标、交易系统
    成交量能、筹码分析
    买卖信号、技术分析
    挖坑、冼盘、吸筹、出货
    均线战法、黄金分割
    经典K线、趋势形态
    牛股黑马、王子理论
    涨停、周线、月线
    止盈、止损、支撑、压力
    案例、波浪、口诀、选股
    分时、盘口、补仓、解套
  4. 技术指标
    DDX
    DDY
    DDZ
    MACD
    KDJ
    CCI
    OBV
    BOLL
    RSI
    VOL
    CR
    WR