»查看更多分类股票软件

天顺人和 与MACD配合使用效果最佳 通达信分时主图指标 源码 贴图

发布时间:2021-01-10 10:24:00  点击:

天顺人和 与MACD配合使用效果最佳 通达信分时主图指标 源码 贴图


自用分时主图,经过四次修改,一个分时引用,一个分时主图,与MACD配合使用效果最佳。具体用法可以自己体会。



分时引用:

HS:HSL;
前1换手:REF(HSL,1);
前2换手:REF(HSL,2);
前3换手:REF(HSL,3);
前4换手:REF(HSL,4);

及时换手率:HSL*100;

均5量:MA(VOL,5)/10000;

总涨跌比:=DYNAINFO(60)/(DYNAINFO(60)+DYNAINFO(61))*100;

基准量:(MA(VOL,5)+MA(VOL,10))/2;


AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),NODRAW;
主动卖盘:IF(CLOSE>OPEN,AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,AA*(HIGH-LOW),VOL/2)),NODRAW;
买卖比:主动买盘/主动卖盘,NODRAW;

ZF:=(C/REF(C,1)-1)*100;
涨速:SUM(ZF,5);

VACAR1:=(CLOSE+HIGH+LOW)/3;
MA5:MA(VACAR1,5),NODRAW;
MA20:MA(VACAR1,20),NODRAW;


当前量:VOL/10000;
HST:REF(VOL,1)/10000;
HST2:REF(VOL,2)/10000;

{黄金分割线引用}
关键点位:(REF(H,1)+REF(L,1)+REF(C,1))/3,COLORGRAY;
阻力3:REF(H,1)-2*((REF(L,1)-关键点位)),COLORGREEN;
阻力2:关键点位+(REF(H,1)-REF(L,1)),COLORYELLOW;
阻力1:2*关键点位-REF(L,1),COLORBLUE;
支撑1:2*关键点位-REF(H,1),COLORBLUE;
支撑2:关键点位-(REF(H,1)-REF(L,1)),COLORYELLOW;
支撑3:REF(L,1)-2*(REF(H,1)-关键点位),COLORGREEN;

{分时K线引用}
O1:REF(O,1);
C1:REF(C,1);
H1:REF(H,1);
L1:REF(L,1);
O2:REF(O,2);
C2:REF(C,2);
H2:REF(H,2);
L2:REF(L,2);
O3:REF(O,3);
C3:REF(C,3);
H3:REF(H,3);
L3:REF(L,3);
O4:REF(O,4);
C4:REF(C,4);
H4:REF(H,4);
L4:REF(L,4);
O5:REF(O,5);
C5:REF(C,5);
H5:REF(H,5);
L5:REF(L,5);
O6:REF(O,6);
C6:REF(C,6);
H6:REF(H,6);
L6:REF(L,6);

天顺人和 与MACD配合使用效果最佳 通达信分时主图指标 源码 贴图

天顺人和 与MACD配合使用效果最佳 通达信分时主图指标 源码 贴图
 


{改绿背景 放最上面}
DRAWGBK(C>0, RGB(10,10,10),RGB(38,90,0),0,'11',0);

{基本面}
净资收益率:=(FINANCE(33)/FINANCE(34)*100);
主营利润率:=(FINANCE(23)/FINANCE(20)*100);
主营业增长率:=FINANCE(44);
净利润增长率:=FINANCE(43);
每股收益:=CONST(FINANCE(38));
每股净资产:=CONST(FINANCE(34));
每股未分配:=CONST(FINANCE(32));
每股公积金:=CONST(FINANCE(18));
A股流通:=FINANCE(7)/100000000;
市盈率:=DYNAINFO(39);
换手率:=VOL/CAPITAL*100;
量比:=DYNAINFO(17);
ER1:=净资收益率>3;
ER12:=净资收益率<3 AND 净资收益率>1;
ER2:=主营利润率>5;
ER22:=主营利润率>1;
ER4:=主营业增长率>5;
ER42:=主营业增长率>1;
ER5:=净利润增长率>5;
ER52:=净利润增长率>0.5;
SAX1:=每股收益>0.01;
SAX12:= 每股收益>0.002;
SAX2:=每股净资产>2;
SAX22:=每股净资产>0.2;
SAX4:=每股未分配>0.5;
SAX42:=每股未分配>0.01;
SAX5:=每股公积金>0.5;
SAX52:=每股公积金>0.05;
DP2:=A股流通<20;
DP22:=A股流通<5000;
DP3:=市盈率<200;
DP32:=市盈率<5000;
DP4:=换手率>1;
DP42:=换手率>0.5;
WMF1:=量比>0.8;
WMF12:=量比>0.5;
优秀:=ER1 AND ER2 AND ER4 AND ER5 AND SAX1 AND SAX2 AND SAX4 AND SAX5 AND DP2 AND DP3 AND DP4 AND WMF1;
较好:=ER12 AND ER22 AND ER42 AND ER52 AND SAX12 AND SAX22 AND SAX42 AND SAX52 AND DP22 AND DP32 AND DP42 AND WMF12;
DRAWTEXT_FIX(优秀,0.5,0.01,0,'基本面:优秀级!'),COLORRED;
DRAWTEXT_FIX(较好,0.5,0.05,0,'基本面:较好!'),COLORMAGENTA;


FX:=IF(C>REF(C,1),1,IF(C<REF(C,1),-1,0));
TT:=BARSLAST(HOUR=9 AND MINUTE=31 AND V>0)+1 ;

昨收:=引用个股.昨日收盘#DAY;
最高价:=CONST(HHV((C/昨收-1)*100,TT));
最低价:=CONST(LLV((C/昨收-1)*100,TT));
单位:=CONST((最高价-最低价)/40);

多方:=SUM(IF(FX=1,V,0),TT)/SUM(V,TT)*100;
空方:=SUM(IF(FX=-1,V,0),TT)/SUM(V,TT)*100;
平衡:=SUM(IF(FX=0,V,0),TT)/SUM(V,TT)*100;

DRAWTEXT_FIX(1,0.15,0,0,STRCAT(STRCAT(STRCAT('多方:',CON2STR(多方,1)),
STRCAT('平衡:',CON2STR(平衡,1))),STRCAT('空方:',CON2STR(空方,1)))),COLORYELLOW;
DRAWTEXT_FIX(1,0,0,0,STRCAT('最小单位:',CON2STR(单位,3))),COLORLIGRAY;

{当前量}
DRAWTEXT_FIX(ISLASTBAR,0.28,0.05,0,'当前量: '),COLORCYAN;
DRAWNUMBER_FIX(ISLASTBAR,0.328,0.05,0.5,V/10000)COLORYELLOW;

{涨跌提示}

ZSTJJ,COLORYELLOW,LINETHICK2;
最新:CLOSE,LINETHICK2,COLORWHITE;
DRAWTEXT( ISLASTBAR AND 最新>REF(最新,1),最新,STRCAT(' 涨',CON2STR(最新,2))),COLOR0000FF;
DRAWTEXT( ISLASTBAR AND 最新<REF(最新,1),最新,STRCAT(' 跌',CON2STR(最新,2))),COLOR00FF00;

MA5:="分时引用.MA5#DAY";
DRAWTEXT(FILTER(CROSS(MA5,C),10),L,'↑破5'),COLORGREEN;
DRAWTEXT(FILTER(CROSS(C,MA5),10),L,'↑上5'),COLORMAGENTA;

{显示自定义板块}
DRAWTEXT_FIX(1,0.08,0.98,0,ZDBLOCK),COLORRED;

{大盘}{www.gpxiazai.com}
AAAB1:=STRCAT('沪深总上涨:',CON2STR(DYNAINFO(60),0));
AAAB2:=STRCAT('沪深总下跌:',CON2STR(DYNAINFO(61),0));
DRAWTEXT_FIX(ISLASTBAR,0.8,0,0,AAAB1),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.9,0,0,AAAB2),COLORGREEN;

流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
DRAWTEXT_FIX(ISLASTBAR,0.58,0.02,0,流通盘),COLORGREEN;

关键点:"分时引用.关键点位#DAY",COLORWHITE;

{顶底预判}
HH:=MAX(DYNAINFO(3),DYNAINFO(5));
LL:=MIN(DYNAINFO(3),DYNAINFO(6));
PP:=HH-LL;阻力:LL+PP*7/8,COLOR00DD00;
支撑:LL+PP*0.5/8,COLORLIGREEN;
现价:CLOSE,COLORWHITE,LINETHICK2;
XG:LONGCROSS(支撑,现价,2),NODRAW;
STICKLINE(CROSS(支撑,现价),支撑,(支撑+阻力)/2,2,0),COLORRED;
STICKLINE(CROSS(现价,阻力),阻力,(支撑+阻力)/2,2,0),COLORGREEN;
DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.001,'★吸'),LINETHICK2,,COLORYELLOW;
DRAWTEXT(LONGCROSS(现价,阻力,2),现价,'★抛'),LINETHICK2,COLORRED;


{分时显示}

DQL:="分时引用.当前量#DAY";
MHST:="分时引用.HST#DAY";
QHST:="分时引用.HST2#DAY";
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.35,0.85,0,STRCAT('量: ',CON2STR(DQL,2))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.35,0.90,0,STRCAT('昨: ',CON2STR(MHST,2))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.35,0.95,0,STRCAT('前: ',CON2STR(QHST,2))),COLORYELLOW;

J5L:="分时引用.均5量#DAY";
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.45,0.90,0,STRCAT('五均量: ',CON2STR(J5L,2))),COLORYELLOW;

MHS:="分时引用.HS#DAY";
MHS2:="分时引用.前1换手#DAY";
MHS3:="分时引用.前2换手#DAY";

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.25,0.85,0,STRCAT('换: ',CON2STR(MHS,2))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.25,0.90,0,STRCAT('昨: ',CON2STR(MHS2,2))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.25,0.95,0,STRCAT('前: ',CON2STR(MHS3,2))),COLORYELLOW;


DRAWTEXT_FIX(1,0.20,0.85,0,STRCAT('五均换:',CON2STR(引用个股.五日每分钟均量#DAY*240/CAPITAL*100,2))),COLORLIGRAY;
DRAWTEXT_FIX(1,0.20,0.90,0,STRCAT('预计:',CON2STR(SUM(V,0)/TT*240/CAPITAL*100,2))),COLORYELLOW;


{开盘放量三蝴蝶 越前越好}
BBAQX:DYNAINFO(3)*1.014,LINETHICK2,COLORAAB220;
XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));
黄线1:=EXPMA(CLOSE/XX,20);
粉线:=EXPMA(CLOSE/XX,60);
绿线:=EXPMA(CLOSE/XX,120);
XGG:DRAWICON(黄线1>粉线 AND 粉线>绿线 AND C>EXPMA(C,20) AND EXPMA(C,10)>EXPMA(C,20) AND EXPMA(C,20)>EXPMA(C,60) AND 黄线1=HHV(黄线1,30) AND CROSS(黄线1,1.003),BBAQX,28);
DRAWICON(XGG,BBAQX*0.99,28);
DRAWICON(XGG,BBAQX*0.98,28);
XGGS:DRAWTEXT(XGG,BBAQX*0.98,' 放量'),COLORMAGENTA;

{最佳买点}
DRAWTEXT((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.9998,
' ←————————— 最佳买点'),COLORWHITE;


 
天顺人和 与MACD配合使用效果最佳 通达信分时主图指标 源码 贴图
打开微信扫一扫,一键复制指标源码,
轻松快捷粘贴至手机通达信APP中。
0

本站提示:股市有风险,入市请慎重,资料由股票下载网整理收集

找不到你要的公式?给我们建议

  1. 股票软件
    股票分析软件
    股票交易软件
    股票行情软件
    指标股票池
    手机炒股软件
    书籍教程
    数据软件
    工具补丁
    大智慧
    通达信
    飞狐
    东方财富通
    操盘手
    指南针
    分析家
    同花顺
    钱龙
    证券之星
    券商股票软件
    特色行情软件
    迷你行情软件
    金融界软件
    美股外盘软件
    大智慧股票池
    通达信股票池
    大智慧L2公式
    通达信公式
    飞狐公式
    同花顺公式
    股票书藉
    视频教程
    金融书籍
    其他书籍
    资讯评测软件
    资金分析软件
    数据接口软件
    江恩波浪软件
    数据下载软件
    软件数据投资
    选股软件
    登录补丁
    其他应用
    股软教程
  2. 股票公式
    通达信公式
    大智慧公式
    飞狐公式
    同花顺公式
    东方财富通公式
    金字塔指标公式
    文华指标公式
    MT4指标
    博易大师指标
    公式教程答疑
  3. 炒股知识
    短线技巧
    软件公式
    炒股视频
    股票入门
    股市实战信息交流
    炒股技巧
    股票基础知识
    技术分析
    炒股一招先
    基本面分析
    股票视频教程
    股票买卖技巧
    k线图分析
    胡立阳教你买股票
    短线炒股技巧
    天狼之眼
    波浪理论技术讲解
    股市赢家杨百万
    股票理论、T0缠论、知识
    经典指标、交易系统
    成交量能、筹码分析
    买卖信号、技术分析
    挖坑、冼盘、吸筹、出货
    均线战法、黄金分割
    经典K线、趋势形态
    牛股黑马、王子理论
    涨停、周线、月线
    止盈、止损、支撑、压力
    案例、波浪、口诀、选股
    分时、盘口、补仓、解套
  4. 技术指标
    DDX
    DDY
    DDZ
    MACD
    KDJ
    CCI
    OBV
    BOLL
    RSI
    VOL
    CR
    WR