»查看更多分类股票软件

通达信主图识妖02版 主图/选股 源码

发布时间:2019-07-02 10:13:00  点击:




 



MM:MA(CLOSE,10);
MM2:MA(CLOSE,10),COLORYELLOW,LINETHICK2;
MM3:IF(MM2>REF(MM2,1),MM2,DRAWNULL),COLORMAGENTA;
搏杀持股线:IF(MM>REF(MM,1),MM,DRAWNULL),COLORRED,LINETHICK2;
MM55:IF(MM<REF(MM,1),MM,DRAWNULL),COLORGREEN,LINETHICK2;
X_1:=(CLOSE+OPEN)/2;
X_2:=CLOSE>REF(CLOSE,1)*1.05;
X_3:=CLOSE<REF(CLOSE,1)*0.95;
STICKLINE(X_2,X_1,OPEN,1,0),COLORMAGENTA;
STICKLINE(X_3,X_1,OPEN,1,0),COLORCYAN;
X_4:=CLOSE>REF(CLOSE,1)*1.08;
X_5:=CLOSE<REF(CLOSE,1)*0.92;
STICKLINE(X_4,CLOSE,OPEN,2,0),COLORRED;
STICKLINE(X_5,CLOSE,OPEN,2,0),COLORCYAN;
X_6:=CLOSE>REF(CLOSE,1)*1.093;
X_7:=(CLOSE+OPEN)/2;
STICKLINE(X_6,X_7,CLOSE,0.02,0),COLORYELLOW;
X_8:=(HIGH+LOW+CLOSE*2)/4;
X_9:=EMA(X_8,10);
X_10:=STD(X_8,10);
X_11:=(X_8-X_9)*100/X_10;
X_12:=EMA(X_11,5);
X_13:=EMA(X_12,10)+100/2-5;
决杀线:MA(CLOSE,20),COLORWHITE;
X_14:=3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1),3,1);
X_15:=EMA(X_14,5);
X_16:=CLOSE=OPEN AND HIGH!=LOW OR CLOSE=OPEN AND HIGH/LOW>1.03 OR CLOSE=OPEN AND CLOSE=LOW AND CLOSE!=HIGH OR REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) OR OPEN>CLOSE AND OPEN/REF(CLOSE,1)>=1+4/100 AND CLOSE/OPEN<=1-5/100 OR ABS(HIGH-REF(HIGH,1))/HIGH<0.001 OR OPEN>=CLOSE AND ABS(HIGH-OPEN)>=ABS(OPEN-LOW) OR CLOSE>=OPEN AND ABS(HIGH-CLOSE)>=ABS(CLOSE-LOW) OR OPEN>REF(CLOSE,1) AND OPEN>CLOSE;
X_17:=CLOSE>=OPEN AND ABS(HIGH-OPEN)<=ABS(OPEN-LOW) OR CLOSE<=OPEN AND ABS(HIGH-CLOSE)<=ABS(CLOSE-LOW);
X_18:=X_16 OR X_17;
X_19:=X_13>REF(X_13,1) AND CLOSE!=OPEN AND CLOSE/REF(CLOSE,1)<1.099;
X_20:=X_13>170 AND X_18 AND X_19 AND COUNT(CLOSE/REF(CLOSE,1)>1.09 AND CLOSE!=OPEN,20)<=4>=5;
X_21:=X_13>170 AND COUNT(CLOSE/REF(CLOSE,1)>1.093,15)>=5 OR BARSLASTCOUNT(CLOSE/REF(CLOSE,1)>=1.093)>=5 AND CLOSE!=OPEN;
X_22:=ABS(LOW-OPEN)<ABS(OPEN-CLOSE) AND CLOSE/REF(CLOSE,1)>1.093 AND REF(CLOSE,1)/REF(CLOSE,2)<1.093 AND REF(CLOSE,97)>-1.099 AND REF(CLOSE,2)/REF(CLOSE,3)<1.093 AND REF(CLOSE,3)/REF(CLOSE,4)<1.093 AND REF(CLOSE,4)/REF(CLOSE,5)<1.093 AND REF(CLOSE,5)/REF(CLOSE,6)<1.093 AND NOT(CLOSE=OPEN AND CLOSE/REF(CLOSE,1)>1.099);
X_23:=CLOSE/REF(CLOSE,1)>1.093 AND VOL<REF(VOL,1) AND REF(CLOSE,1)/REF(CLOSE,2)<1.093 AND COUNT(CLOSE/REF(CLOSE,1)>1.093,20)<3;
X_24:=X_20 OR X_21 AND CLOSE>MA(CLOSE,5) AND CLOSE>MA(CLOSE,30) AND MA(CLOSE,5)>MA(CLOSE,10) AND CLOSE>MA(CLOSE,60) AND REF(CLOSE,1)/REF(CLOSE,2)<1.08 AND CLOSE/REF(CLOSE,1)>CLOSE/REF(OPEN,1);
X_25:=(HIGH-LLV(LOW,90))/LLV(LOW,90)*100>120 AND X_15>=REF(X_15,1) AND X_15>95 AND CLOSE/REF(CLOSE,1)<1.099;
X_26:=X_15>100 AND CLOSE!=OPEN AND CLOSE/REF(CLOSE,1)!=CLOSE/REF(OPEN,1);
X_27:=X_24 OR X_25 OR X_26;
X_28:=X_22 OR X_23 AND COUNT(CLOSE/REF(CLOSE,1)>1.05,10)<=4 AND SUM(X_27,12)<1;
DRAWICON(X_22 OR X_23 AND COUNT(CLOSE/REF(CLOSE,1)>1.05,10)<=4 AND SUM(X_27,12)<1 AND SUM(X_28,20)<2,OPEN,23);
DRAWTEXT(X_22 OR X_23 AND COUNT(CLOSE/REF(CLOSE,1)>1.05,10)<=4 AND SUM(X_27,12)<1 AND SUM(X_28,20)<2,LOW-0.05,'妖气'),COLORMAGENTA;
STICKLINE(X_22 OR X_23 AND COUNT(CLOSE/REF(CLOSE,1)>1.05,10)<=4 AND SUM(X_27,12)<1 AND SUM(X_28,20)<2,X_7,CLOSE,0.002,0),COLORWHITE;
DRAWTEXT_FIX(1,0.4,4,0,'股林绝技-原创指标'),COLORYELLOW;

 


{公式名称:精选妖股02版}
MM:=MA(CLOSE,10);
MM2:=MA(CLOSE,10),COLORYELLOW,LINETHICK2;
MM3:=IF(MM2>REF(MM2,1),MM2,DRAWNULL),COLORMAGENTA;
搏杀持股线:=IF(MM>REF(MM,1),MM,DRAWNULL),COLORRED,LINETHICK2;
MM55:=IF(MM<REF(MM,1),MM,DRAWNULL),COLORGREEN,LINETHICK2;
X_1:=(CLOSE+OPEN)/2;
X_2:=CLOSE>REF(CLOSE,1)*1.05;
X_3:=CLOSE<REF(CLOSE,1)*0.95;
X_4:=CLOSE>REF(CLOSE,1)*1.08;
X_5:=CLOSE<REF(CLOSE,1)*0.92;
X_6:=CLOSE>REF(CLOSE,1)*1.093;
X_7:=(CLOSE+OPEN)/2;
X_8:=(HIGH+LOW+CLOSE*2)/4;
X_9:=EMA(X_8,10);
X_10:=STD(X_8,10);
X_11:=(X_8-X_9)*100/X_10;
X_12:=EMA(X_11,5);
X_13:=EMA(X_12,10)+100/2-5;
决杀线:=MA(CLOSE,20);
X_14:=3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1),3,1);
X_15:=EMA(X_14,5);
X_16:=CLOSE=OPEN AND HIGH!=LOW OR CLOSE=OPEN AND HIGH/LOW>1.03 OR CLOSE=OPEN AND CLOSE=LOW AND CLOSE!=HIGH OR REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) OR OPEN>CLOSE AND OPEN/REF(CLOSE,1)>=1+4/100 AND CLOSE/OPEN<=1-5/100 OR ABS(HIGH-REF(HIGH,1))/HIGH<0.001 OR OPEN>=CLOSE AND ABS(HIGH-OPEN)>=ABS(OPEN-LOW) OR CLOSE>=OPEN AND ABS(HIGH-CLOSE)>=ABS(CLOSE-LOW) OR OPEN>REF(CLOSE,1) AND OPEN>CLOSE;
X_17:=CLOSE>=OPEN AND ABS(HIGH-OPEN)<=ABS(OPEN-LOW) OR CLOSE<=OPEN AND ABS(HIGH-CLOSE)<=ABS(CLOSE-LOW);
X_18:=X_16 OR X_17;
X_19:=X_13>REF(X_13,1) AND CLOSE!=OPEN AND CLOSE/REF(CLOSE,1)<1.099;
X_20:=X_13>170 AND X_18 AND X_19 AND COUNT(CLOSE/REF(CLOSE,1)>1.09 AND CLOSE!=OPEN,20)<=4>=5;
X_21:=X_13>170 AND COUNT(CLOSE/REF(CLOSE,1)>1.093,15)>=5 OR BARSLASTCOUNT(CLOSE/REF(CLOSE,1)>=1.093)>=5 AND CLOSE!=OPEN;
X_22:=ABS(LOW-OPEN)<ABS(OPEN-CLOSE) AND CLOSE/REF(CLOSE,1)>1.093 AND REF(CLOSE,1)/REF(CLOSE,2)<1.093 AND REF(CLOSE,5)>-1.099 AND REF(CLOSE,2)/REF(CLOSE,3)<1.093 AND REF(CLOSE,3)/REF(CLOSE,4)<1.093 AND REF(CLOSE,4)/REF(CLOSE,5)<1.093 AND REF(CLOSE,5)/REF(CLOSE,6)<1.093 AND NOT(CLOSE=OPEN AND CLOSE/REF(CLOSE,1)>1.099);
X_23:=CLOSE/REF(CLOSE,1)>1.093 AND VOL<REF(VOL,1) AND REF(CLOSE,1)/REF(CLOSE,2)<1.093 AND COUNT(CLOSE/REF(CLOSE,1)>1.093,20)<3;
X_24:=X_20 OR X_21 AND CLOSE>MA(CLOSE,5) AND CLOSE>MA(CLOSE,30) AND MA(CLOSE,5)>MA(CLOSE,10) AND CLOSE>MA(CLOSE,60) AND REF(CLOSE,1)/REF(CLOSE,2)<1.08 AND CLOSE/REF(CLOSE,1)>CLOSE/REF(OPEN,1);
X_25:=(HIGH-LLV(LOW,90))/LLV(LOW,90)*100>120 AND X_15>=REF(X_15,1) AND X_15>95 AND CLOSE/REF(CLOSE,1)<1.099;
X_26:=X_15>100 AND CLOSE!=OPEN AND CLOSE/REF(CLOSE,1)!=CLOSE/REF(OPEN,1);
X_27:=X_24 OR X_25 OR X_26;
X_28:=X_22 OR X_23 AND COUNT(CLOSE/REF(CLOSE,1)>1.05,10)<=4 AND SUM(X_27,12)<1;
妖气去除多信号:(X_22 OR X_23 AND COUNT(CLOSE/REF(CLOSE,1)>1.05,10)<=4 AND SUM(X_27,12)<1 AND SUM(X_28,20)<2) AND O>MA(C,10) AND O<MA(C,5) AND ABS(MA(C,5)-O)>=ABS(MA(C,10)-O);

通达信主图识妖02版 主图/选股 源码
打开微信扫一扫,一键复制指标源码,
轻松快捷粘贴至手机通达信APP中。
1

本站提示:股市有风险,入市请慎重,资料由股票下载网整理收集

找不到你要的公式?给我们建议

  1. 股票软件
    股票分析软件
    股票交易软件
    股票行情软件
    指标股票池
    手机炒股软件
    书籍教程
    数据软件
    工具补丁
    大智慧
    通达信
    飞狐
    东方财富通
    操盘手
    指南针
    分析家
    同花顺
    钱龙
    证券之星
    券商股票软件
    特色行情软件
    迷你行情软件
    金融界软件
    美股外盘软件
    大智慧股票池
    通达信股票池
    大智慧L2公式
    通达信公式
    飞狐公式
    同花顺公式
    股票书藉
    视频教程
    金融书籍
    其他书籍
    资讯评测软件
    资金分析软件
    数据接口软件
    江恩波浪软件
    数据下载软件
    软件数据投资
    选股软件
    登录补丁
    其他应用
    股软教程
  2. 股票公式
    通达信公式
    大智慧公式
    飞狐公式
    同花顺公式
    东方财富通公式
    金字塔指标公式
    文华指标公式
    MT4指标
    博易大师指标
    公式教程答疑
  3. 炒股知识
    短线技巧
    软件公式
    炒股视频
    股票入门
    股市实战信息交流
    炒股技巧
    股票基础知识
    技术分析
    炒股一招先
    基本面分析
    股票视频教程
    股票买卖技巧
    k线图分析
    胡立阳教你买股票
    短线炒股技巧
    天狼之眼
    波浪理论技术讲解
    股市赢家杨百万
    股票理论、T0缠论、知识
    经典指标、交易系统
    成交量能、筹码分析
    买卖信号、技术分析
    挖坑、冼盘、吸筹、出货
    均线战法、黄金分割
    经典K线、趋势形态
    牛股黑马、王子理论
    涨停、周线、月线
    止盈、止损、支撑、压力
    案例、波浪、口诀、选股
    分时、盘口、补仓、解套
  4. 技术指标
    DDX
    DDY
    DDZ
    MACD
    KDJ
    CCI
    OBV
    BOLL
    RSI
    VOL
    CR
    WR