股票下载网 股票软件7284 个 ┆ 股票公式33579 个 ┆ 炒股知识3863
首 页炒股知识股票软件股票公式技术指标设为首页  加入收藏  放到桌面本站分类
当前位置:股票下载网股票公式通达信公式
日期:2019-01-07 10:33:00  来源:本站整理

飓风眼指标 要拉一波 通达信主图/副图指标 源码 贴图

下面的主图中,分先后一共留下3条下插线。
第一条下插时显示红箭头(系统自带);
第二条A15D下插时显示洋红球;
第三条操作线下插时显示蓝茶杯。
3条下插线分别递进与M5交叉,只有在M5小幅上行时才会出现信号(跑道起飞时段)。
很明显,洋红球比蓝茶杯早一天出现(所以出蓝茶杯的下插线可以删掉不用)。
那么我把A3改成上插变色,其目的正是为了突出A15D下插后,出现K线呈30度角缓步走高时的——黄色跑道助飞时间段!(切记,对于研判买点非常重要!)
请让你的目光第一眼看到的是——黄色助跑时间段是否具备上行30度角,然后再在附图与主图对应的时间段内寻找共振信号!

飓风眼指标 要拉一波 通达信主图/副图指标 源码 贴图

飓风眼指标 要拉一波 通达信主图/副图指标 源码 贴图

飓风眼指标 要拉一波 通达信主图/副图指标 源码 贴图

飓风眼指标 要拉一波 通达信主图/副图指标 源码 贴图

点击下载飓风眼指标 要拉一波 通达信主图/副图指标 源码 贴图


{飓风眼主图A;参数:NN:1、99、21;MM:1、99、8;显示均线:0、1、1;
P:1、100、4;K:1、999、12;K2:1、2、1;K3:1、999、8;}
{修改后的主图源码}
{卖出------------------------}
VAR55:=EMA(EMA(EMA(CLOSE,8),13),62);
VAR56:=((REF(HIGH,1) + REF(LOW,1)) / 2);
VAR57:=(MA(CLOSE,20) + (2 * STD(CLOSE,20)));
VAR58:=((SMA(MAX((CLOSE - REF(CLOSE,1)),0),7,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),7,1)) * 100);
卖出1:=FILTER(CROSS(79,VAR58),4);
MA21:=REF(CLOSE,1);
ZX:=((SMA(MAX((CLOSE - MA21),0),6,1) / SMA(ABS((CLOSE - MA21)),6,1)) * 100);
卖出2:=CROSS(84,ZX);
卖出3:=CROSS(90,RSI);
卖出:=卖出1 OR 卖出2 OR 卖出3;
DRAWICON(卖出,(LOW * 1.15),15);

{买入------------------------}
MA3:=MA(CLOSE,3);
ZVAR4:=(((HIGH + LOW) + CLOSE) / 3);
QQ2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
QQ3:=SMA(QQ2, 9, 1);
QQ4:=SMA(QQ3, 3, 1);
长趋势:=3*QQ3-2*QQ4,COLORWHITE,LINETHICK3;
趋势线1:=EMA(QQ3, 3),COLORRED,LINETHICK3;
金叉:= CROSS(长趋势,趋势线1);
AAAA1:=AMOUNT/V;
BBB1:=L<AAAA1*0.9;
CCC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DDD1:=L<MA(C,5)*0.921;
EEE1:=V<MA(V,5)*1.5;
老鼠仓:=BBB1 AND CCC1 AND DDD1 AND EEE1,,NODRAW;
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,7)-REF(EMA(X1,7),1))*3.1416*10;
VAR1:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
VAR2:=( MA((CLOSE-VAR1)/VAR1,1));
VVAR3:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100;
{VVAR4:=SMA(VVAR3,4,1);}

MMA:=EMA(VAR2,12)*0.7;
MMB:=EMA(VAR2,3);
快到底:=IF(LLV(MMB-MMA,12)>0,0,-20),LINETHICK2,COLORGREEN;

DIFF:=( EMA(CLOSE,12) - EMA(CLOSE,26))*100;
DEA:=EMA(DIFF,9);
MACD:= 2*(DIFF-DEA);
抄底:=IF(快到底<0 AND CROSS(MACD,0) AND ZVAR4<18,1,0);
AVAR2:=(2*CLOSE+HIGH+LOW)/4;
AVAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
AVAR4:=LLV(LOW,5);
AVAR5:=HHV(HIGH,4);
散户:= EMA((AVAR2-AVAR4)/(AVAR5-AVAR4)*100,4)*AVAR3;
庄家:= EMA(0.667*REF(散户,1)+0.333*散户,2)*AVAR3;
试买:=(((CROSS(散户,庄家) AND 散户<50 AND 29<散户)) NOT 大雪)
OR (CROSS(散户,庄家) AND 散户<30 { AND 角1>0}) OR 抄底;
AA05:=MA(C,5),COLOR0099CC;
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
AA10:=MA(C,10);
AA20:=MA(C,20);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND
AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND
AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
MV3:=EMA(V,3);
MV3角度:=ATAN((MV3/REF(MV3,1)-1)*100)*180/3.1416;
MA3角度:=ATAN((MA3/REF(MA3,1)-1)*100)*180/3.1416;
MV5:=EMA(V,5);
MA5:=EMA(C,5);
MV5角度:=ATAN((MV5/REF(MV5,1)-1)*100)*180/3.1416;
MA5角度:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
MV10:=EMA(V,10);
MA10:=EMA(C,10);
MV10角度:=ATAN((MV10/REF(MV10,1)-1)*100)*180/3.1416;
MA10角度:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
强弱度:=(MV3角度+MA3角度+MV5角度+MA5角度+MV10角度+MA10角度)/6,COLORFFFFFF;
QBD:=CROSS(强弱度,50) AND COUNT(强弱度>50,7)<=3;
启爆点:=IF(K=0 AND QBD AND COUNT(QBD,4)=1,50,0),COLOR00FFFF;
半月相对价位:=(C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*10;
半月相对价位M:=SMA(半月相对价位,3,2);
半月相对价位MM:=SMA(半月相对价位M,10,6);
K13:=MA(半月相对价位MM,3);
福缘:=半月相对价位MM>=K13,COLORRED;
启爆福缘:=K=0 AND 启爆点 AND 福缘;
HD:=HIGH-REF(HIGH,1);
LLD:=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LLD,HD,0),14);
DMM:=EXPMEMA(IF(LLD>0&&LLD>HD,LLD,0),14);
AK:=EMA((DMP-DMM)*1,3)*100+50,COLORFFFFFF;
AD:=EMA((MA(DMP,3)-MA(DMM,3))*1,3)*100+50,COLORFFFFFF;
{DRAWICON(CROSS(AK,AD) AND 启爆点 AND 福缘,L*0.99 ,9);}
{DRAWICON(老鼠仓 OR 金叉,(LOW - (LOW * 0.01)),1);}

MH:=K*10;
MK:=K3*10;
HH:=CONST(HHV(H,MH));
LH:=CONST(LLV(H,MH));
LC:=CONST(LLV(L,MK));
HC:=CONST(HHV(H,MK));
幅1:=(L-LC)/LC*100;
AAA:=IF(L=LC,1,0);
AAB:=BARSLAST(AAA),NODRAW;
幅2:=(H-HC)/HC*100;
BBA:=IF(H=HC,1,0);
BBB:=BARSLAST(BBA),NODRAW;
R1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
R2:=(REF(R1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R3:=(REF(R2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R4:=(REF(R3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R5:=(REF(R4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R6:=(REF(R5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R7:=(REF(R6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R8:=(REF(R7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R9:=(REF(R8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RA:=(REF(R9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
RB:=(REF(RA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RC:=(REF(RB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
RD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
RE:=(REF(RD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RF:=(REF(RE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R10:=(REF(RF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R11:=(REF(R10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R12:=(REF(R11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R13:=(REF(R12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R14:=(REF(R13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R15:=(REF(R14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R16:=(REF(R15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R17:=(REF(R16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R18:=(REF(R17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R19:=REF(RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,1) AND R1;
R1A:=((REF(R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,1)) AND RD);
VAR3:=IF(C<200 ,MA(COST(80),3),2500),NODRAW;
VAR4:=(((HIGH + LOW) + CLOSE) / 3);
VAR5:=EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),2330);
VAR6:=(VAR5 + ((VAR5 * 6) / 100));

{短买春:=R19,NODRAW,COLOR00DD00;
秋离场:=R1A,NODRAW,COLOR2288DD;}
红持股:=R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,NODRAW,COLOR0000FF;
阴观望:=RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,NODRAW,COLOR999999;
{急速超跌关注:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORBBBBBB,NODRAW;
Q1:=CONST(IF(短买春,0,IF(秋离场,100,IF(红持股,100,IF(急速超跌关注,50,50))))),NODRAW;
Q2:=CONST(IF(短买春,80,IF(秋离场,100,IF(红持股,0,IF(急速超跌关注,50,50))))),NODRAW;
Q3:=CONST(IF(短买春,0,IF(秋离场,20,IF(红持股,50,IF(急速超跌关注,50,50))))),NODRAW;
DRAWRECTREL(970,0,1000,990,RGB(Q1,Q2,Q3));
DRAWRECTREL(970,189,1000,807,RGB(0,55,5));
DRAWRECTREL(970,374,1000,610,RGB(0,5,55));
DRAWRECTREL(970,495,1000,495,RGB(255,00,00));}


A:=EMA((EMA(C,29)+EMA(C,31)+EMA(C,33))/3,3);
A1:=EMA((EMA(C,1)+EMA(C,3)+EMA(C,5))/3,3),COLOR1010FF;
A2:=EMA((EMA(C,3)+EMA(C,5)+EMA( C,7))/3,3),COLOR1020FF;
MT1:=IF(ISLASTBAR,REF((C*2-REF(C,3)),1),DRAWNULL);
MT2:=IF(ISLASTBAR,REF((C*2-REF(C,3)),2),DRAWNULL);
MT3:=IF(ISLASTBAR,C*2-REF(C,3),DRAWNULL);
JRH:=HHV(C,2);
JRL:=LLV(C,2);

离场:=IF(红持股,JRL,DRAWNULL);
今离场价:=REF(离场,1)COLOR0000FF,NODRAW;
进:=IF(阴观望,JRH,DRAWNULL);
今进场价:=REF(进,1),COLOR00FF00,NODRAW;
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
RRRSV:=SMA(下档线,3,1);
KKK:=SMA(RRRSV,3,1);
DDDDD:=((3 * RRRSV) - (2 * KKK));
JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
RSV24:=SMA(JJ12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) - (2 * K24));
压力2:=IF(CROSS(D24,DDDDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDDDD)))),COLORFFFFFF;
底部:=LLV(HIGH,30),COLOR00FF00;
压力位:=IF(ISLASTBAR,压力2,DRAWNULL),NODRAW;
底部位:=IF(ISLASTBAR,底部,DRAWNULL),NODRAW;
AA1:=IF(ISLASTBAR AND (红持股 OR REF(红持股,1)=1),1,0),NODRAW;
AA2:=IF(ISLASTBAR AND (阴观望 OR REF(阴观望,1)=1),1,0),NODRAW;
A99:=EMA((EMA(C,17)+EMA(C,19)+EMA( C,21))/3,3),COLOR1090FF;
A233:=A-(A99-A),COLORFF9010;
中轴:=MA(C,21),COLORFFCC33;
压力1:=IF(K2=1 AND (中轴 + 2*STD(C,34))<=HH,中轴 + 2*STD(C,34),DRAWNULL);
支撑1:=IF(K2=1 AND (中轴 - 2*STD(C,21))>=LH,中轴 - 2*STD(C,21),DRAWNULL);
压力3:=中轴 + 2*STD(C,34);
支撑3:=中轴 - 2*STD(C,21);
压力:=IF(K2=1,压力1,压力3),COLOR0055CC,LINETHICK3;
支撑:=IF(K2=1,支撑1,支撑3),COLORLICYAN,LINETHICK3;

{5日变色线}
越过成仙M240:=MA(C,240),COLORGRAY,LINETHICK1;
M144:=MA(C,144),COLORWHITE,LINETHICK1;
M88:=MA(C,88),COLORLIGRAY,LINETHICK1;
越过有道M120:=MA(C,120),COLORMAGENTA,LINETHICK1;
{越过强势M60:MA(C,60),COLORGREEN,LINETHICK3;}
M30:=MA(C,27),COLORGREEN,LINETHICK2;
M20:=MA(C,17),COLORMAGENTA,LINETHICK2;
M10:=MA(C,10),COLORWHITE,LINETHICK1;
M5:MA(C,3),COLORRED,LINETHICK3;
BB55:=ATAN((M5/REF(M5,1)-1)*100)*180/3.1416;
IF(BB55>30 AND M5>REF(M5,1), M5,DRAWNULL),COLORRED,LINETHICK3;
BB100:=ATAN((M10/REF(M10,1)-1)*100)*180/3.1416;
IF(BB55<0 AND M5<REF(M5,1), M5,DRAWNULL),COLORCYAN,LINETHICK3;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));

A3:IF(K2!=2, EMA((EMA(C,5)+EMA(C,6)+EMA( C,7))/3,3),DRAWNULL),COLORCYAN,LINETHICK3;{COLOR1030FF;}
A4:=IF(K2!=2, EMA((EMA(C,7)+EMA(C,9)+EMA( C,11))/3,3),DRAWNULL),COLOR1040FF;
A5:=IF(K2!=2, EMA((EMA(C,9)+EMA(C,11)+EMA( C,13))/3,3),DRAWNULL)COLOR1050FF;
A6:=IF(K2!=2, EMA((EMA(C,11)+EMA(C,13)+EMA( C,15))/3,3),DRAWNULL)COLOR1060FF;
A7:=IF(K2!=2, EMA((EMA(C,13)+EMA(C,15)+EMA( C,17))/3,3),DRAWNULL)COLOR1070FF;
A8:=IF(K2!=2, EMA((EMA(C,15)+EMA(C,17)+EMA( C,19))/3,3),DRAWNULL)COLOR1080FF;
A9:=IF(K2!=2, EMA((EMA(C,17)+EMA(C,19)+EMA( C,21))/3,3),DRAWNULL),COLORLIMAGENTA;{COLOR1080EF;}
A10D:=IF(K2!=2, EMA((EMA(C,19)+EMA(C,21)+EMA( C,23))/3,3),DRAWNULL),COLORLIMAGENTA;{COLOR10C0FF;}
{A11D:IF(K2!=2, EMA((EMA(C,21)+EMA(C,23)+EMA( C,25))/3,3),DRAWNULL),COLORWHITE,LINETHICK2;
A15D:IF(K2!=2, A-(A1-A*0.987),DRAWNULL),COLORWHITE,LINETHICK2;{COLORFF0000;原997}
A16D:=IF(K2!=2, A-(A2-A),DRAWNULL)COLORFE2525;{A16D--A23D隐去。}
A17D:=IF(K2!=2, A-(A3-A),DRAWNULL)COLORFD3030;
A18D:=IF(K2!=2, A-(A4-A),DRAWNULL)COLORFC4030;
A19D:=IF(K2!=2, A-(A5-A),DRAWNULL)COLORFB5030;
A20D:=IF(K2!=2, A-(A6-A),DRAWNULL)COLORFA6030;
A21D:=IF(K2!=2, A-(A7-A),DRAWNULL)COLORF97030;
A22D:=IF(K2!=2, A-(A8-A),DRAWNULL)COLORF88030;
A23D:=IF(K2!=2, A-(A9-A),DRAWNULL)COLORF7A030;
A11D:=IF(K2!=2, EMA((EMA(C,21)+EMA(C,23)+EMA( C,25))/3,3),DRAWNULL),COLORWHITE,LINETHICK2;
A15D:IF(K2!=2, A-(A1-A*0.977),DRAWNULL),COLORCYAN,LINETHICK2;{COLORFF0000;原997}
A24D:=IF(K2!=2, A-(A10D-A),DRAWNULL)COLORF6D030;
A25D:=IF(K2!=2, A-(A11D-A*0.987),DRAWNULL)COLORF5F030;{原997}
AK2:=IF(K2=2,EMA((EMA(C,5)+EMA(C,7)+EMA( C,9))/3,3),DRAWNULL);
AK1:=IF(K2=2,A-(A1-A*0.987),DRAWNULL);{原997}
DRAWBAND(AK2,RGB(250,250,250),EMA((EMA(C,1)+EMA(C,3)+EMA(C,5))/3,3),RGB(250,00,00));
DRAWBAND(AK1,RGB(250,250,0),A-(A2-A),RGB(00,00,250));
DRAWNUMBER(ISLASTBAR AND BBB>3,HC,幅2);
DRAWNUMBER(ISLASTBAR AND AAB>3,LC+(HC-LC)*0.05,幅1);

{古道西风主图 K=12 P=4 K2=0(0-2) K3=8}
{DRAWGBK(CLOSE>0,RGB(20,58,120),RGB(1,2,3),0,61,0);}
YM:=EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,40);
YM1:=EMA(YM,1),NODRAW;{3}
YM2:=EMA(YM1,2),NODRAW;{7}
DRAWBAND(YM1,RGB(240,120,80),YM2,RGB(40,240,50));{变色条。原参数:200,80,50;压力+支撑线}

{下插操作线}
B:=SMA(CLOSE,17,1)*2-REF(SMA(CLOSE,17,1),1);
分水岭:=SMA(IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),3,1);
操作线:SMA(分水岭-(MA(C,3)-分水岭),2,1),COLOR66FF16,LINETHICK2;
{M5上穿操作线变黄色}
OUTF:=CROSS(M5,操作线);
IF(M5>REF(操作线,1),操作线,DRAWNULL),COLORYELLOW,LINETHICK3;
DRAWICON(OUTF,L*1.1,19);

OUT1:=CROSS(M5,A15D);
IF(M5>REF(A3,1),A3,DRAWNULL),COLORYELLOW,LINETHICK3;{黄金支撑线}
DRAWICON(OUT1,L*1.1,13);

越过强势M60:=MA(C,60),COLORWHITE,LINETHICK1;{60日均线};
{飓风眼附图}
{趋势转强}
VAR5X:=(CLOSE-LLV(LOW, 100))/(HHV(HIGH, 100)-LLV(LOW, 100))*200;
VAR6X:=SMA(VAR5X, 3, 1);
VAR7X:=SMA(VAR6X, 3, 1);
VAR8X:=3*VAR6X-2*VAR7X;
VAR11:=EMA((CLOSE-LLV(LOW, 5))/(HHV(HIGH, 5)-LLV(LOW, 5))*100, 4)*2;
VAR12:=EMA(0.667*REF(VAR11, 1)+0.333*VAR11, 2);
VAR13:=3*VAR11-2*VAR12;
VAR14:=POW(MA(CLOSE, 5), 2)+MA(CLOSE, 5);
VAR15:=POW(MA(LOW, 5), 2)+MA(LOW, 5);
VAR16:=POW(MA(HIGH, 5), 2)+MA(HIGH, 5);
VAR17:=(VAR14-LLV(VAR15, 64))/(HHV(VAR16, 64)-LLV(VAR15, 64))*150+65-10;
VAR18:=SMA(VAR17, 3, 1)*1.5-100;
VAR19:=SMA(VAR18, 3, 1);
VAR20:=3*VAR18-2*VAR19;
VAR21:=(HIGH+LOW+CLOSE*2)/4;
VAR22:=EMA(VAR21, 13);
VAR23:=STD(VAR21, 13);
VAR24:=(VAR21-VAR22)*100/VAR23;
VAR25:=EMA(VAR24, 5);
VAR26:=EMA(VAR25, 13);
VAR27:=EMA(VAR25, 13)+200-100;
VAR28:=EMA(VAR27, 10);
VAR29:=3*VAR27-2*VAR28;
VAR30:=VAR6X+VAR11+VAR18+VAR27;
VAR31:=VAR7X+VAR12+VAR19+VAR28;
VAR32:=VAR8X+VAR13+VAR20+VAR29;
VAR33:=(HIGH+LOW+CLOSE)/3;
VAR34:=AMOUNT/VOL/100;
VAR35:=SUM(AMOUNT, 5)/SUM(VOL, 5)/100;
VAR36:=(VAR33-MA(VAR33, 34))/(0.015*AVEDEV(VAR33, 34));
VAR41:=(VAR33-EMA(VAR33, 24))/STD(VAR33, 24)*100;
VAR42:=(VAR33-MA(VAR33, 24))/(0.015*AVEDEV(VAR33, 24));
VAR43:=EMA(VAR41, 5);
VAR44:=(VAR34-MA(VAR34, 21))/(0.015*AVEDEV(VAR34, 21));
VAR45:=(VAR35-MA(VAR35, 90))/(0.015*AVEDEV(VAR35, 90));
VAR46:=((VAR45+VAR44+VAR43+VAR42+VAR36)/5+165)/4;
VAR47:=(EMA(EMA(EMA(VAR46, 15), 10), 5)-25)*2+DMA(AMOUNT/VOL/100, VOL/CAPITAL);
VAR48:=(VAR30+VAR31+VAR32*30)/32/5-15;
VAR49:=EMA(VAR48, 13);
VAR51:=(VAR47+VAR49)/2;
VAR52:=EMA(VAR51, 1);
ZX:EMA(VAR52, 2),LINETHICK0, COLORFF7710;
{STICKLINE(ZX-REF(ZX, 2)<0, ZX, 10, 9, 0),COLORBROWN;{COLOR9CA010;}
STICKLINE(ZX-REF(ZX, 2)>0, ZX, 10, 9, 0),COLORLIRED;{LINETHICK0, COLOREEEEEE;}

VAR1:=IF(YEAR>=2038 AND MONTH>=1,0,1);
VAR2:=REF(LOW,1)*VAR1;
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100*VAR1;
GG:=100*(1-WINNER(C))>99.8 AND V/CAPITAL*100<5 AND 100*(WINNER(1.1*C)-WINNER(0.9*C))<3.9;
最佳建仓点:=C>REF(C,1) AND REF(GG,1)>0 AND VAR3,COLORRED;
STICKLINE(C>REF(C,1) AND REF(GG,1)>0 AND VAR3,0,80,4,0),COLORRED;
{DRAWTEXT(C>REF(C,1) AND REF(GG,1)>0 AND VAR3,85,'★低位建仓'),COLORYELLOW;}

{1指.能量线}
能量线:=EMA(100*(C-LLV(L,34))/(HHV(H,34)-LLV(L,34)),3),LINETHICK0;
{2指.RSI} RSI:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100,LINETHICK0;
{3指.KDJ} RSVF:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,LINETHICK0;
KF:=SMA(RSVF,3,1);
DF:=SMA(KF,3,1);
JF:=3*KF-2*DF,LINETHICK0;
{4指.W&R} 威廉WR:=(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))*100,LINETHICK0;
{5指.CCI} TYP := (HIGH + LOW + CLOSE)/3; }
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0;
五指A:WMA((能量线+RSI+JF-威廉WR+CCI)/2.5,5);{调节高低位置}
五指B:WMA((能量线+RSI+JF-威廉WR+CCI)/4,13);
KC:=FORCAST(((2*C+H+L)/4*0.618+C*0.382),3);
AAX:=(KC-MA(KC,9))/MA(KC,9)*100; VAR0:=MIN(EXIST(KC,55),9);
AAX1:=EMA(AAX,VAR0)*VAR0; AAX2:=MA(AAX1,3);
AAX3:=MA(AAX1,5); 卖:=AAX3>3 AND AAX1<REF(AAX1,1) AND CROSS(AAX2,AAX1);
VBA:=FILTER(卖,5);
{DRAWTEXT(VBA,五指A*1.08,'★顶背离警惕'),COLORGREEN;}
VB2:=EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6)*100;
VB3:=IF(LLV(VB2,3)=LLV(VB2,11) AND COUNT(VB2<0,2) AND CROSS(VB2,MA(VB2,2)),1,0);
VB4:=FILTER(VB3=1,5);
{DRAWTEXT(VB4,五指A*0.97,'★买入'),COLOR00FFFF;}
DRAWBAND(五指A,RGB(255,200,0),五指B,RGB(0,40,55));{亮度}
{MA((能量线+RSI+JF-威廉WR+CCI)/5,5),COLORLICYAN,LINETHICK3;{淡青色线}
IF(五指A>REF(五指A,1),五指A,DRAWNULL),COLORRED,LINETHICK4;{红色线};
DRAWTEXT_FIX(1,0.02,0,0,'◆能量线,RSI3.KDJ,W&R,CCI,
【五个指标共振线.[红].[绿].变化是买卖信号.颜色及标记是配合信号】'),COLOR00FFFF,LINETHICK3;
DRAWTEXT(VB4,五指A*0.97,'★低买'),COLOR00FFFF;

{飓风眼,红色下叉带}
VAR11F:=(HHV(HIGH,8)-CLOSE)/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR33F:=100-3*SMA((CLOSE-LLV(LOW,72))/(HHV(HIGH,72)-LLV(LOW,72))*100,20,1)
+2*SMA(SMA((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100,20,1),15,1);{72}
冷气OAMV:=EMA(VAR33,2),COLORRED;
冷气南下:=EMA(EMA(SMA(VAR11,6,1)-7,2),2);
WR线:=EMA(EMA(100*(HHV(HIGH,42)-CLOSE)/(HHV(HIGH,42)-LLV(LOW,42)),3),3),COLORWHITE,DOTLINE;
SBZLPA1:=BARSLAST(L=HHV(L,7));
SBZLPA2:=EMA(SBZLPA1*SBZLPA1,13);
暖气北上:=IF(SBZLPA2>88,88+SQRT(SBZLPA2-88),SBZLPA2);
TPV:=(暖气北上+冷气南下+冷气OAMV)/3;
T冷气南下:=(暖气北上+TPV)/2+8,COLORWHITE,DOTLINE;
T暖气北上:=(冷气南下+TPV)/2+8,COLORBLUE,DOTLINE;
T飓风形成:=(T暖气北上+T冷气南下)/2,COLORGRAY,DOTLINE;
WR慢:=EMA(EMA(100*(HHV(HIGH,42)-CLOSE)/(HHV(HIGH,42)-LLV(LOW,42)),2),2);
ZLCQ:=EMA((WINNER(CLOSE) * 69),3);
SHCQ:=EMA(((WINNER((CLOSE * 1.1)) - WINNER((CLOSE * 0.93))) * 80),3);
主力控盘Q:=EMA(((ZLCQ / (ZLCQ+ SHCQ)) * 110),2),COLORFF11FF,LINETHICK2;
上限Q:=HHV(主力控盘Q,20),COLORGRAY,LINETHICK3;
下限Q:=LLV(主力控盘Q,20),COLORGRAY,LINETHICK3;
圈Q:=100*(HHV(HIGH,42)-C)/(HHV(HIGH,42)-LLV(LOW,42));
M圈Q:=EMA(EMA(圈Q,3),2);
MM圈Q:=EMA(EMA(EMA(圈Q,4),3),2);
控盘主升Q:=EMA(主力控盘Q,2);
KONGQ0:=(上限Q/控盘主升Q)*(下限Q/控盘主升Q)*50;
KONGQ:=IF(KONGQ0>100,100,IF(KONGQ0<1,1,KONGQ0));
MAXV:=MAX(T冷气南下,T暖气北上);
MINV:=MIN(T冷气南下,T暖气北上);
MMV0:=MAXV/MINV;
MMV1:=T冷气南下/REF(T冷气南下,1);
MMV2:=T暖气北上/REF(T暖气北上,1);

散筹集中度Q:=EMA(EMA((WINNER(C*1.1)-WINNER(C*0.9))*50/(WR慢/MM圈Q)/MMV0/MMV1/MMV2,3),2);

KKONG0:=KONGQ*KONGQ*5/SQRT(散筹集中度Q)/控盘主升Q;
KKONG:=IF(KKONG0>100,100,KKONG0);
KV0:=KKONG/KONGQ;
KV1:=KONGQ/REF(KONGQ,1);
KV2:=KKONG/REF(KKONG,1);
KV3:=EMA(KV0*KV0*KV1*KV2*30,2);
OKV:=IF(KV3>100,100,IF(KV3<0,0,KV3));
WVQ0:=1.18*(上限Q*下限Q+5)/(KONGQ+2)/SQRT(SQRT((OKV+2)/(KONGQ+5)));
WVQ1:=100-IF(WVQ0>70,70+SQRT(WVQ0-1),IF(WVQ0<1,1,WVQ0));{90}
WVVQ:=(IF(WVQ1<05,0.5,WVQ1));
EVVQ:=EMA(EMA(WVVQ*0.97,3),3);

DRAWBAND(WVVQ,RGB(11,60,55),EVVQ,RGB(240,11,33));{红色下叉变色}

{要拉一波}
VAR1A:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR4AA:=CLOSE/(REF(CLOSE,1))>1.05 AND (HIGH/CLOSE<1.01);{1.05;1.01}
游资进场:=(FILTER(VAR4AA>0,34)AND DYNAINFO(4)>0)*8,COLORYELLOW;
A10:10,COLORYELLOW;
{STICKLINE(XYSHSL>2.1 AND CYS13>5,53,86,5,0 ),COLOR000055;}
STICKLINE(游资进场,10,66,6,0),COLORBLUE;
LS:=C/REF(C,1)>1.048 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));
拉升:=FILTER(LS,28);


M:=10;
N:=9;
散户线:100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M)),COLORGREEN,LINETHICK2;{COLORFFFF00青线}
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
庄筹线:EMA(J,6),COLORRED,LINETHICK3;{粉线COLORFF00FF}
IF(散户线<庄筹线,散户线,DRAWNULL),COLORRED,LINETHICK3;
IF(庄筹线<散户线,庄筹线,DRAWNULL),COLORCYAN,LINETHICK2;
IF(散户线>A10,散户线,DRAWNULL),COLORCYAN,LINETHICK2;

XG1P:=CROSS(散户线,A10);
{DRAWICON(XG1,OPEN+1,18);}
{STICKLINE(XG1P,L*4.40,L*1.05,1,0),COLORWHITE;
DRAWTEXT(XG1P,L*3.89,'--主图空仓'),COLORBLUE;}

STICKLINE(拉升,10,58,0.5,0)COLORGREEN;
DRAWTEXT(拉升,40,' 芝麻开花'),COLORGREEN;
DRAWICON(拉升,66,9);
DRAWICON(游资进场=8,44,34);
DRAWICON(游资进场=8,30,33);
DRAWICON(游资进场=8,14,18);
DRAWTEXT(游资进场=8,66,' 要拉一波'),COLORCYAN;

DRAWTEXT(C>REF(C,1) AND REF(GG,1)>0 AND VAR3,85,'★低位建仓'),COLORYELLOW;

DRAWTEXT(VBA,五指A*1.08,'★顶背离警惕'),COLORGREEN;


 
飓风眼指标 要拉一波 通达信主图/副图指标 源码 贴图
打开微信扫一扫,一键复制指标源码,
轻松快捷粘贴至手机通达信APP中。

Tags:

作者:佚名

公式评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论
Copyright © 2009-2019 GPxiazai.com. All Rights Reserved .
备案号: 苏ICP备12020055号-2 苏公网安备 32058302001104号
声明:本站所有信息免费,广告收费行为均与本站无关. 侵权请联系QQ929946094进行处理.
若本站收录的软件无意侵犯了贵司版权,请联系QQ929946094进行处理,谢谢!