股票下载网 股票软件7388 个 ┆ 股票公式34153 个 ┆ 炒股知识3863
首 页炒股知识股票软件股票公式技术指标设为首页  加入收藏  放到桌面本站分类
当前位置:股票下载网股票公式通达信公式
日期:2019-01-02 08:50:00  来源:本站整理

优化版“筹码能量” 我心飞扬 通达信指标 附图 贴图 不加密 无未来函数(三)

 优化版“筹码能量” 我心飞扬 通达信指标 附图 贴图 不加密 无未来函数(三)

优化版“筹码能量” 我心飞扬 通达信指标 附图 贴图 不加密 无未来函数(三)点击下载优化版“筹码能量” 我心飞扬 通达信指标 附图 贴图 不加密 无未来函数(三)


{筹码能量图}
DRAWGBK(1,RGB(1,1,1),RGB(1,1,1),0,'00',0);
DRAWBAND(15,RGB(40,30,35),0,RGB(0,0,0));

主力筹码估算:=EMA(WINNER(CLOSE)*70,3),NODRAW;
散户筹码估算:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3),NODRAW;
主力控盘比率0:=主力筹码估算/(主力筹码估算+散户筹码估算)*100;
主力控盘比率:=IF(主力控盘比率0<-6,-6,IF(主力控盘比率0>100,100+SQRT(主力控盘比率0-100),主力控盘比率0));
散户套牢比率:=散户筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW;
散户警戒:=EMA(散户套牢比率,89);
主力警戒:EMA(主力控盘比率,89),COLORGRAY,LINETHICK3;


{主力控盘筹码}
{粉}
STICKLINE(主力控盘比率>REF(主力控盘比率,1) AND 主力控盘比率>15,主力控盘比率,15,2,0 ),COLORAA00BB;
{蓝}
STICKLINE(主力控盘比率<=REF(主力控盘比率,1) AND 主力控盘比率>15,主力控盘比率,15,2,0 ),COLORCC7700;
{亮红}
STICKLINE(主力控盘比率>REF(主力控盘比率,1) AND 主力控盘比率<15,主力控盘比率,0,2,0 ),COLOR131FFD;
{深蓝}
STICKLINE(主力控盘比率<=REF(主力控盘比率,1) AND 主力控盘比率<15,主力控盘比率,0,2,0 ),COLOR990000;
STICKLINE(主力控盘比率>15,15,主力控盘比率,0,0),COLORAAAAAA;
{主力筹码警戒}
{黄}
STICKLINE(主力警戒>REF(主力警戒,1),主力控盘比率,主力警戒,2,0 ),COLOR0066FF;
STICKLINE(主力警戒>REF(主力警戒,1),主力控盘比率,主力警戒,0.3,0 ),COLOR00BBFF;
{红}
STICKLINE(主力控盘比率>主力警戒 AND 主力警戒>50,主力控盘比率,主力警戒,2,0 ),COLOR0000AA;
STICKLINE(主力控盘比率>主力警戒 AND 主力警戒>50,主力控盘比率,主力警戒,0.3,0 ),COLOR0055FF;
{红}
STICKLINE(主力控盘比率>主力警戒 AND 主力警戒<50 AND 主力控盘比率>50 AND 主力警戒>REF(主力警戒,1),主力控盘比率,50,2,0 ),COLOR0000AA;
STICKLINE(主力控盘比率>主力警戒 AND 主力警戒<50 AND 主力控盘比率>50 AND 主力警戒>REF(主力警戒,1),主力控盘比率,50,0.3 ,0 ),COLOR0055FF;
STICKLINE(主力控盘比率<=10,主力控盘比率,0,4,0),COLORDD00DD;
STICKLINE(REF(散户套牢比率,1)>90 AND 散户套牢比率<90,30,0,2.5,0),COLOR0000FF;

VAR11:=(HHV(HIGH,8)-CLOSE)/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR33:=100-3*SMA((CLOSE-LLV(LOW,72))/(HHV(HIGH,72)-LLV(LOW,72))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,72))/(HHV(HIGH,72)-LLV(LOW,72))*100,20,1),15,1);
活筹OAMV:=EMA(VAR33,2),COLORYELLOW;
做空资金:=EMA(EMA(SMA(VAR11,6,1)-7,2),2);
WR线:=EMA(EMA(100*(HHV(HIGH,42)-CLOSE)/(HHV(HIGH,42)-LLV(LOW,42)),3),3),COLORWHITE,DOTLINE;
SBZLPA1:=BARSLAST(L=HHV(L,7));
SBZLPA2:=EMA(SBZLPA1*SBZLPA1,13);
我心飞扬:=IF(SBZLPA2>88,88+SQRT(SBZLPA2-88),SBZLPA2);
TPV:=(我心飞扬+做空资金+活筹OAMV)/3;
T我心飞扬:=(我心飞扬+TPV)/2+8,COLORWHITE,DOTLINE;
T做空资金:=(做空资金+TPV)/2+8,COLORBLUE,DOTLINE;
T飞扬资金:=(T我心飞扬+T做空资金)/2,COLORGRAY,DOTLINE;

WR慢:=EMA(EMA(100*(HHV(HIGH,42)-CLOSE)/(HHV(HIGH,42)-LLV(LOW,42)),2),2);
ZLCQ:=EMA((WINNER(CLOSE) * 69),3);
SHCQ:=EMA(((WINNER((CLOSE * 1.1)) - WINNER((CLOSE * 0.93))) * 80),3);
主力控盘Q:=EMA(((ZLCQ / (ZLCQ+ SHCQ)) * 110),2),COLORFF11FF,LINETHICK2;
上限Q:=HHV(主力控盘Q,20),COLORLIRED,LINETHICK2;
下限Q:=LLV(主力控盘Q,20),COLORGRAY,LINETHICK2;
圈Q:=100*(HHV(HIGH,42)-C)/(HHV(HIGH,42)-LLV(LOW,42));
M圈Q:=EMA(EMA(圈Q,3),2);
MM圈Q:=EMA(EMA(EMA(圈Q,4),3),2);
控盘主升Q:=EMA(主力控盘Q,2);
KONGQ0:=(上限Q/控盘主升Q)*(下限Q/控盘主升Q)*50;
KONGQ:=IF(KONGQ0>100,100,IF(KONGQ0<1,1,KONGQ0));
MAXV:=MAX(T做空资金,T我心飞扬);
MINV:=MIN(T做空资金,T我心飞扬);
MMV0:=MAXV/MINV;
MMV1:=T做空资金/REF(T做空资金,1);
MMV2:=T我心飞扬/REF(T我心飞扬,1);
散筹集中度Q:=EMA(EMA((WINNER(C*1.1)-WINNER(C*0.9))*50/(WR慢/MM圈Q)/MMV0/MMV1/MMV2,3),2);
KKONG0:=KONGQ*KONGQ*5/SQRT(散筹集中度Q)/控盘主升Q;
KKONG:=IF(KKONG0>100,100,KKONG0);
KV0:=KKONG/KONGQ;
KV1:=KONGQ/REF(KONGQ,1);
KV2:=KKONG/REF(KKONG,1);
KV3:=EMA(KV0*KV0*KV1*KV2*30,2);
OKV:=IF(KV3>100,100,IF(KV3<0,0,KV3));
WVQ0:=1.18*(上限Q*下限Q+5)/(KONGQ+2)/SQRT(SQRT((OKV+2)/(KONGQ+5)));
WVQ1:=100-IF(WVQ0>90,90+SQRT(WVQ0-90),IF(WVQ0<1,1,WVQ0));
WVVQ:=(IF(WVQ1<05,0.5,WVQ1));
EVVQ:=EMA(EMA(WVVQ*0.96,3),3);
DRAWBAND(WVVQ,RGB(11,88,55),EVVQ,RGB(222,11,33));

MTR:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
ADX0:=EMA(100-EMA(ABS(MDI-PDI)/(MDI+PDI)*主力控盘Q+下限Q,6),2);
ADX:=IF(ADX0<0.5,0.5,IF(ADX0>106,106,ADX0));
ADXR:EXPMEMA(ADX,6),COLORGRAY,LINETHICK3;
DRAWBAND(ADXR,RGB(166,66,33),ADX,RGB(88,118,168));

RSV1:=(CLOSE-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
FASTK:=SMA(RSV1,3,1);
龙K:=SMA(FASTK,2,1);
龙D:=SMA(龙K,5,1);
UK0:=EVVQ*44/龙D;
UK:=IF(UK0>98,98,IF(UK0<1,1,UK0));
YK0:=UK/(ABS((100-UK)-EVVQ)+1)+46;YK:=IF(YK0>98,98,YK0);

价量:=EMA(0.98*3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),2);
主线:=EMA(0.98*(((价量-LLV(价量,27))/(HHV(价量,27)-LLV(价量,27)))*(4))*(25),2);
主价:=SQRT(价量*主线*1.1);
OKK0:(价量+主价)/2,NODRAW;
OKK1:=YK*10/(OKK0+1)+40;
OKK2:=IF(OKK1>96,96+SQRT(SQRT(OKK1-96)),IF(OKK1<1,1,OKK1));
OKK3:=(100-OKK2);
OKK4:=IF(OKK3>0,IF(OKK3>100,100,OKK3),0-SQRT(0-OKK3));
OKK5:=(OKK2-YK)-OKK4+78,NODRAW;{+100}
NOK:=106-IF(OKK5>96,96+SQRT(OKK5-96),IF(OKK5<1,1,OKK5)),COLORBLUE,LINETHICK2;

OKK7:=((OKK2+10)/(OKK0+10))*((NOK+10)/(OKK4+10))*((OKK4+10)/(OKK0+10))*2;
OKK8:=IF(OKK7>100,100+SQRT(OKK7-100),OKK7);
OKK99:=98-SQRT(OKK8*NOK);
OKK9:=IF(OKK99<1,1-SQRT(ABS(OKK99)),OKK99);
OOK0:=(ABS(OKK0-OKK9)*1.18+18);
OOK1:=IF(OOK0<1,1,IF(OOK0>100,100,OOK0));
OOK2:=(106-(ABS(OKK0-OKK9)*1.14+14));
OOK3:=100-IF(OOK2<1,1,IF(OOK2>100,100,OOK2)),COLORWHITE,LINETHICK2;
OPK0:=EMA(SQRT(OKK2*NOK/OOK3)*12.6*ABS((OOK1+10)/(OKK9+10)),2);
OPK1:=0.76*OPK0*((REF(OKK0,1)+10)/(OKK0+10))*((REF(OKK0,1)+10)/(OKK0+10))*((REF(OKK9,1)+10)/(OKK9+10))*((REF(OKK9,1)+10)/(OKK9+10));
OPK:=IF(OPK1>96,96+SQRT(SQRT((OPK1-96)/2)),IF(OPK1<1,1,OPK1));
OQK0:=(OPK-OOK1)+50;
OQK:=IF(OQK0>98,98+SQRT(OQK0-98),IF(OQK0<1,1,OQK0));
VK0:=((OPK/(OQK+1))*(OOK3/(OKK0/主力警戒+1)+31));
VK:=96-IF(VK0>98,98+SQRT(VK0-98),IF(VK0<1,1,VK0));
VKK1:=SQRT((100-VK)*OOK3);
VLL:=106-IF(VKK1<1,1,IF(VKK1>99,99+SQRT((VKK1-99)/5),VKK1));
VKK2:=SQRT((116-VK)*OOK3+188)/(OPK1/NOK+0.36)/SQRT(ADXR/ADX);
WLL:=106-IF(VKK2<1,1,IF(VKK2>99,99+SQRT((VKK2-99)/6),VKK2)),COLORLIGRAY,LINETHICK3;

XLL0:=EMA(EMA(VLL*(OOK3+10)/(WLL+10)*(OOK3+10)/(WLL+10),2),2);
XLL:=111-IF(XLL0>96,96+SQRT((XLL0-96)/10),XLL0),COLORCYAN,LINETHICK2;
YLL0:=SQRT(XLL*(60+((OPK+10)/(OKK0+10)) *(((OOK3+10)/(WLL+10))/((NOK+10))/(VLL+10)))/((XLL+10)/(WLL+10))/((XLL+10)/(WLL+10)) );
YLL:=IF(YLL0>99,99+SQRT((YLL0-99)/50),YLL0),COLORYELLOW,LINETHICK1;
VOK0:=EMA(EMA(((OKK0/WLL)*VLL)*SQRT((SQRT(((OKK0+10)/(VLL+10))*((OKK0+10)/(WLL+10))))/((OKK0+6)/(REF(OKK0,1)+6))),2),2);
VOK:=(100-IF(VOK0>97,97+SQRT(SQRT(VOK0-97)),IF(VOK0<0,0-SQRT(0-VOK0),VOK0)))*0.88,COLORBLUE,LINETHICK2;
WOK:SQRT(VOK*YLL),COLORLIBLUE,LINETHICK2,NODRAW;


R1:=(CLOSE-LLV(LOW,90))/(HHV(HIGH,90)-LLV(LOW,90))*200;
R2:=EMA((CLOSE-(LLV(LOW,5)))/((HHV(HIGH,5))-(LLV(LOW,5)))*100,4)*2;
R3:=EMA(0.618*REF(R2,1)+0.382*R2,2);
R4:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
R5:=POW(MA(LOW,5),2)+MA(LOW,5);
R6:=POW(MA(HIGH,5),2)+MA(HIGH,5);
R7:=(R4-LLV(R5,64))/(HHV(R6,64)-LLV(R5,64))*150+65-10;
R8:=SMA((SMA(R7,3,1)*1.5-100),3,1);
R9:=3*(SMA(R7,3,1)*1.5-100)-2*R8;
R10:=(HIGH+LOW+CLOSE*2)/4;
R11:=(R10-(EMA(R10,13)))*100/(STD(R10,13));
R12:=EMA((EMA(R11,5)),13)+200-100;
R13:=(SMA(R1,3,1))+R2+(SMA(R7,3,1)*1.5-100)+R12;
R14:=(SMA((SMA(R1,3,1)),3,1))+R3+R8+(EMA(R12,10));
R15:=(3*(SMA(R1,3,1))-2*(SMA((SMA(R1,3,1)),3,1)))+(3*R12-2*(EMA(R12,10)))+R9+(3*R12-2*(EMA(R12,10)));
R16:=(HIGH+LOW+CLOSE)/3;
R17:=(R16-MA(R16,34))/(0.015*AVEDEV(R16,34));
R18:=(HIGH+LOW+CLOSE+R16)/4;
R19:=(R18-(EMA(R18,24)))/(STD(R18,24))*100;
R20:=(R16-MA(R16,24))/(0.015*AVEDEV(R16,24));
R21:=(((EMA(R19,5))+R20+R17)/3+165)/4;
R22:=(R13+R14+R15*30)/32/5-15;
R23:=((R21+R22)/2/1.5);
买卖:=100-IF(R23<-5,-5,R23);
阻力:=EMA(EMA(买卖,3),2);


圈:=100*(HHV(HIGH,42)-C)/(HHV(HIGH,42)-LLV(LOW,42));
M圈:=EMA(EMA(圈,3),2);
MM圈:=EMA(EMA(EMA(圈,4),3),2);
QXBL:=M圈*6/MM圈;
WKV0:=QXBL*QXBL*CS/10;
WKV:=IF(WKV0>90,90,WKV0);
EWKV:=EMA(EMA(EMA(WKV,3),3),2);
VAR1:=EMA(EMA(EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),2),2);
散筹集中度1:=(WINNER(C*1.1)-WINNER(C*0.9))*100;
天:=IF(散筹集中度1<0,0,IF(散筹集中度1>100,100,散筹集中度1));
散筹集中度:=(WINNER(C*1.1)-WINNER(C*0.9))*50/SQRT(EWKV/阻力);
人:=IF(散筹集中度<0,0,IF(散筹集中度>100,100,散筹集中度));
JZDV0:=EMA(SQRT(天*(天/人)*(天/人))*5,2);
JZDV1:=(100-JZDV0);
JZD0:=IF(JZDV0>100,100,IF(JZDV0<0,0,JZDV0));
JZD1:=IF(JZDV1>100,100,IF(JZDV1<0,0,JZDV1));
TJZD:=JZD1*15/JZD0;
OKJ:=JZD1*66/JZD0;
暴涨1:=IF(OKJ>100,100+SQRT(OKJ-100)/2,OKJ);
暴涨2:=IF(TJZD>100,100+SQRT(TJZD-100),TJZD);
TJZD1:=JZDV1*15/JZDV0;
OKJ1:=(暴涨1+JZDV1*60/JZDV0+50)/2;
涨势:=IF(OKJ1>100,100+SQRT(OKJ1-100)/2,IF(OKJ1<0,0,OKJ1));
OKJ2:=100-100*SQRT(SQRT((暴涨1/REF(涨势,1))*(暴涨2/REF(涨势,1))*(暴涨1/REF(JZD1,1))*(暴涨2/REF(JZD1,1))));
OKJZD:=IF(OKJ2>100,100+SQRT(OKJ2-100),IF(OKJ2<0,0,OKJ2));
TJZB4:=MA(100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)),5);
TJZB5:=MA(100*(C-LLV(L,50))/(HHV(C,50)-LLV(L,50)),5);
TJZB6:=MA(100*(C-LLV(L,120))/(HHV(C,120)-LLV(L,120)),5);
VDIM0:=ABS(MAX(TJZB5,TJZB6)/MIN(TJZB5,TJZB6)-1);
VDIM1:=EMA(OKJZD*VDIM0,2);
VDIM2:=ABS(MAX(TJZB5,TJZB4)/MIN(TJZB5,TJZB4)-1);
VDIM3:=EMA(OKJZD*VDIM2,2);
VDIM4:=(VDIM1+VDIM3)/2;
VDIM:=IF(VDIM4>100,100,VDIM4);
TVAR0:=VAR1/VDIM-1;
TVAR1:=IF(TVAR0<0,0,10*SQRT(SQRT(TVAR0)));
TVAR2:=SQRT(涨势*VAR1/VDIM)*1.1;
TVAR:=IF(TVAR2>100,100,TVAR2);
UVV1:=SQRT(JZD0*暴涨1*200/TVAR/(暴涨1+1));
UVV2:=IF(UVV1>98,98,IF(UVV1<1,1,UVV1));
{------------------------------------------------------------------};
A0:=(H+L+C*2)/4;A1:=HHV(A0,21);
A2:=LLV(A0,21);A3:=A1-A2;
A趋势:=EMA((A0-A2)/A3,2)*100;
XL0:=A趋势/REF(A趋势,1);
XL1:=(阻力+20)/REF(阻力+20,1);
XL2:=EWKV/REF(EWKV,1);
XL3:=TVAR/REF(TVAR,1);
XL4:=暴涨2/REF(暴涨2,1);
XL5:=((XL2+2)*(XL2+2))/ABS(XL0*XL1*XL3+XL4);
XL6:=(XL5+5)*(XL5+5)*(XL5+5)*SQRT(EWKV)/SQRT(暴涨2+0.5)/SQRT(A趋势)/(UVV2+1);
XL7:=(100-IF(XL6>98,98,XL6))*TVAR/98;
UVAR:=IF(XL7>98,98,XL7);
XL8:=(IF(EWKV<0,0,EWKV)+25)*(IF(EWKV<0,0,EWKV)+25)/((100-IF(XL6>99,99,XL6))*(100-IF(XL6>99,99,XL6))/SQRT(XL7*ABS(阻力)));
好买:=100-IF(XL8>98,98,XL8);
YL0:=(好买+1)*2/(EWKV+1);
YL1:=YL0*YL0;
YL2:=(UVAR+1)/(好买+1);
YL3:=SQRT(YL1*YL2*YL2*YL2)*5;
主升:=IF(YL3>99,99+SQRT(SQRT(YL3-99)),YL3);
ZV0:=REF(UVAR,2)/(主升+10);
ZV1:=REF(主升,2)/(暴涨2+10);
ZV2:=REF(UVAR,2)/(暴涨2+10);
ZV3:=(ZV0+ZV1+ZV2)*11;
妖线1:=100-SQRT(SQRT((好买+1)/(ZV3+1))*SQRT(UVAR*主升*暴涨2))*3;
妖线:=IF(妖线1>90,90+SQRT(妖线1-90),IF(妖线1<1,1,妖线1));
BDFF1:=ABS(好买-妖线)/(REF(WKV,1)/WKV)/YL0*(REF(EMA(好买+1,5),1)/EMA(妖线+1,5));
轨轨:=100-IF(BDFF1>98,98,BDFF1),COLOR996633,LINETHICK2;
BDFF2:=SQRT(轨轨*(轨轨/阻力)/(REF(EWKV,1)/EWKV)/(阻力/REF(阻力,1)));
BDFF3:=EMA(SQRT(BDFF2*BDFF2*BDFF2),2);
上轨:IF(BDFF3>90,90,BDFF3),COLORYELLOW,LINETHICK2;

中轨1:=100-IF(BDFF1>90,90,BDFF1);
BDFF5:=SQRT(中轨1*(中轨1/阻力)/((REF(妖线,1)/妖线)/(REF(EWKV,1)/EWKV)));
BDFF6:=EMA(SQRT(SQRT(BDFF5*BDFF5*BDFF5*(妖线+1)*(阻力+1)*(YL0+1)))*(阻力/REF(阻力,1)),2);
中轨:=IF(BDFF6>90,90+SQRT(SQRT(BDFF6-90)),IF(BDFF6<1,1,BDFF6));
XOK0:=100-ABS(上轨-中轨);
XOK1:=100-ABS(中轨-XOK0);
XOK2:=SQRT(XOK0*XOK1);
XOK3:=(100-(SQRT(WOK*中轨/上轨*OKK0)))*0.88;
潜能上行:IF(XOK3<1,1,XOK3),COLORWHITE,DOTLINE;

(100-OKK0)*0.9,COLORFF3311,LINETHICK2;
主升能量:(100-SQRT((EMA(EMA((100-"PAVE.CV")/2,3),2)-50)*中轨))*0.96,COLORWHITE,LINETHICK2;

SW多空对比
DRAWGBK(1,RGB(1,1,1),RGB(1,1,1),0,'00',0);
RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*106;
短多0:=EMA(SMA(RSV,3,1),2);
短多:=IF(短多0>99,99+SQRT(短多0-99),短多0);
短空:=100-EMA(SMA(短多,3,1),2),COLORFFFFFF,LINETHICK1;
RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*106;
中多:=SMA(RSV1,7,1),COLOR000080,LINETHICK1;
中空:=SMA(中多,10,1),COLOR282800,LINETHICK1;
DRAWBAND(短多,RGB(66,11,33),短空,RGB(66,77,88));
DRAWBAND(中多,RGB(118,66,44),中空,RGB(1,66,1));

NN:=42;
圈圈:=100-100*(HHV(HIGH,NN)-C)/(HHV(HIGH,NN)-LLV(LOW,NN));
M圈圈:=EMA(EMA(圈圈,3),2);
MM圈圈:=EMA(EMA(EMA(圈圈,5),3),2);
DRAWBAND(M圈圈,RGB(222,99,55),MM圈圈,RGB(11,222,244));

圈:=100-100*(HHV(HIGH,NN)-C)/(HHV(HIGH,NN)-LLV(LOW,NN));
M圈:=EMA(EMA(圈,3),2);MM圈:=EMA(EMA(EMA(圈,4),3),2);
ZLCQ:=EMA((WINNER(CLOSE) * 69),3);
SHCQ:=EMA(((WINNER((CLOSE * 1.1)) - WINNER((CLOSE * 0.93))) * 80),3);
主力控盘Q:=EMA(((ZLCQ / (ZLCQ+ SHCQ)) * 110),2);
上限Q:=HHV(主力控盘Q,20);
下限Q:=LLV(主力控盘Q,20);
MTR:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
ADXX0:=EMA(100-EMA(ABS(MDI-PDI)/(MDI+PDI)*主力控盘Q+下限Q,6),3);
ADXX:=IF(ADXX0<0.5,0.5,IF(ADXX0>106,106,ADXX0));
ADXXR:=EXPMEMA(ADXX,5),COLORGRAY,LINETHICK3;
DRAWBAND(ADXXR,RGB(166,11,66),ADXX,RGB(55,166,66));
DRAWBAND(短空,RGB(188,166,11),100-短多,RGB(88,66,188));
100-短多,COLORGRAY,LINETHICK1;
短空,COLORGRAY,LINETHICK1;


长期2:=EMA(100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)),2);
引导线:=100-("PAVE.MCV"+101);
主导线0:=("PAVE.DIFF"+96);
主导线:=IF(主导线0>101,101,主导线0);
下轨:=EMA(SQRT((SW筹码能量6.WLL)*引导线),2)*0.80;{SW筹码能量66.YLL}
中轨:=EMA(SQRT((SW筹码能量6.WLL)*SQRT(引导线*主导线)),2);
上轨0:=EMA(SQRT(SW筹码能量6.WLL)*(SQRT((主导线)+(引导线)/((100-下轨)+(100-中轨))))+3,2);
上轨:=IF(上轨0>100,100,上轨0),COLORWHITE;
下下轨:=(中轨+下轨)/2;
上上轨:=(中轨+上轨)/2;
上轨1:=EMA(EMA(SQRT(SW筹码能量6.WLL)*(SQRT((主导线+100-下轨)/(99-引导线+中轨)))*5,2),2);
上上1:=IF(上轨1>98,98,IF(上轨1<1,1,上轨1));
上轨2:=EMA(SQRT(SW筹码能量6.WLL+中轨)*(SQRT((上上1+上上轨)/(引导线+主导线)))*5,2);
上上2:=IF(上轨2>100,100+SQRT(SQRT(上轨2-100)),IF(上轨2<1,1,上轨2));
多方趋势:=3.3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),COLORYELLOW;
{=======================================================================================}
ADX0:=EMA(EMA(96-EMA(ABS(MDI-PDI)/(MDI+PDI)*主力控盘Q+下限Q,6),5),3);
ADX:=IF(ADX0<1,1,IF(ADX0>96,96,ADX0));
VAR11:=(HHV(HIGH,8)-CLOSE)/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR33:=100-3*SMA((CLOSE-LLV(LOW,72))/(HHV(HIGH,72)-LLV(LOW,72))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,72))/(HHV(HIGH,72)-LLV(LOW,72))*100,20,1),15,1);
活筹OAMV:=EMA(VAR33,2);
做空资金:=EMA(EMA(SMA(VAR11,6,1)-7,2),2);
WR线:=EMA(EMA(100*(HHV(HIGH,42)-CLOSE)/(HHV(HIGH,42)-LLV(LOW,42)),3),3);
SBZLPA1:=BARSLAST(L=HHV(L,7));
SBZLPA2:=EMA(SBZLPA1*SBZLPA1,13);
我心飞扬:=IF(SBZLPA2>88,88+SQRT(SBZLPA2-88),SBZLPA2);
TPV:=(我心飞扬+做空资金+活筹OAMV)*上上1;
T我心飞扬:=(我心飞扬+TPV)/2;
T做空资金:=(做空资金+TPV)/2;
控盘主升Q:=EMA(主力控盘Q,2);

KONGQ0:=(上限Q*上上1/控盘主升Q/长期2)*(下限Q*上上1/控盘主升Q/长期2)*50;
KONGQ:=IF(KONGQ0>100,100,IF(KONGQ0<1,1,KONGQ0));
MAXV:=MAX(T做空资金,T我心飞扬);
MINV:=MIN(T做空资金,T我心飞扬);
MMV0:=MAXV/MINV;
MMV1:=T做空资金/REF(T做空资金,1);
MMV2:=T我心飞扬/REF(T我心飞扬,1);
散筹集中度Q:=EMA(EMA((WINNER(C*1.1)-WINNER(C*0.9))*中轨/MMV0/MMV1/MMV2,3),2);
KKONG0:=KONGQ*KONGQ*中轨/SQRT(散筹集中度Q)/控盘主升Q;
KKONG:=IF(KKONG0>100,100,KKONG0);
KV0:=KKONG/KONGQ;
KV1:=KONGQ/REF(KONGQ,1);
KV2:=KKONG/REF(KKONG,1);
KV3:=EMA(KV0*KV0*KV1*KV2*30,2);{*30}
OKV:=IF(KV3>100,100,IF(KV3<1,1,KV3));
WVQ0:=1.18*(上限Q*下限Q+6)/(KONGQ+2)/SQRT(SQRT((OKV+2)/(KONGQ+5)));
WVQ1:=IF(WVQ0>100,100+SQRT(WVQ0-100),IF(WVQ0<1,1,WVQ0));
WVVQ:=(IF(WVQ1<0.5,0.5,IF(WVQ1>99,99+SQRT(WVQ1-99),WVQ1)));
WVVQ0:=IF(WVVQ<0,0-SQRT(0-WVVQ),WVVQ);
WVVQQ:=IF(WVVQ0>99,99+SQRT(WVVQ0-99),IF(WVVQ0<1,1,WVVQ0));

XVV0:=(100-SW筹码能量66.OKK0)*(短多/上上2)*SQRT((REF(中空,2)/中空)*(REF(MM圈,1)/MM圈));
XVVQ:=IF(XVV0>99,99,XVV0),COLORBLUE;
XVV1:=(100-SW筹码能量66.OKK0)*(短多/上上2)*SQRT((REF(中空,2)/中空)*(REF(MM圈,1)/MM圈))*0.88;
XVVR:=IF(XVV1>96,96+SQRT((XVV1-96)/2),IF(XVV1<1,1,XVV1)),COLORWHITE,DOTLINE;

XV0:=(100-XVVR)/REF((100-XVVR),1);
XV1:=XVVQ/REF(XVVQ,1);
XV2:=(100-30*XV0*XV0/XV1);
XV3:=IF(XV2>96,96+SQRT(SQRT(100+XV2)/10),IF(XV2<1,1,XV2));
XVVS:=100-(50+(XV3-(100-XVVR))/2),COLORFF00FF;

XV4:=SQRT((100-XVVR)*XVVS/XVVQ*SQRT(XVVQ*WVVQQ/XV3))*1.36;
XVVT:IF(XV4>96,96+SQRT(SQRT(XV4-96)/10),IF(XV4<1,1,XV4)),COLORRED,LINETHICK3;

YVV1:=(100-SQRT(多方趋势*XVVS+(XVVS)*((100-XVVR))/(XVVT)));{YVVQ}
YVV11:=IF(YVV1>99,99+SQRT(YVV1-99),IF(YVV1<1,1,YVV1));
YVVR:=SQRT(YVV11*(100-XVVR)),COLORLIGRAY,LINETHICK4;
ZVVR:(100-SW筹码能量66.WOK),COLORYELLOW,LINETHICK2;
ZVVS:(100-SW筹码能量66.OKK0)*0.9,COLORFF6611,LINETHICK4;

ZVV0:=(REF(XVVR,1)/XVVR)*(((REF(ZVVS,1)+10)/(ZVVS+10)))*XVVT;
ZVVA:IF(ZVV0>99,99+SQRT(SQRT(ZVV0-99)),IF(ZVV0<1,1,ZVV0)),COLORFF00FF,DOTLINE;
YVV6:=0.88*(SQRT((ZVVS)*((100-(ABS(ZVVS-ZVVA)+1)+(ABS(YVVR-ZVVA)+1)/(ABS(YVVR-ZVVA)+1)))));
ZVVT:IF(YVV6>99,99,IF(YVV6<1,1,YVV6)),COLORCYAN,LINETHICK2;


 
优化版“筹码能量” 我心飞扬 通达信指标 附图 贴图 不加密 无未来函数(三)
打开微信扫一扫,一键复制指标源码,
轻松快捷粘贴至手机通达信APP中。

Tags:

作者:佚名

公式评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论
Copyright © 2009-2019 GPxiazai.com. All Rights Reserved .
备案号: 苏ICP备12020055号-2 苏公网安备 32058302001104号
声明:本站所有信息免费,广告收费行为均与本站无关. 侵权请联系QQ929946094进行处理.
若本站收录的软件无意侵犯了贵司版权,请联系QQ929946094进行处理,谢谢!