股票下载网 股票软件7351 个 ┆ 股票公式33945 个 ┆ 炒股知识3863
首 页炒股知识股票软件股票公式技术指标设为首页  加入收藏  放到桌面本站分类
当前位置:股票下载网股票公式通达信公式
日期:2018-11-29 09:55:00  来源:本站整理

黑马 极点精准线 通达信主图指标 源码 贴图

黑马 极点精准线 通达信主图指标 源码 贴图

黑马 极点精准线 通达信主图指标 源码 贴图

黑马 极点精准线 通达信主图指标 源码 贴图点击下载黑马 极点精准线 通达信主图指标 源码 贴图


顶底开关:=1;
点位差:=1;
指定点:=10;
DRAWGBK(O>0,RGB(33,47,58),RGB(0,0,0),0,'02',0);
{标缺口}
LL:=REF(L,1);HH:=REF(H,1);上跳:=L>HH;下跳:=H<LL;
STICKLINE(L>REF(H,1),L,REF(H,1),3.1,-1),COLORRED;
STICKLINE(REF(L,1)>H,REF(L,1),H,3.1,-1),COLORGREEN;
{灰色}
STICKLINE(O>=C,H,L,0,0),COLOR909090;
STICKLINE(O>=C,C,O,3.1,0),COLOR606060;
STICKLINE(O>=C,C,O,2.1,0),COLOR707070;
STICKLINE(O>=C,C,O,1.2,0),COLOR808080;
STICKLINE(O>=C,C,O,0.2,0),COLOR909090;
STICKLINE(O<=C,H,L,0,0),COLOR666B6F;
STICKLINE(C>O,C,O,3.1,1),COLOR666B6F;
V2V:=V/REF(V,1)>=1.9 AND C>REF(C,1);
{金黄色}
STICKLINE(V2V,H,L,0,0),COLORYELLOW;
STICKLINE(V2V,O,C,3.1,0),COLOR0033FF;
STICKLINE(V2V,O,C,2.1,0),COLOR0077FF;
STICKLINE(V2V,O,C,1.1,0),COLOR00BBFF;
STICKLINE(V2V,O,C,0.1,0),COLOR00FFFF;
{涨停粉}
ZT:=C/REF(C,1)>1.097;
ZT数:COUNT(ZT,BARSSINCE(ZT)),NODRAW;
{涨停红色}
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF>9.5,C,O,3.1,0),COLOR0000CC;
STICKLINE(ZDF>9.5,C,O,2.1,0),COLOR0000DD;
STICKLINE(ZDF>9.5,C,O,1.2,0),COLOR0000EE;
STICKLINE(ZDF>9.5,C,O,0.2,0),COLOR0000FF;
STICKLINE(ZDF>9.5,H,L,0,0),COLOR0000FF;
{跌停绿色}
STICKLINE(ZDF<-9.9,O,C,3.1,0),COLOR66CC66;
STICKLINE(ZDF<-9.9,O,C,2.1,0),COLOR77DD77;
STICKLINE(ZDF<-9.9,O,C,1.2,0),COLOR88EE88;
STICKLINE(ZDF<-9.9,O,C,0.2,0),COLOR99FF99;
STICKLINE(ZDF<-9.5,H,L,0,0),COLOR99FF99;
均价:=AMO/VOL/100;
假阴真阳:=C<O AND C>=REF(MIN(C,O),1) AND 均价>REF(均价,1);
{蓝}
DT:=假阴真阳;
STICKLINE(DT,H,L,0,0),COLORFFAA00;
STICKLINE(DT,O,C,3,0),COLORFF3300;
STICKLINE(DT,O,C,2,0),COLORFF7700;
STICKLINE(DT,O,C,1,0),COLORFFAA00;
STICKLINE(DT,O,C,0.1,0),COLORFFFF00;
YX:=REF(O,BARSLAST(假阴真阳));
假阴实顶:YX,COLORFF7700,NODRAW;
STICKLINE(V,YX,YX,1,0),COLORFF7700;
L0:=点位差/100;
前极点精准线:IF(顶底开关=0,CONST(REF(L,指定点)),CONST(REF(H,指定点))),COLOR178448;
DRAWICON(ABS(L-前极点精准线)<=L0,前极点精准线*0.99,38);
DRAWICON(ABS(H-前极点精准线)<=L0,前极点精准线*1.01,39);
{H极点精准线:CONST(REF(H,指定点)),COLOR7777FF;
DRAWICON(ABS(H极点精准线-H)<=L0,H极点精准线*1.01,35);
DRAWICON(ABS(H极点精准线-L)<=L0,H极点精准线*0.99,34);}
{极点精准线:CONST(L),COLOR0077FF;
DRAWICON(ABS(L-极点精准线)<=L0,极点精准线*0.99,1);
DRAWICON(ABS(H-极点精准线)<=L0,极点精准线*1.01,2);
同向极点精准数:COUNT(ABS(L-极点精准线)<=L0,60)-1,COLOR0077FF,NODRAW;
异向极点精准数:COUNT(ABS(H-极点精准线)<=L0,60),COLOR0077FF,NODRAW;
XG:=同向极点精准数>0 AND 异向极点精准数>0;}
{DIFF:=10*(EMA(CLOSE,12)-EMA(CLOSE,26));
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
量缩价涨:=C<REF(O,1) AND V<REF(V,1) AND MACD>REF(MACD,1) AND C>REF(C,1) AND REF(C<O,1) AND C>O;
阴KDAY:=BARSLAST(量缩价涨)+1;
STICKLINE(V,REF(O,阴KDAY),REF(O,阴KDAY),3.5,0),COLORMAGENTA;
DRAWICON(CROSS(C,REF(O,阴KDAY)),L,1);}
DRAWTEXT_FIX(ISLASTBAR,0.5,0.05,0,CODE),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.05,0,STKNAME)COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.6,0.05,0,HYBLOCK),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.6,0,0,DYBLOCK),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.85,0,GNBLOCK),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.90,0,FGBLOCK),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.95,0,ZSBLOCK);

 
黑马 极点精准线 通达信主图指标 源码 贴图
打开微信扫一扫,一键复制指标源码,
轻松快捷粘贴至手机通达信APP中。

Tags:

作者:佚名

公式评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论
Copyright © 2009-2019 GPxiazai.com. All Rights Reserved .
备案号: 苏ICP备12020055号-2 苏公网安备 32058302001104号
声明:本站所有信息免费,广告收费行为均与本站无关. 侵权请联系QQ929946094进行处理.
若本站收录的软件无意侵犯了贵司版权,请联系QQ929946094进行处理,谢谢!