»查看更多分类股票软件

金砖主图 强势选股 大智慧指标 源码 贴图

发布时间:2018-11-20 10:07:00  点击:

 {四价数据}
n:=30;m:=95;

C1:REF(C,1),linethick0;
L1:REF(L,1),linethick0;
{引用 自定义}
买入日期:=selfstring('买入日期');
买入价:=SELFDATA('买入价');
{以下设置个股信息}
DRAWTEXTREL(5,950,'■今天日期: '+YEAR+'年 '+MONTH+'月 '+DAY+'日 '),linethick2,Colormagenta,layer0;
WW:=BARSLAST(DISPSTATUS=1);
天:=BARSLAST(L=LLV(LOW,WW));
DRAWTEXTREL(5,915,'■目前可见K线:'+NUMTOSTRN(WW+1,0)+'天 50~65天看短中波段'),linethick1,COLOR00ff00,layer0;
{MACD优化----大智慧L2版本}
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA := EMA(DIFF,9);
MACD:= 2*(DIFF-DEA);
主升:= DIFF>0 AND DIFF>DEA;
结束:=CROSS(DEA,DIFF);
强度:=DIFF-DEA;
强度1:=ref(强度,1);
{FILLRGN(DIFF,DEA,主升,RGB(250,0,0));}
转弱:=DIFF>0 AND 强度<强度1;
ZSQD1:=主升=1 AND 强度>强度1;{强上}
ZSQD2:=主升=1 AND 强度<强度1;{转弱}
ZSQD3:=主升<=O AND DIFF>DEA;
ZSQD4:=主升<=O AND DIFF<DEA;
IF BARSTATUS=2 AND ZSQD1 THEN BEGIN
DRAWTEXTREL(400,120 ,'● MACD 0线上 上升中 持股!'),COLOR0000FF,LINETHICK2,LAYER0;
END
ELSE
IF BARSTATUS=2 AND ZSQD2 THEN BEGIN
DRAWTEXTREL(400,120 ,'● MACD 0线上 下降中 小心!'),COLOR00FFFF,LINETHICK2,LAYER0;
END
ELSE
IF BARSTATUS=2 AND ZSQD3 THEN BEGIN
DRAWTEXTREL(400,120 ,'● MACD 0线下 上升中 观望!'),COLORFFFFFF,LINETHICK2,LAYER0;
END
ELSE
IF BARSTATUS=2 AND ZSQD4 THEN BEGIN
DRAWTEXTREL(400,120 ,'● MACD 0线下 下降中 放弃!'),COLOR00FF00,LINETHICK2,LAYER0;
END
{回调买入}
{HH:=HHV(HIGH,10);
LL:=LLV(LOW,30);
回调:=(HH+LL)/2;
DRAWTEXTREL(5,770,'■ 十天最高价:'+NUMTOSTRN(HH,2)+'元'),COLOR00ffff,LINETHICK1;
DRAWTEXTREL(5,810,'■ 三十天最低价:'+NUMTOSTRN(LL,2)+'元'),COLOR00ffff,LINETHICK1;
DRAWTEXTREL(5,850,'■ 回调买入价:'+NUMTOSTRN(回调,2)+'元 收盘价:'+NUMTOSTRN(C,2)+'元'),COLOR00ffff,LINETHICK1;}

DRAWTEXTREL(250,20,' 趋势分析'),COLORFFFFFF,layer0,LINETHICK2;

{3 8 21 均线}
MA3:=MA(CLOSE,3);
MA8:=MA(CLOSE,8);
MA21:=MA(CLOSE,21);
三线红:=MA3>REF(MA3,1) AND MA8>REF(MA8,1) AND MA21>REF(MA21,1);
三线上:=MA3>MA8 AND MA8>MA21
AND MA3>REF(MA3,1) AND MA8>REF(MA8,1) AND MA21>REF(MA21,1) ;
回调线:=MA3<REF(MA3,1) AND MA8>REF(MA8,1) AND MA21>REF(MA21,1) ;
趋势:=MA21/REF(MA21,1);
趋势1:=趋势>=1.003;
趋势2:=趋势<1.003;
趋势3:=趋势<0;
IF BARSTATUS=2 AND 趋势1 THEN BEGIN
DRAWTEXTREL(240,120 ,'● 均线趋势 走强 持股!'),COLOR0000FF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND 趋势2 THEN BEGIN
DRAWTEXTREL(240,120 ,'● 均线趋势 走平 小心!'),COLOR00FFFF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND 趋势3 THEN BEGIN
DRAWTEXTREL(240,120 ,'● 均线趋势 走弱 退场!'),COLOR00FF00,LINETHICK2;
END
{DRAWTEXT(MA21,MA21,'●'),COLORGREEN,linethick1,align1 ;}
{DRAWTEXT(MA21>ref(ma21,1),MA21,'◎'),COLOR00FF00,linethick1,align1 ;}
天数21:=barslast(CROSS(MA21,ref(ma21,1)));{计算上涨天数};

{新牛股公式}
牛股:=100-100*(HHV(HIGH,5*8)-CLOSE)/(HHV(HIGH,5*8)-LLV(LOW,5*8));
牛现:CROSS((100-100*(HHV(HIGH,5*8)-CLOSE)/(HHV(HIGH,5*8)-LLV(LOW,5*8))),99),linethick0;
kk:=-150;
kkk:=790;
NG1:=牛股>REF(牛股,1);
NG2:=牛股<REF(牛股,1);
NG3:=牛股=REF(牛股,1);
IF BARSTATUS=2 AND NG1 THEN BEGIN
DRAWRECTREL(380+kk,50+kkk,520+kk,220+kkk,rgb(0,0,255)),layer0,colorffffff,LINETHICK1;
DRAWTEXTREL(382+kk,70+kkk,' 【股价 上升】'),COLORRED,linethick3,layer0;
DRAWTEXTREL(382+kk,120+kkk,' 今日趋势: '+NUMTOSTRN(牛股,2)),COLORRED,linethick2,layer0;
DRAWTEXTREL(382+kk,170+kkk,' 昨日趋势: '+NUMTOSTRN((REF(牛股,1)),2)),COLORGREEN,linethick2,layer0;
DRAWTEXTREL(870,940,'金砖强势选股'),COLOR0000FF,linethick4,layer0;
END
ELSE
IF BARSTATUS=2 AND NG2 THEN BEGIN
DRAWRECTREL(380+kk,50+kkk,520+kk,220+kkk,rgb(47,79,79)),layer0,color00FF00,LINETHICK1;
DRAWTEXTREL(382+kk,70+kkk,' 【股价 下跌】'),COLORFFFFFF,linethick2,layer0;
DRAWTEXTREL(382+kk,120+kkk,' 今日趋势: '+NUMTOSTRN(牛股,2)),COLORFFFFFF,linethick2,layer0;
DRAWTEXTREL(382+kk,170+kkk,' 昨日趋势: '+NUMTOSTRN((REF(牛股,1)),2)),COLORRED,linethick2,layer0;
DRAWTEXTREL(870,940,'金砖强势选股'),COLOR00FF00,linethick4,layer0;
END
ELSE
IF BARSTATUS=2 AND NG3 THEN BEGIN
DRAWRECTREL(380+kk,50+kkk,520+kk,220+kkk,rgb(0,0,255)),layer0,colorFFFFFF,LINETHICK1;
DRAWTEXTREL(382+kk,70+kkk,' 【股价 平盘】'),COLORYELLOW,linethick3,layer0;
DRAWTEXTREL(382+kk,120+kkk,' 今日趋势: '+NUMTOSTRN(牛股,2)),COLORYELLOW,linethick2,layer0;
DRAWTEXTREL(382+kk,170+kkk,' 昨日趋势: '+NUMTOSTRN((REF(牛股,1)),2)),COLORFFFFFF,linethick2,layer0;
DRAWTEXTREL(870,940,'金砖强势选股'),COLORFFFFFF,linethick4,layer0;
END
NX:=牛现>0;
IF BARSTATUS=2 AND NX THEN BEGIN
DRAWRECTREL(380+kk,50+kkk,520+kk,220+kkk,rgb(0,0,255)),layer0,colorffffff,LINETHICK1;
DRAWRECTREL(398+kk,84+kkk,482+kk,183+kkk,rgb(255,0,0)),layer0,colorffffff,LINETHICK1;
DRAWTEXTREL(406+kk,110+kkk,'牛 股'),COLORFFFFFF,linethick5,layer0;
DRAWTEXTREL(870,940,'金砖强势选股'),COLOR0000FF,linethick4,layer0;
END
{买入表格}
DRAWTEXTREL(177,20,'昨今趋势'),COLORFFFFFF,layer0,LINETHICK2;
{显示金砖 蓝砖 DPPD提供薛丝通道公式}
XSVAR2:=CLOSE*VOL;
XSVAR3:=EMA((EMA(XSVAR2,3)/EMA(VOL,3)+EMA(XSVAR2,6)/EMA(VOL,6)+EMA(XSVAR2,12)/EMA(VOL,12)+EMA(XSVAR2,24)/EMA(VOL,24))/4,13);
XSVAR4:=EMA(CLOSE,9);
SUP:1.06*XSVAR3,linethick0;{强势上升}
SUP1:=REF(SUP,1);
SUP2:=REF(SUP,2);
HUP:EMA(XSVAR4*1.14,5),linethick0;{顶部高位}
{DRAWTEXT(HUP>ref(HUP,1),HUP,'◎'),COLORmagenta,linethick1,align1 ;}
金砖:=SUP>SUP1 AND C>SUP;
蓝砖:=SUP>SUP1 AND C<SUP;
IF BARSTATUS=2 AND 金砖 THEN BEGIN
DRAWTEXTREL(205,70,'■'),COLOR00FFFF,layer0,LINETHICK3;
END
ELSE
IF BARSTATUS=2 AND 蓝砖 THEN BEGIN
DRAWTEXTREL(205,70,'■'),COLOR00ff00,layer0,LINETHICK3;
END
金砖1:=SUP1>SUP2 AND C1>SUP1;
蓝砖1:=SUP1>SUP2 AND C1<SUP1;
IF BARSTATUS=2 AND 金砖1 THEN BEGIN
DRAWTEXTREL(177,70,' ■'),COLOR00FFFF,layer0,LINETHICK3;
END
ELSE
IF BARSTATUS=2 AND 蓝砖1 THEN BEGIN
DRAWTEXTREL(177,70,' ■'),COLOR00ff00,layer0,LINETHICK3;
END
STICKLINE(金砖,SUP,SUP1,6,0),CoLor00FFFF,LAYER0;{显示金砖}
STICKLINE(蓝砖,SUP,SUP1,6,0),CoLor00ff00,LAYER0;{显示蓝砖}
{显示砖量}
砖量:=(SUP-SUP1)-(SUP1-SUP2);
FDU1:=砖量>0;
FDU2:=砖量<0;
IF BARSTATUS=2 AND FDU1 THEN BEGIN
DRAWTEXTREL(240,70 ,'● 砖量 增大 持股!'),COLORRED,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND FDU2 THEN BEGIN
DRAWTEXTREL(240,70 ,'▼ 砖量 缩小 小心!'),COLOR00FFFF,LINETHICK2;
END

{显示红砖 起涨}
JZVAR1:=(CLOSE+HIGH+LOW)/(3);
JZVAR2:=EMA(JZVAR1,10);
红砖:=JZVAR2>REF(JZVAR2,1);
红砖1:=REF(JZVAR2,1)>REF(JZVAR2,2);
STICKLINE(红砖,JZVAR2,REF(JZVAR2,1),4,0),CoLorred,layer0;{显示红砖}
起涨1:=红砖>0;
IF BARSTATUS=2 AND 起涨1 THEN BEGIN
DRAWTEXTREL(205,110,'■'),COLORRED,layer0,LINETHICK3;
END
起涨2:=红砖1>0;
IF BARSTATUS=2 AND 起涨2 THEN BEGIN
DRAWTEXTREL(177,110,' ■'),COLORRED,layer0,LINETHICK3;
END
{强势股买入信号}
强买:=金砖>0{超级买入}
AND 三线上;
{ AND 天数<=6;}
VERTLINE(CROSS(强买,0.1),2),COLORmagenta,layer2;
DRAWTEXT(CROSS(强买,0.1),C,'----'+NUMTOSTRN(C,2)),Colormagenta,linethick2,layer0;
DRAWTEXT(CROSS(强买,0.1),H*1.03,'☆强买'),Colormagenta,linethick1,ALIGN1,layer0;
起涨A:=蓝砖>0 AND 红砖>0 AND MA21>REF(MA21,1) {起涨买入}
AND 天数21<=3;
{AND 三线红
AND (主升>0 OR REF(主升,1)>0) AND REF(DIFF,1)<0;
{AND SUP1<SUP2; }
VERTLINE(CROSS(起涨A,0.1),2),COLORFFFFFF,layer2;
DRAWTEXT(CROSS(起涨A,0.1),C,'----'+NUMTOSTRN(C,2)),ColorFFFFFF,linethick2,layer0;
DRAWTEXT(CROSS(起涨A,0.1),L*0.97,'☆起涨A'),ColorFFFFFF,linethick1,ALIGN1,layer0;

起涨B:=C1<SUP1 AND 蓝砖>0 AND 红砖>0 {起涨买入}
{AND 三线红}
AND (主升>0 OR REF(主升,1)>0) AND REF(DIFF,1)<0;
{AND SUP1<SUP2; }
VERTLINE(CROSS(起涨B,0.1),2),COLOR00FFFF,layer2;
DRAWTEXT(CROSS(起涨B,0.1),C,'----'+NUMTOSTRN(C,2)),Color00FFFF,linethick2,layer0;
DRAWTEXT(CROSS(起涨B,0.1),L*0.98,'☆起涨B'),Color00FFFF,linethick1,ALIGN1,layer0;
{强势股买入信号}
MR1:=(C1<SUP1 AND 金砖>0 AND 红砖>0 AND 三线上>0)
OR (蓝砖1>0 AND 金砖>0 AND 红砖>0 AND 三线上>0)
OR (金砖>0 AND 三线上);{强买信号}
MR2:=(C1<SUP1 AND 蓝砖>0 AND 红砖>0 AND 三线红>0 )
OR (蓝砖>0 AND 红砖>0 AND MA21>REF(MA21,1) AND REF(MA21,1)<REF(MA21,2))
OR (C1<SUP1 AND 蓝砖>0 AND 红砖>0);{起涨信号}
MR3:=金砖1>0 AND 金砖>0 AND 红砖>0 AND 三线上>0;
MR4:=蓝砖1>0 AND 蓝砖>0 AND 红砖>0 AND 三线上>0;
MR5:=(蓝砖1>0 AND 蓝砖>0 AND 红砖>0 AND 三线红>0) OR (金砖1>0 AND 蓝砖>0 AND 红砖>0 AND 三线红>0);
MR6:=回调线>0 AND 红砖>0;
MR7:=JZVAR2<REF(JZVAR2,1) OR 红砖=0 OR (金砖=0 AND 蓝砖=0);
IF BARSTATUS=2 AND MR1 THEN BEGIN
DRAWTEXTREL(600,50,'● 金砖出现 上涨行情 强买信号 MR1!'),COLORmagenta,LINETHICK4;
END
ELSE
IF BARSTATUS=2 AND MR2 THEN BEGIN
DRAWTEXTREL(600,50,'● 趋势转强 上升行情 起涨信号 MR2!'),COLOR00FFFF,LINETHICK4;
END
ELSE
IF BARSTATUS=2 AND MR3 THEN BEGIN
DRAWTEXTREL(600,50,'● 金砖出现 持续上涨行情 持股 MR3!'),COLOR0000FF,LINETHICK4;
END
ELSE
IF BARSTATUS=2 AND MR4 THEN BEGIN
DRAWTEXTREL(600,50,'● 趋势强 持续上升行情 MR4!'),COLORmagenta,LINETHICK4;
END
ELSE
IF BARSTATUS=2 AND MR5 THEN BEGIN
DRAWTEXTREL(600,50,'● 趋势平 持续上升行情 MR5!'),COLOR00FFFF,LINETHICK4;
END
ELSE
IF BARSTATUS=2 AND MR6 THEN BEGIN
DRAWTEXTREL(600,50,'● 金砖出现 回调行情 MR6!'),COLOR00CCFF,LINETHICK4;
END
ELSE
IF BARSTATUS=2 AND MR7 THEN BEGIN
DRAWTEXTREL(600,50,'▼ 金砖消失 看看就好!'),COLOR00FF00,LINETHICK4;
END
MR9:=金砖1>0 AND 金砖>0 AND JZVAR2>REF(JZVAR2,1)
AND C>HUP AND C1>REF(HUP,1)
AND C/REF(C,1)>1.05
AND REF(C,1)/REF(C,2)>1.05;
MR10:=金砖1>0 AND 金砖>0 AND JZVAR2>REF(JZVAR2,1)
AND C>HUP AND C1>REF(HUP,1)
AND C/REF(C,1)>1.05
AND REF(C,1)/REF(C,2)<1.05;
IF BARSTATUS=2 AND MR9 THEN BEGIN
DRAWTEXTREL(600,170,' ● 牛股 买入不后悔'),COLORRED,layer0,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND MR10 THEN BEGIN
DRAWTEXTREL(600,170,' ● 牛势 买入不后悔'),COLOR00FFFF,layer0,LINETHICK2;
END

{趋势分析}
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
BBB:=VAR1>VAR6 AND REF(VAR1,1)=REF(VAR6,1);
CCC:=VAR1>VAR6 AND VAR6>VAR4 AND REF(VAR1,1)=REF(VAR4,1);
DDD:=VAR1=VAR4 AND VAR4>REF(VAR4,1);
EEE:=VAR1>VAR6 AND VAR1>REF(VAR1,1) AND VAR6>REF(VAR6,1);
FFF:=REF(VAR1,1)=REF(VAR4,1) AND VAR4>VAR1;
GGG:=VAR1=VAR6 AND VAR6<REF(VAR6,1);
HHH:=VAR1<REF(VAR1,1) AND VAR5>VAR1;
III:=(VAR1=VAR6) OR (VAR6=VAR4);
IF BARSTATUS=2 AND BBB THEN BEGIN
DRAWTEXTREL(400,70,'● 调整结束短线介入'),COLOR00FFFF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND CCC THEN BEGIN
DRAWTEXTREL(400,70,'● 底部特征建仓时机'),COLOR00FFFF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND (DDD OR EEE) THEN BEGIN
DRAWTEXTREL(400,70,'● 上升通道走势良好'),COLOR0000FF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND FFF THEN BEGIN
DRAWTEXTREL(400,70,'▼ 顶部特征注意风险'),COLOR00FF00,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND (GGG OR HHH OR III) THEN BEGIN
DRAWTEXTREL(400,70,'▼ 下跌通道回避观望'),COLOR00FF00,LINETHICK2;
END
jjj:=ma8/ref(ma8,1)>1.022;
IF BARSTATUS=2 AND jjj THEN BEGIN
DRAWRECTREL(870,920,1000,1000,rgb(0,0,255)),layer0,colorffffff,LINETHICK1;
DRAWTEXTREL(880,935,'●大胆买入!'),COLOR0000ff,LINETHICK4,layer0;
END
{天河饮马老师的成交量分析}
TT1:=V>REF(V,1) AND MA(V,5)>REF(MA(V,5),1);
TT2:=V<REF(V,1) AND MA(V,5)>REF(MA(V,5),1);
TT3:=V>REF(V,1) AND MA(V,5)<REF(MA(V,5),1);
TT4:=V<REF(V,1) AND MA(V,5)<REF(MA(V,5),1);
IF BARSTATUS=2 AND TT1 THEN BEGIN
DRAWTEXTREL(600,120 ,' ● 今日成交量大于昨日,且有继续增大趋势'),COLOR0000FF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND TT2 THEN BEGIN
DRAWTEXTREL(600,120 ,' ● 今日成交量小于昨日,但有放大迹象'),COLORFFFFFF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND TT3 THEN BEGIN
DRAWTEXTREL(600,120 ,' ● 今日成交量大于昨日, 但有缩小迹象'),COLOR00FFFF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND TT4 THEN BEGIN
DRAWTEXTREL(600,120 ,' ● 今日成交量小于昨日,且有缩小迹象'),COLOR00FF00,LINETHICK2;
END;

金砖主图 强势选股 大智慧指标 源码 贴图

金砖主图 强势选股 大智慧指标 源码 贴图点击下载金砖主图 强势选股 大智慧指标 源码 贴图

金砖主图 强势选股 大智慧指标 源码 贴图
打开微信扫一扫,一键复制指标源码,
轻松快捷粘贴至手机通达信APP中。
0

本站提示:股市有风险,入市请慎重,资料由股票下载网整理收集

找不到你要的公式?给我们建议

  1. 股票软件
    股票分析软件
    股票交易软件
    股票行情软件
    指标股票池
    手机炒股软件
    书籍教程
    数据软件
    工具补丁
    大智慧
    通达信
    飞狐
    东方财富通
    操盘手
    指南针
    分析家
    同花顺
    钱龙
    证券之星
    券商股票软件
    特色行情软件
    迷你行情软件
    金融界软件
    美股外盘软件
    大智慧股票池
    通达信股票池
    大智慧L2公式
    通达信公式
    飞狐公式
    同花顺公式
    股票书藉
    视频教程
    金融书籍
    其他书籍
    资讯评测软件
    资金分析软件
    数据接口软件
    江恩波浪软件
    数据下载软件
    软件数据投资
    选股软件
    登录补丁
    其他应用
    股软教程
  2. 股票公式
    通达信公式
    大智慧公式
    飞狐公式
    同花顺公式
    东方财富通公式
    金字塔指标公式
    文华指标公式
    MT4指标
    博易大师指标
    公式教程答疑
  3. 炒股知识
    短线技巧
    软件公式
    炒股视频
    股票入门
    股市实战信息交流
    炒股技巧
    股票基础知识
    技术分析
    炒股一招先
    基本面分析
    股票视频教程
    股票买卖技巧
    k线图分析
    胡立阳教你买股票
    短线炒股技巧
    天狼之眼
    波浪理论技术讲解
    股市赢家杨百万
    股票理论、T0缠论、知识
    经典指标、交易系统
    成交量能、筹码分析
    买卖信号、技术分析
    挖坑、冼盘、吸筹、出货
    均线战法、黄金分割
    经典K线、趋势形态
    牛股黑马、王子理论
    涨停、周线、月线
    止盈、止损、支撑、压力
    案例、波浪、口诀、选股
    分时、盘口、补仓、解套
  4. 技术指标
    DDX
    DDY
    DDZ
    MACD
    KDJ
    CCI
    OBV
    BOLL
    RSI
    VOL
    CR
    WR