»查看更多分类股票软件

涨停密码 牛股三绝 通达信幅图指标 源码 贴图

发布时间:2018-11-09 09:38:00  点击:

涨停密码 牛股三绝 通达信幅图指标 源码 贴图

点击下载涨停密码 通达信幅图指标 源码 贴图


{------------ 基础部分 ------------}
0,POINTDOT,COLOR808080;
12,POINTDOT,COLOR808080;

绿低量:=10;
蓝低量:=50;
灰低量:=100;
量:=VOL;
换手:= VOL*10000/FINANCE(7),NODRAW;
全换手周期:= SUMBARS(V,CAPITAL),NODRAW;{求完全换手到现在的周期数}
量比:= V/REF(MA(V,5),1),NODRAW;
几倍:= V/REF(V,1),NODRAW;
倍数:=1.9;
倍量:= VOL>=REF(V,1)*倍数 AND (IF(CREF(C,1),1)),NODRAW;
倍缩:= REF(V,1)>=VOL*倍数,NODRAW;
平量:= RANGE(V/REF(V,1),0.97,1.03) AND BARSCOUNT(V)>=2,NODRAW;
低量10:= VOL=LLV(VOL,绿低量) AND BARSCOUNT(V)>=绿低量,NODRAW;
低量50:= VOL=LLV(VOL,蓝低量) AND BARSCOUNT(V)>=蓝低量,NODRAW;
地量:=VOL=LLV(VOL,灰低量) AND BARSCOUNT(V)>=灰低量,NODRAW;
真阳或假阴:=C>O OR C>REF(C,1);
收阳:= REF(真阳或假阴,3);
倍量1:=REF(倍量,3);
高量:=REF(V,3)>=HHV(V,7);
三日不破:= LLV(C,3)>=REF(L,3);
价升:=COUNT(C>=REF(C,1),3)=3;{收盘价逐升}
量缩:=COUNT(V<=REF(V,1),3)=3;
连阳:= COUNT(真阳或假阴,3)=3;
倍量将军柱:= 倍量1 AND 三日不破 AND 收阳;
高量将军柱:= 高量 AND 三日不破 AND 收阳;
V100:= V<=LLV(V,100)*1.2 AND V>0 AND BARSCOUNT(V)>=100;
NOTEXT_将军柱: REFX(倍量将军柱 OR 高量将军柱,3),NODRAW;
NOTEXT_黄金柱: NOTEXT_将军柱 AND REFX(价升,3) AND REFX(量缩,3) AND REFX(连阳,3),NODRAW;{标准黄金柱}
NOTEXT_元帅柱:REFX(NOTEXT_将军柱 OR NOTEXT_黄金柱,1) AND H<refx(l,1),nodraw;
百日地量群:COUNT(V100,5)>=3,COLORLIGRAY,NODRAW;

STICKLINE(百日地量群,1,1.5,2,0),COLORLIGRAY;

{------------ 涨跌停 ------------}
RC1:=REF(C,1);
CS:=IF(C>=1,10000,100000);
C涨停10:=1.10*RC1-49/CS;{考虑到4舍5入}
C涨停5 :=1.05*RC1-49/CS;
C跌停10:=0.90*RC1+51/CS;
C跌停5 :=0.95*RC1+51/CS;
ST:=NAMELIKE('S') OR NAMELIKE('*S');
盘中涨停:=IF(ST, H>=C涨停5, H>=C涨停10);
盘中跌停:=IF(ST, L<=C跌停5, L<=C跌停10);
NOTEXT_跌停: IF(ST, C<=C跌停5, C<=C跌停10),COLORLIGRAY,NODRAW;
NOTEXT_涨停: IF(ST, C>=C涨停5, C>=C涨停10),COLORLIGRAY,NODRAW;

{------------ 大阴大阳 ------------}
NOTEXT_大阳线:C>O AND (C>=C涨停5 OR C>(1.05*O-51/CS) ) OR (C>1000 AND C>RC1*1.024),COLORLIGRAY,NODRAW;
NOTEXT_大阴线:C1000 AND C<rc1*0.976),colorligray,nodraw;

{------------ 过左峰(含倍量、缩量、零号) ------------}

TY1:=C;
HD1:=FILTER(BACKSET(FILTER(REF(TY1,10)=HHV(TY1,2*10+1),10),10+1),10);
LD1:=FILTER(BACKSET(FILTER(REF(TY1,10)=LLV(TY1,2*10+1),10),10+1),10);
A5:=REF(C,BARSLAST(HD1));
T9:=BARSLAST(HD1)<barslast(ld1) and="" not(hd1)="" ;
波浪顶:=IF(T9,A5,A5);
过左峰:CROSS(C,波浪顶),COLORLIGRAY,NODRAW;
STICKLINE(过左峰,2,2.5,2,0),COLORLIGRAY;


{------------ 倍量伸缩 ------------}

A8A1:=VOL/REF(VOL,1)>1.9 AND C/REF(C,1)>1.03;
B8A1:=VOL/REF(VOL,1)<0.6 AND REF(C,1)>REF(C,2) AND C/REF(C,1)>0.99 AND C/REF(C,1)<1.01;
ZF9A:=(C-REF(C,1))/REF(C,1)*100;
NOST9A:=EXIST(ZF9A>5.2,100) OR EXIST(ZF9A<-5.2,100);
K109A:=SLOPE(CLOSE,10)>0.02;
倍量伸缩:COUNT(A8A1,5) AND COUNT(B8A1,5) AND NOST9A AND K109A AND C>REF(C,1),COLORLIGRAY,NODRAW;
STICKLINE(倍量伸缩,3,3.5,2,0),COLORLIGRAY;

{------------ 长阴短柱 ------------}

长阴短柱:C/REF(C,1)<=0.96 AND V<hhv(v,30) 1.9,colorligray,nodraw;
STICKLINE(长阴短柱,4,4.5,2,0),COLORLIGRAY;

{------------ 双剑 ------------}

长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
长腿A:= (MIN(O,C)-L)/(H-L)>0.3 AND (MIN(O,C)-L)/C>=0.03;
双剑:=REF(长上影,1) AND 长腿A AND REF(MIN(C,O),1)>=MAX(C,O),COLORLIGRAY,NODRAW;
双剑霸:REF(双剑,1) AND C>REF(C,1),COLORLIGRAY,NODRAW;
STICKLINE(双剑霸,5,5.5,2,0),COLORLIGRAY;

{------------ 假阳真阴 ------------};

均价:=AMOUNT/VOL/100;
假阳真阴:=C>O AND REF(C,1)>均价 AND C>均价,NODRAW;


{------------ 假阴真阳 ------------};
假阴真阳:O>C AND C<均价 AND 均价>REF(C,1),COLORLIGRAY,NODRAW;
STICKLINE(假阴真阳,6,6.5,2,0),COLORLIGRAY;


{------------ 极阴次阳 ------------};

ZF:=(C-REF(C,1))/REF(C,1)*100;
极阴:=ZF<= -3;
次阳:=C > O AND C > REF((O+C)/2,1);
极阴次阳:极阴 AND 次阳,COLORLIGRAY,NODRAW;
STICKLINE(极阴次阳,7,7.5,2,0),COLORLIGRAY;

{------------ 三元连动 ------------};

ZTB1:=EVERY(C>REF(C,1) ,3);
ZTB2:=EVERY(O>REF(C,1),2);
三连元:ZTB1 AND ZTB2,COLORLIGRAY,NODRAW;
STICKLINE(三连元,8,8.5,2,0),COLORLIGRAY;

{------------ 悬阴31 ------------}
{------------ T4变异 ------------}

T3:=V>REF(V,1) AND REF(V,1)>REF(V,2) AND C=HHV(C,3);
T4变异:REF(T3,1) AND C>REF(C,1),COLORLIGRAY,NODRAW;
STICKLINE(T4变异,9,9.5,2,0),COLORLIGRAY;

{------------ 现场直憋 ------------}

DD1:=REF(C,10)/REF(C,9)>=1.05 AND REF(C,9)<ref(o,9);
DD2:=REF(C,10)/REF(C,8)>=1.05 AND REF(C,9)REF(C,8);
DD:=DD1 OR DD2;
ZB1:=HHV(H,8)/REF(H,9)<1.04 AND LLV(L,8)/REF(L,9)>0.96;
ZB2:=HHV(H,8)/REF(H,9)<1.04 AND LLV(L,7)/REF(L,8)>0.96;
ZB:=ZB1 OR ZB2;
现场直憋:DD AND ZB,COLORLIGRAY,NODRAW;
STICKLINE(现场直憋,10,10.5,2,0),COLORLIGRAY;

{------------ 牛股三绝 ------------}

HH:=HHV(VOL,10);
T:=BARSLAST(HH=VOL)=1;
跳空:=HIGH<(REF(LOW,1)-0.001) || LOW>(REF(HIGH,1)+0.001);
倍量不穿:=REF(倍量,1) AND O>=REF(C,1) AND C/REF(C,1)>=1.03,NODRAW;
高量不破:=O>=REF(MAX(O,C),T) AND C>REF(MAX(O,C),T),NODRAW;
跳空不补:=跳空 AND C>O AND C>REF(C,1),NODRAW;
牛股三绝:倍量不穿 OR 高量不破 OR 跳空不补,COLORLIGRAY,NODRAW;

STICKLINE(牛股三绝,11,11.5,2,0),COLORLIGRAY;

{------------------------ 统计 ------------------------}
基因统计:百日地量群+过左峰+倍量伸缩+长阴短柱+双剑+假阴真阳+极阴次阳+三连元+T4变异+现场直憋+牛股三绝,COLORLIGRAY,NODRAW;
位置:=15;
DRAWNUMBER(百日地量群,位置,基因统计),COLORFFFFFF;
DRAWNUMBER(过左峰,位置,基因统计),COLORFFFFFF;
DRAWNUMBER(倍量伸缩,位置,基因统计),COLORFFFFFF;
DRAWNUMBER(长阴短柱,位置,基因统计),COLORFFFFFF;
DRAWNUMBER(双剑,位置,基因统计),COLORFFFFFF;
DRAWNUMBER(假阴真阳,位置,基因统计),COLORFFFFFF;
DRAWNUMBER(极阴次阳,位置,基因统计),COLORFFFFFF;
DRAWNUMBER(三连元,位置,基因统计),COLORFFFFFF;
DRAWNUMBER(T4变异,位置,基因统计),COLORFFFFFF;
DRAWNUMBER(现场直憋,位置,基因统计),COLORFFFFFF;
DRAWNUMBER(牛股三绝,位置,基因统计),COLORFFFFFF;


 
涨停密码 牛股三绝 通达信幅图指标 源码 贴图
打开微信扫一扫,一键复制指标源码,
轻松快捷粘贴至手机通达信APP中。
0

本站提示:股市有风险,入市请慎重,资料由股票下载网整理收集

找不到你要的公式?给我们建议

  1. 股票软件
    股票分析软件
    股票交易软件
    股票行情软件
    指标股票池
    手机炒股软件
    书籍教程
    数据软件
    工具补丁
    大智慧
    通达信
    飞狐
    东方财富通
    操盘手
    指南针
    分析家
    同花顺
    钱龙
    证券之星
    券商股票软件
    特色行情软件
    迷你行情软件
    金融界软件
    美股外盘软件
    大智慧股票池
    通达信股票池
    大智慧L2公式
    通达信公式
    飞狐公式
    同花顺公式
    股票书藉
    视频教程
    金融书籍
    其他书籍
    资讯评测软件
    资金分析软件
    数据接口软件
    江恩波浪软件
    数据下载软件
    软件数据投资
    选股软件
    登录补丁
    其他应用
    股软教程
  2. 股票公式
    通达信公式
    大智慧公式
    飞狐公式
    同花顺公式
    东方财富通公式
    金字塔指标公式
    文华指标公式
    MT4指标
    博易大师指标
    公式教程答疑
  3. 炒股知识
    短线技巧
    软件公式
    炒股视频
    股票入门
    股市实战信息交流
    炒股技巧
    股票基础知识
    技术分析
    炒股一招先
    基本面分析
    股票视频教程
    股票买卖技巧
    k线图分析
    胡立阳教你买股票
    短线炒股技巧
    天狼之眼
    波浪理论技术讲解
    股市赢家杨百万
    股票理论、T0缠论、知识
    经典指标、交易系统
    成交量能、筹码分析
    买卖信号、技术分析
    挖坑、冼盘、吸筹、出货
    均线战法、黄金分割
    经典K线、趋势形态
    牛股黑马、王子理论
    涨停、周线、月线
    止盈、止损、支撑、压力
    案例、波浪、口诀、选股
    分时、盘口、补仓、解套
  4. 技术指标
    DDX
    DDY
    DDZ
    MACD
    KDJ
    CCI
    OBV
    BOLL
    RSI
    VOL
    CR
    WR