股票下载网共有股票软件:7233 个 | 股票公式:32885 个 | 文章:3812 篇 | 总容量:71.075 G | 总下载:7648218 次 | 今日更新:0

等待介入机会 资金走势 通达信主图指标 源码 贴图

简介:根据DDX资金流入和流出,在主图上画出资金进出的矩形,黄色矩形资金流入,青色矩形资金流出,标示了周月的开盘价,表示了每日相对量。参数:M1,资金平均的短周期M2,资金平均的长周期S,是否标注突破30日价格和量的文字N1,价格和量突破的周期P
标签:  来源:www.gpxiazai.com   发布时间:2018-08-02 点击:

根据DDX资金流入和流出,在主图上画出资金进出的矩形,黄色矩形资金流入,青色矩形资金流出,标示了周月的开盘价,表示了每日相对量。
参数:
M1,资金平均的短周期
M2,资金平均的长周期
S,是否标注突破30日价格和量的文字
N1,价格和量突破的周期
P,应对上市日期读错的情况,作废了
源码:
上市日期:(FINANCE(42)+1),COLORLIGRAY,NODRAW;
流通市值:(FINANCE(40)/100000000),NODRAW,COLORRED;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)) ;
卖:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2));
买卖%:=ABS(买/卖);
买M5:=MA(买,M1),NODRAW;
卖M5:=MA(卖,M1),NODRAW;

MAVOL1:=MA(VOL,M1);
MAVOL2:=MA(VOL,M2);
UP:=IF(P>0,CROSS(买M5,-卖M5),CROSS(MAVOL1,MAVOL2)),NODRAW;
DOWN:=IF(P>0,CROSS(-卖M5,买M5),CROSS(MAVOL2,MAVOL1)),NODRAW;
{UP:=CROSS(买M5,-卖M5),NODRAW;
DOWN:=CROSS(-卖M5,买M5),NODRAW;}
UPL:=BARSLAST(UP),NODRAW;
UPE:=BARSNEXT(UP),NODRAW;
DOWNL:=BARSLAST(DOWN),NODRAW;
DOWNE:=BARSNEXT(DOWN),NODRAW;
UO:=REF(O,UPL),NODRAW;
MO:=REFX(C,DOWNE-1),NODRAW;
DC:=REFX(C,UPE-1),NODRAW;
DRAWSL(UP,O,0,DOWNE-1,0),COLORYELLOW;{上升矩形}
DRAWSL(UP,MO,0,DOWNE-1,0),COLORYELLOW;
STICKLINE(UP,O,MO,0,0),COLORYELLOW;
STICKLINE(DOWNE==1,C,UO,0,0),COLORYELLOW;
DRAWSL(DOWN,DC,0,UPE-1,0),COLORGREEN;{下降矩形}
DRAWSL(DOWN,O,0,UPE-1,0),COLORGREEN;
STICKLINE(DOWN,O,DC,0,0),COLORGREEN;
STICKLINE(UPE==1,C,REF(O,DOWNL),0,0),COLORGREEN;
{====================================}
{突破N1=30日量前高}
{N1:=30;}
K1:=REF(C,1)=DYNAINFO(3) AND O=DYNAINFO(4) AND C=DYNAINFO(7) AND H=DYNAINFO(5) AND L=DYNAINFO(6);
K2:=BARSLAST(V=HHV(V,N1));
K3:=BACKSET(K1,K2+1);
DRAWSL(K2=0 AND K3=1,H,0,2,0),COLORWHITE,LINETHICK2;
收:C,NODRAW;
{DRAWTEXT(S=1&&K2=0&&K3=1,H*1.02,'破N1日最高量的最高价'),COLORGREEN;}
DRAWTEXT(S=1&&K2=0&&K3=1,H*0.97,'V'),COLORWHITE,LINETHICK2;

{突破N1=30日价格前高}
TJG:=C==HHV(H,N1) AND REF(C,1)<HHV(H,N1);
K4:=BARSLAST(TJG);
K5:=BACKSET(K1,K4+1);
DRAWSL(K4=0 AND K5=1,C,0,2,0),COLORWHITE,LINETHICK2;
DRAWTEXT(S=1 AND K4=0 AND K5=1,C*0.97,'P'),COLORWHITE;

{标示周月开盘价}
YN:=MOD(YEAR,4)==0 AND MOD(YEAR,100)!=0,NODRAW;
DN:=IF(MONTH==1 OR MONTH==3 OR MONTH==5 OR MONTH==7 OR MONTH==8 OR MONTH==10 OR MONTH==12,31,IF(MONTH==4 OR MONTH==6 OR MONTH==9 OR MONTH==11,30,IF(MONTH==2,IF(YN,29,28),0))),NODRAW;
FD:=IF(DAY<REF(DAY,1),DAY,0),NODRAW;
{LD:=IF(DAY>REF(DAY,1) AND DAY>REFX(DAY,1),DAY,0),NODRAW;}
FW:=IF(WEEKDAY<REF(WEEKDAY,1) AND WEEKDAY!=0,WEEKDAY,0),NODRAW;
{LW:=IF(WEEKDAY>REF(WEEKDAY,1) AND WEEKDAY>REFX(WEEKDAY,1),WEEKDAY,0),NODRAW;}
DRAWSL(DAY==FD OR DAY==1,O,0,10,0),COLORMAGENTA,LINETHICK2;
{DRAWSL(DAY==LD OR DAY==DN,C,0,1,0),COLORRED,LINETHICK3,POINTDOT;}
DRAWSL(WEEKDAY==FW OR WEEKDAY==1,O,0,1,0),COLORWHITE,LINETHICK5,POINTDOT;
{DRAWSL(WEEKDAY==5,C,0,1,0),COLORBLUE,LINETHICK5,POINTDOT;}

{标示相对量}
P:=IF(上市日期>120,上市日期,120),NODRAW;
买卖差:=买+卖,NODRAW;
最大差:=HHV(买卖差,P),NODRAW;
最小差:=LLV(买卖差,P),NODRAW;
相对差:IF(买卖差>0,买卖差/最大差,-买卖差/最小差)*100,NODRAW;
涨幅:=(C-REF(C,1))/REF(C,1)*100,NODRAW;
量价比:=相对差/涨幅,NODRAW;
A:=MA(C,5),NODRAW;
最大量:=HHV(VOL,P),NODRAW;
相对量:VOL/最大量*100,NODRAW;
三日差:SUM(相对差,3),NODRAW;
三日量:SUM(相对量,3),NODRAW;
五日差:SUM(相对差,5),NODRAW;
五日量:SUM(相对量,5),NODRAW;
十日差:SUM(相对差,10),NODRAW;
十日量:SUM(相对量,10),NODRAW;

Y1:=L*0.99,NODRAW;
Y2:=H*1.04,NODRAW;
B:=INTPART(ABS(相对量/10)),NODRAW;
S:=IF(B==10,0,B),NODRAW;
DRAWNUMBER(涨幅>0 AND 量价比>0 AND B!=0,Y1,S),COLORRED;
DRAWNUMBER(涨幅<0 AND 量价比>0 AND B!=0,Y2,S),COLORCYAN;
DRAWNUMBER(量价比<0 AND C>A AND B!=0,Y1,S),COLORGREEN;
DRAWNUMBER(量价比<0 AND C<A AND B!=0,Y1,S),COLORYELLOW;

Y3:=L*0.95,NODRAW;
Y4:=H*1.07,NODRAW;
B1:=INTPART(ABS(相对差/10)),NODRAW;
S1:=IF(B1==10,0,B1),NODRAW;
DRAWNUMBER(涨幅>0 AND 量价比>0 AND B1!=0,Y3,S1),COLORLIRED;
DRAWNUMBER(涨幅<0 AND 量价比>0 AND B1!=0,Y4,S1),COLORLICYAN;
DRAWNUMBER(量价比<0 AND C>A AND B1!=0,Y3,S1),COLORLIGREEN;
DRAWNUMBER(量价比<0 AND C<A AND B1!=0,Y3,S1),COLORYELLOW;

资金走势 通达信主图指标 源码 贴图

点击下载资金走势 通达信主图指标 源码 贴图

  • 股票公式精品推荐
  • 03-02精品指标喜欢的下 波段抓妖 通达信主图
  • 03-02金钻指标 特殊MACD源码 通达信副图指标
  • 03-02精品实战指标 精准短线出击 通达信副图
  • 03-02精准指标 精准提前必涨停3 通达信副图+
  • 03-02希望大家能抓到大牛 寻牛 通达信副图/选
  • 03-02修改后通达信版本《通达信三角洲预测》
  • 03-02指标可叠加于任何主图 限售股解禁公式
  • 03-02捕捉到的黑马很多 铁血教官之小样还藏+
  • 03-02获取短线暴利 绝对原创——极速反转短线
  • 03-02逢低买入 等待拉升 强庄主图标识代码 通
  • 03-02在网上找到的指标 一战成名 通达信主图
  • 03-01金钻指标原创不喜勿下 又见金底 通达信
  • 03-01让你坐上头等舱 K线发射成功 通达信主图
  • 03-01及时坐上头等仓 K线发射成功 通达信选股
  • 03-01这个指标需要较高的操作技术 配套指标,
  • 03-01实战指标 【高抛低吸T+0】 精准背离 通
  • 03-01今天借花献佛 公开这个公式源码 爆涨公
  • 02-28狗年旺旺旺 暴力杀庄 通达信副图指标 源
  • 02-28股市没烦恼!量价指标 通达信副图指标
  • 02-28精准提前抄底指标 成交量提前预警抓涨停
  • 02-28指标挺好的 吊打止损优化公式 通达信主
  • 02-28获取短线暴利 原创——急速反转买 通达
  • 02-28恭喜、恭喜、赢钱笑微微 跟你,明日就有
  • 02-28祝投资顺利 跟你,明日就有起!通达信选
  • 02-28二个选股公式源码 超级大黑马选股公式
  • 02-28用了你才知道好 一线游资建仓指标公式
  • 02-27真正的高手都是买在阴线 卖在阳线 阴线
  • 02-27金钻指标 【牛、妖股`主升浪利器】薛斯
  • 02-27以投资的角度出发 黄蓝带主图 大局掌控
  • 02-27具体交易要结合大盘和个股情况来看 一个
  • 学了还要学
    股票公式火热下载榜
    看了还想看