»查看更多分类股票软件

通达信加油翻红副图公式 选股公式

发布时间:2015-11-07 23:24:00  点击:

通达信加油翻红副图公式

源码如下:

DIF:EMA(CLOSE,6)-EMA(CLOSE,19),,NODRAW;
 DEA:EMA(DIF,9),NODRAW;
 MACD:2*(DIF-DEA),COLORSTICK;
 STICKLINE(MACD>0,MACD,0,0.5,0),COLORRED;
 STICKLINE(MACD<0,MACD,0,0.5,0),COLORGREEN;
 STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.5,0),COLORWHITE;
 STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.5,0),COLORFF00FF;
 FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
 FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
 FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
 FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;
 FH5:=FH1 AND FH2 AND MACD<0.10;
 VV:=CLOSE>OPEN AND MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,30)
 AND DIF>DEA AND MACD>REF(MACD,1) AND DIF>0 AND DEA>0 AND
 MA(VOL,5)>MA(VOL,34) AND MA(CLOSE,30)>=REF(MA(CLOSE,30),1);
佛手:IF(VV,1,0),NODRAW;

 {二次起动}
X0:=BARSLAST((CROSS(MACD,REF(MACD,1)) AND MACD>0) OR CROSS(MACD,0));
 X1:=BARSLAST(CROSS(0.5,COUNT(MACD>REF(MACD,1),X0+1)=X0+1));{回}
X2:=COUNT(MACD<REF(MACD,1),X1+1)=X1+1 AND COUNT(MACD<0,X1+1)<=2;
 X3:=REF(X2,1) AND MACD>REF(MACD,1) AND C>O AND C>REF(C,1);
 STICKLINE(X1=0 AND MACD>0,MACD,0,2,0),COLORDCDC00;{MACD缩头}
STICKLINE(X3,MACD,0,2,0),COLOR0854FF;{二次起动};
DRAWICON(佛手,-0.15,11);
二次翻红:(FH3 OR FH4 OR FH5),COLORRED,NODRAW;
低买:CROSS(DIF,DEA) AND DIF<0,COLORFF00FF,NODRAW;
加油:CROSS(DIF,DEA) AND DIF>0,COLORYELLOW,NODRAW;
 DRAWICON(二次翻红,-0.05,1);
 DRAWTEXT(二次翻红,-0.15,"↖翻红"),COLORRED;
 DRAWTEXT(CROSS(DIF,DEA) AND DIF<0,DEA-0.02,"↖低买"),COLORFF00FF;
 DRAWTEXT(CROSS(DIF,DEA) AND DIF>0,DEA-0.05,"↖加油"),COLORYELLOW;
 XG:二次翻红 OR 低买 OR 加油,NODRAW;
 YLZC:=IF(CLOSE=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(VOL+0.01)/100);
阻价:=IF(CLOSE=INDEXC,YLZC+INDEXC-INDEXL,YLZC+(CLOSE-LOW));
支价:=IF(CLOSE=INDEXC,INDEXL+INDEXC-YLZC,LOW+(CLOSE-YLZC));
今压:REF(阻价,1),LINETHICK0,COLORAA11BB,NODRAW;
今撑:REF(支价,1),LINETHICK0,COLOR009900,NODRAW;
明压:阻价,LINETHICK0,NODRAW;
明撑:支价,LINETHICK0,NODRAW;
 DIFF:DIF,COLORRED,LINETHICK2;
 DDEA:DEA,COLORYELLOW,LINETHICK2;
 

加油翻红选股:


DIF:=EMA(CLOSE,6)-EMA(CLOSE,19);
 DEA:=EMA(DIF,9);
 MACD:=2*(DIF-DEA);
 FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
 FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
 FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
 FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;
 FH5:=FH1 AND FH2 AND MACD<0.10;
 VV:=CLOSE>OPEN AND MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,30)
 AND DIF>DEA AND MACD>REF(MACD,1) AND DIF>0 AND DEA>0 AND
 MA(VOL,5)>MA(VOL,34) AND MA(CLOSE,30)>=REF(MA(CLOSE,30),1);
 X0:=BARSLAST((CROSS(MACD,REF(MACD,1)) AND MACD>0) OR CROSS(MACD,0));
 X1:=BARSLAST(CROSS(0.5,COUNT(MACD>REF(MACD,1),X0+1)=X0+1));{回}
X2:=COUNT(MACD<REF(MACD,1),X1+1)=X1+1 AND COUNT(MACD<0,X1+1)<=2;
 X3:=REF(X2,1) AND MACD>REF(MACD,1) AND C>O AND C>REF(C,1);
二次翻红:=(FH3 OR FH4 OR FH5);
加油:=CROSS(DIF,DEA) AND DIF>0;
 XG1:= DRAWTEXT(二次翻红,-0.15,"↖翻红"),COLORRED;
 XG2:= DRAWTEXT(CROSS(DIF,DEA) AND DIF>0,DEA-0.05,"↖加油");
XG:XG1 AND XG2;

 

0

本站提示:股市有风险,入市请慎重,资料由股票下载网整理收集

下载必看(为了保障您的权益,请在下载资源前看清楚相关说明)

  • ›› 指标不属于投资资讯产品和推股软件,指标旨在辅助大家提高投资胜率参考而研发,仅供参考学习研究之用,不构成投资建议或未来保证,依此操作买卖,盈亏自负。
  • ›› 指标页面宣传的收益仅代表指标信号成立后的历史收益,收益具有不确定性,不保证未来达到同等收益。
  • ›› 您所下载的软件由股票下载网网络收集发布,不保证提供的下载资源的准确性、安全性和完整性。请自行谨慎甄别软件相关描述后再下载,股票下载网不保障和承担使用该软件投资带来的一切损失。
  • ›› 该软件仅供学习和研究使用,不得用于商业或者非法用途。本站对于提供下载的指标、软件、资讯等不拥有任何权利,其版权归该下载资源的合法拥有者所有,如有侵犯您的版权,请查看《股票下载网的侵权处理流程》,本站将于五个工作日内移除相关内容,同时要求用户在23小时内删除从本站下载的文件。
  • ›› 如果您发现下载链接错误,请点击报告错误谢谢!

找不到你要的公式?给我们建议