股票下载网 股票软件7324 个 ┆ 股票公式33803 个 ┆ 炒股知识3863
首 页炒股知识股票软件股票公式技术指标设为首页  加入收藏  放到桌面本站分类
当前位置:股票下载网股票公式通达信公式
日期:2015-04-09 22:47:00  来源:本站整理

通达信十个指标整合主图指标(源码)

E13:EXPMA(C,13),COLORGREEN;
M8:MA(C,8);
M21:MA(C,21);
M233:MA(C,233);
E10:EXPMA(C,10),COLORRED;
ZZT:=C/REF(C,1)>1.095 AND C=H;
ZA:=BARSLASTCOUNT(ZZT);
ZT:=BARSLAST(CROSS(ZA=3,0.5));
ZLL:=REF(L,(ZT+2));
ZTJ:=C<ZLL;
ZAA:=COUNT(ZTJ,ZT+1)=1 AND ZTJ;
ZTA:=BARSLAST(ZAA);
ZLT:=BARSLAST(L=LLV(L,ZTA+1));
ZTJ1:=CROSS(C,E10);
ZXG:=COUNT(ZTJ1,ZLT+1)=1 AND ZTJ1 AND TOTALBARSCOUNT>200;
STICKLINE(ZXG,C,O,2,0),COLORYELLOW;
DRAWTEXT(ZXG,L*0.95,"起轿"),COLORYELLOW;
HA:=M8/M21*100;
HTJ:=BARSLASTCOUNT(RANGE(HA,99.9,100.3));
HHB:=MAX(C,O)/MIN(C,O)*100-100;
HTJ1:=BARSLASTCOUNT(HHB<2);
HZF:=(HHV(H,5)-LLV(L,5))/LLV(L,5)*100;
HDZF:=(H-L)/REF(C,1)*100;
HTJ2:=COUNT(MIN(C,O)/L>1.03,5)=0;
HTJ3:=COUNT(H<REF(L,1),5)=0;
HTJ4:=C>M233;
HXG:=HTJ>4 AND HTJ1>4 AND HZF<10 AND HTJ2 AND HTJ3 AND HTJ4;
STICKLINE(CROSS(HXG,0.5),C,O,2,0),COLORLIMAGENTA;
STICKLINE(CROSS(HXG,0.5),H,L,2,0),COLORLIMAGENTA;
DRAWTEXT(CROSS(HXG,0.5),L*0.95,"绽放"),COLORYELLOW;
ZF:=(C-REF(C,1))/REF(C,1)*100;
TJ:=EVERY(RANGE(ZF,-2.22,2.55),15);
TJ1:=C>O AND C/REF(C,1)>1.03;
TJ2:=COUNT(E13>=REF(E13,1),15);
JD:=(ATAN((E13/REF(E13,15)-1)*100)*180/3.1415926);
A:=IF(MIN(C,O)>E13,MAX(C,O)/E13*100-100,IF(MAX(C,O)<E13,E13/MIN(C,O),E13));
B:=MAX(C,O)/MIN(C,O)*100-100;
LL:=LLV(A,15);
HH:=HHV(A,15);
HB:=COUNT(BB>3,15)<2;
XG:=REF(TJ,1) AND TJ1 AND TJ2>13 AND JD>72 AND REF(LL,1)<1.37 AND REF(HH,1)<11.15;
STICKLINE(XG,C,O,2,0),COLORGREEN;
DRAWTEXT(XG,L*0.95,"上树"),COLORYELLOW;
WT:=BARSLAST(WEEKOFYEAR!=REF(WEEKOFYEAR,1));
C1:=REF(C,WT+1);
C2:=REF(C1,WT+1);
C3:=REF(C2,WT+1);
C4:=REF(C3,WT+1);
C5:=REF(C4,WT+1);
C6:=REF(C5,WT+1);
C7:=REF(C6,WT+1);
C8:=REF(C7,WT+1);
C9:=REF(C8,WT+1);
WM10:=(C+C1+C2+C3+C4+C5+C6+C7+C8+C9)/10;
E20:=EXPMA(C,20);
E120:=EXPMA(C,120);
E250:=EXPMA(C,250);
WA:=MACD.DIF;
WB:=MACD.DEA;
WT1:=BARSLAST(CROSS(WA,WB));
WST:=BARSLAST(CROSS(WB,WA));
WZF:=(HHV(H,110)-LLV(L,110))/LLV(L,110)*100;
WTJ:=EVERY(V>REF(V,1),2);
WHH:=MAX(MAX(E20,E120),E250);
WLL:=MIN(MIN(E20,E120),E250);
WNH:=WHH/WLL*100-100;
WTJ1:=EVERY(WNH<40,25);
WZZF:=(C-REF(C,10))/REF(C,10)*100 ;
WTJA:=C>WM10;
WXG:=WT1=0 AND WA<REF(WA,WST) AND WB<REF(WB,WST) AND WZF<70 AND WTJ AND WTJ1 AND WZZF<1.4 AND WTJA;
STICKLINE(WXG,C,O,2,0),COLORYELLOW;
STICKLINE(WXG,H,L,0,0),COLORYELLOW;
DRAWTEXT(WXG,H*1.02,"周线走好"),COLORYELLOW;
M5:=MA(C,5);
M10:=MA(C,10);
M15:=MA(C,15);
FTJ:=M5>REF(M5,1) AND M10>REF(M10,1) AND M15>=REF(M15,10);
FT:=BARSLAST(CROSS(FTJ,0.5));
FTT:=BARSLAST(WEEKOFYEAR!=REF(WEEKOFYEAR,1));
FHH:=MAX(MAX(M5,M10),M15);
FLL:=MIN(MIN(M5,M10),M15);
FNH:=FHH/FLL*100-100;
FZZF:=(C-REF(C,FTT+1))/REF(C,FTT+1)*100;
FZZF1:=REF(FZZF,FTT+1);
FTJ2:=CROSS(FZZF>20,0.5) OR CROSS(FZZF1>20,0.5);
FJD:=(ATAN((M5/REF(M5,1)-1)*100)*180/3.1415926);
FTJA:=FZZF1>0 AND FZZF1>0 ;
FDT:=M10/M15*100-100>1 AND H/MAX(C,O)<1.03;
FBL:=MIN(C,O)/M5;
FBL5:=M5/M10*100-100;
FXG:=FTJ2 AND C=HHV(C,5) AND BETWEEN(FT,0,5)AND FTJA AND FNH<12 AND FDT AND FBL<1.045 AND FBL5<7.2 AND FJD<77.5;
STICKLINE(CROSS(FXG,0.5),C,O,1.8,0),COLORMAGENTA;
STICKLINE(CROSS(FXG,0.5),H,L,0,0),COLORMAGENTA;
DRAWTEXT(CROSS(FXG,0.5),L*0.98,"周线翻红"),COLORYELLOW;
DTJ:=O>REF(H,1) AND C<O AND O/C<C/L AND V>REF(V,1);
DTT:=BARSLAST(REF(ZA>1,1) AND DTJ);
DXG:=COUNT(CROSS(C,REF(H,DTT)),DTT+1)=1 AND CROSS(C,REF(H,DTT));
STICKLINE(DTT>=0,REF(H,DTT),REF(H,DTT),6,0),COLORRED;
DRAWTEXT(DTT=0,REF(H,DTT)*1.02,"清茶"),COLORYELLOW;
DRAWICON(DXG,L*0.95,7);
QT:=BARSLAST(C>REF(C,1)*1.095 AND C=H);
QTJ:=(C-REF(C,QT+1))/REF(C,QT+1)*100;
QTJ1:=EVERY(C<O,QT);
QTJ2:=COUNT(REF(C,1)/C>1.09,QT)>0 AND REF(C,1)/C>1.09;
QA:=QTJ>-1 AND QTJ1 AND QTJ2;
QTA:=BARSLAST(QA);
QHH:=REF(H,QTA);
QTJ3:=EVERY(MAX(C,O)<QHH,QTA);
QTJ4:=MIN(C,O)<QHH AND MAX(C,O)>QHH AND COUNT(MIN(C,O)<QHH AND MAX(C,O)>QHH,QTA)=1;
QTJ5:=REF(QTJ3,1) AND QTA<69 AND IF(C<O,O/QHH>1.007,C>O) AND IF(C<O,REF(C,1)/C<1.06,C>O);
QXG:=QTJ4 AND QTJ5;
STICKLINE(QTA>=0,REF(H,QTA),REF(H,QTA),6,0),COLORBLUE;
DRAWICON(QXG=1,L*0.95,1);
DRAWTEXT(QTA=0,H*1.02,STRCAT(STRCAT("阴线最高价:",VAR2STR(REF(H,QTA),2)),"元"))COLORYELLOW;
DIF:=MACD.DIF;
H300:=HHVBARS(DIF,300);
IA:=BOLL.UB;
IT:=BARSLAST(CROSS(IA>=REF(IA,1),0.5));
E25:=EXPMA(C,25);
IZF:=EVERY(RANGE(C/REF(C,1),0.97,1.05),IT+1);
IZFF:=(HHV(H,IT+1)-LLV(L,IT+1))/LLV(L,IT+1)*100;
ITJ:=EVERY(MAX(C,O)/IA<1.02 ,IT+1);
IXL:=(ATAN((E25/REF(E25,IT)-1)*100)*180/3.1415926);

[1] [2]  下一页

通达信十个指标整合主图指标(源码)
打开微信扫一扫,一键复制指标源码,
轻松快捷粘贴至手机通达信APP中。

Tags:

作者:佚名

公式评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论
Copyright © 2009-2019 GPxiazai.com. All Rights Reserved .
备案号: 苏ICP备12020055号-2 苏公网安备 32058302001104号
声明:本站所有信息免费,广告收费行为均与本站无关. 侵权请联系QQ929946094进行处理.
若本站收录的软件无意侵犯了贵司版权,请联系QQ929946094进行处理,谢谢!