»查看更多分类股票软件

红心黑板(三)(顶底背离 大智慧源码)

发布时间:2010-06-21 10:40:00  点击:

关于顶底的背离是我一直比较关注的一种公式表达方法。也是我从一开始学习编辑公式时就想做出的一个看盘小工具。奈何,一拖再拖,今天将此公式再以小黑板的形式发表出来,是为红心黑板(三)。至此,算为小黑板系列画上了一个句号……
关于“背离”,很多人的认识不一样:
1,我曾分解学习过论坛的一些精品公式,如思绪飘零老师的“飘零盯庄”,和估界文老师的“中间两头”,所给出的“背离”信号是:“公式两条线交叉时,公式的趋势线和股价收盘价发生了背离”,即,先以公式为基点,找股价的背离。
2,也有一种是基于股价,指标线发生背离的。如王小松班长在炒股一招鲜里讲到的“CCI背离抄底”。原话是这样的“股价经过长期的下跌,一路不断创出新低,然而对应的CCI指标却拒绝继续下跌,反而不断上升,出现股价和CCI指标的背离。”同时,再将松班的图引用一张:



input:n(60);
K值:="KDJ.K";
dd:=C=LLV(C,N);{60日最低点}
ddsj:=BARSLAST(REF(dd,1));{上一低点时间}
ddgj:=REF(CLOSE,ddsj+1)>CLOSE;{股价趋势}
Kdzb:=REF(K值,ddsj+1)<K值;{KDJ.K指标趋势}
K底背离:=ddgj and Kdzb;
gd:=c=hhv(c,N);{60日最高点}
gdsj:=BARSLAST(REF(gd,1));{上一高点时间}
gdgj:=REF(CLOSE,gdsj+1)<CLOSE;{股价趋势}
Kgzb:=REF(K值,gdsj+1)>K值;
K顶背离:=gdgj and Kgzb;
MACD:="macd.macd";
Mdzb:=REF(MACD,ddsj+1)<MACD;{MACD指标趋势}
M底背离:=ddgj and Mdzb;
Mgzb:=REF(MACD,gdsj+1)>MACD;
M顶背离:=gdgj and mgzb;
RSI:="RSI.RSI1";
Rdzb:=REF(RSI,ddsj+1)<RSI;{RSI指标趋势}
R底背离:=ddgj and Rdzb;
Rgzb:=REF(RSI,gdsj+1)>RSI;
R顶背离:=gdgj and Rgzb;
TYP:=(HIGH + LOW + CLOSE)/3;
cci:=(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
cdzb:=REF(cci,ddsj+1)<cci;{cci指标趋势}
C底背离:=ddgj and cdzb;
cgzb:=REF(cci,gdsj+1)>cci;
C顶背离:=gdgj and cgzb;
REFLINE: 0,15,30;
drawtextrel(5,10,'KDJ顶背离'),linethick2,colorred;
drawtext(K顶背离,29.8,'(×)'),linethick2,colorred,ALIGN1;
drawtextrel(5,140,'MACD顶背离'),linethick2,colormagenta;
drawtext(M顶背离,26,'(×)'),linethick2,colormagenta,ALIGN1;
drawtextrel(5,270,'RSI顶背离'),linethick2,colorblue;
drawtext(R顶背离,22.1,'(×)'),linethick2,colorblue,ALIGN1;
drawtextrel(5,400,'CCI顶背离'),linethick2,colorgreen;
drawtext(C顶背离,18.1,'(×)'),linethick2,colorgreen,ALIGN1;
drawtextrel(5,530,'CCI底背离'),linethick2,colorgreen;
drawtext(C底背离,14.2,'(√)'),linethick2,colorgreen,ALIGN1;
drawtextrel(5,660,'RSI底背离'),linethick2,colorblue;
drawtext(R底背离,10,'(√)'),linethick2,colorblue,ALIGN1;
drawtextrel(5,790,'MACD底背离'),linethick2,colormagenta;
drawtext(M底背离,6,'(√)'),linethick2,colormagenta,ALIGN1;
drawtextrel(5,910,'KDJ底背离'),linethick2,colorred;
drawtext(K底背离,3,'(√)'),linethick2,colorred,ALIGN1;

0
本站提示:股市有风险,入市请慎重,资料由股票下载网整理收集

找不到你要的文章?给我们建议

  1. 股票软件
    股票分析软件
    股票交易软件
    股票行情软件
    指标股票池
    手机炒股软件
    书籍教程
    数据软件
    工具补丁
    大智慧
    通达信
    飞狐
    东方财富通
    操盘手
    指南针
    分析家
    同花顺
    钱龙
    证券之星
    券商股票软件
    特色行情软件
    迷你行情软件
    金融界软件
    美股外盘软件
    大智慧股票池
    通达信股票池
    大智慧L2公式
    通达信公式
    飞狐公式
    同花顺公式
    股票书藉
    视频教程
    金融书籍
    其他书籍
    资讯评测软件
    资金分析软件
    数据接口软件
    江恩波浪软件
    数据下载软件
    软件数据投资
    选股软件
    登录补丁
    其他应用
    股软教程
  2. 股票公式
    通达信公式
    大智慧公式
    飞狐公式
    同花顺公式
    东方财富通公式
    金字塔指标公式
    文华指标公式
    MT4指标
    博易大师指标
    公式教程答疑
  3. 炒股知识
    短线技巧
    软件公式
    炒股视频
    股票入门
    股市实战信息交流
    炒股技巧
    股票基础知识
    技术分析
    炒股一招先
    基本面分析
    股票视频教程
    股票买卖技巧
    k线图分析
    胡立阳教你买股票
    短线炒股技巧
    天狼之眼
    波浪理论技术讲解
    股市赢家杨百万
    股票理论、T0缠论、知识
    经典指标、交易系统
    成交量能、筹码分析
    买卖信号、技术分析
    挖坑、冼盘、吸筹、出货
    均线战法、黄金分割
    经典K线、趋势形态
    牛股黑马、王子理论
    涨停、周线、月线
    止盈、止损、支撑、压力
    案例、波浪、口诀、选股
    分时、盘口、补仓、解套
  4. 技术指标
    DDX
    DDY
    DDZ
    MACD
    KDJ
    CCI
    OBV
    BOLL
    RSI
    VOL
    CR
    WR