股票下载网 股票软件7268 个 ┆ 股票公式33565 个 ┆ 炒股知识3863
首 页炒股知识股票软件股票公式技术指标设为首页  加入收藏  放到桌面本站分类
当前位置:股票下载网炒股知识软件公式
日期:2010-05-19 08:49:00  来源:本站整理

个股与大盘强弱对比指标-(简单明确 通达信源码)

大家在很多时候都是用图形叠加的办法对个股与大盘的走势进行对比,但这样一般图形会发生错位,对比效果一般不怎么好,前段时间正好应一网友要求,写个大盘副图指标,就是在副图里画出大盘的K线,在此基础上加上了一段时间内的统计数据。时间参数N可随意设定。

{大盘强弱}
最高指数:INDEXH,LINETHICK0;
最低指数:INDEXL,LINETHICK0;
开盘指数:INDEXO,LINETHICK0;
收盘指数:INDEXC,LINETHICK0;
大盘涨幅:(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100,LINETHICK0;

个股涨幅:=(C-REF(C,1))/REF(C,1)*100;
i:=COUNT(大盘涨幅<个股涨幅 ,N);
大盘:=(INDEXC-REF(INDEXC,N))/REF(INDEXC,N)*100;
个股:=(C-REF(C,N))/REF(C,N)*100;

IF DISPSTATUS=2 and 大盘<个股 THEN DRAWTEXTREL(10,570,'最近'+NUMTOSTRN(N,0)+'个交易日与大盘对比:涨幅强于大盘'),COLOR00EEff;
IF DISPSTATUS=2 and 大盘>个股 THEN DRAWTEXTREL(10,570,'最近'+NUMTOSTRN(N,0)+'个交易日与大盘对比:涨幅弱于大盘'),COLOR00EEff;
IF DISPSTATUS=2 THEN DRAWTEXTREL(10,650,'大盘累计涨跌幅:'+NUMTOSTRN(大盘,3)),COLOR00EEff;
IF DISPSTATUS=2 THEN DRAWTEXTREL(10,730,'个股累计涨跌幅:'+NUMTOSTRN(个股,3)),COLOR00EEff;
IF DISPSTATUS=2 THEN DRAWTEXTREL(10,810,'强于大盘:'+NUMTOSTRN(i,0)+'天'),COLOR00EEff;
IF DISPSTATUS=2 THEN DRAWTEXTREL(10,890,'弱于大盘:'+NUMTOSTRN((N-i),0)+'天'),COLOR00EEff;

STICKLINE(INDEXA>0 and INDEXO<INDEXC,INDEXO,INDEXC,6,0),COLORRED;
STICKLINE(INDEXA>0 and INDEXO>INDEXC,INDEXC,INDEXO,6,0),COLORGREEN;
STICKLINE(INDEXA>0 and INDEXO<INDEXC,INDEXH,INDEXL,1,0),COLORRED;
STICKLINE(INDEXA>0 and INDEXO>INDEXC,INDEXH,INDEXL,1,0),COLORGREEN;

Tags:

作者:佚名

文章评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论
Copyright © 2009-2019 GPxiazai.com. All Rights Reserved .
备案号: 苏ICP备12020055号-2 苏公网安备 32058302001104号
声明:本站所有信息免费,广告收费行为均与本站无关. 侵权请联系QQ929946094进行处理.
若本站收录的软件无意侵犯了贵司版权,请联系QQ929946094进行处理,谢谢!