股票下载网共有股票软件:7218 个 | 股票公式:32392 个 | 文章:3812 篇 | 总容量:71.001 G | 总下载:7367874 次 | 今日更新:13

个股与大盘强弱对比指标-(简单明确 通达信源码)

简介:大家在很多时候都是用图形叠加的办法对个股与大盘的走势进行对比,但这样一般图形会发生错位,对比效果一般不怎么好,前段时间正好应一网友要求,写个大盘副图指标,就是在副图里画出大盘的K线,在此基础上加上了一段时间内的统计数据。时间参数N可随意设定
标签:个股与大盘强弱对比指标-(简单明确 通达信源码)  来源:www.gpxiazai.com   发布时间:2010-05-19 点击:

大家在很多时候都是用图形叠加的办法对个股与大盘的走势进行对比,但这样一般图形会发生错位,对比效果一般不怎么好,前段时间正好应一网友要求,写个大盘副图指标,就是在副图里画出大盘的K线,在此基础上加上了一段时间内的统计数据。时间参数N可随意设定。

{大盘强弱}
最高指数:INDEXH,LINETHICK0;
最低指数:INDEXL,LINETHICK0;
开盘指数:INDEXO,LINETHICK0;
收盘指数:INDEXC,LINETHICK0;
大盘涨幅:(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100,LINETHICK0;

个股涨幅:=(C-REF(C,1))/REF(C,1)*100;
i:=COUNT(大盘涨幅<个股涨幅 ,N);
大盘:=(INDEXC-REF(INDEXC,N))/REF(INDEXC,N)*100;
个股:=(C-REF(C,N))/REF(C,N)*100;

IF DISPSTATUS=2 and 大盘<个股 THEN DRAWTEXTREL(10,570,'最近'+NUMTOSTRN(N,0)+'个交易日与大盘对比:涨幅强于大盘'),COLOR00EEff;
IF DISPSTATUS=2 and 大盘>个股 THEN DRAWTEXTREL(10,570,'最近'+NUMTOSTRN(N,0)+'个交易日与大盘对比:涨幅弱于大盘'),COLOR00EEff;
IF DISPSTATUS=2 THEN DRAWTEXTREL(10,650,'大盘累计涨跌幅:'+NUMTOSTRN(大盘,3)),COLOR00EEff;
IF DISPSTATUS=2 THEN DRAWTEXTREL(10,730,'个股累计涨跌幅:'+NUMTOSTRN(个股,3)),COLOR00EEff;
IF DISPSTATUS=2 THEN DRAWTEXTREL(10,810,'强于大盘:'+NUMTOSTRN(i,0)+'天'),COLOR00EEff;
IF DISPSTATUS=2 THEN DRAWTEXTREL(10,890,'弱于大盘:'+NUMTOSTRN((N-i),0)+'天'),COLOR00EEff;

STICKLINE(INDEXA>0 and INDEXO<INDEXC,INDEXO,INDEXC,6,0),COLORRED;
STICKLINE(INDEXA>0 and INDEXO>INDEXC,INDEXC,INDEXO,6,0),COLORGREEN;
STICKLINE(INDEXA>0 and INDEXO<INDEXC,INDEXH,INDEXL,1,0),COLORRED;
STICKLINE(INDEXA>0 and INDEXO>INDEXC,INDEXH,INDEXL,1,0),COLORGREEN;

  • 炒股知识精品推荐
  • 08-29一位操盘手珍藏10年的MACD高级用法
  • 08-27主升浪操盘的模式:回抽打到筹码密集峰
  • 10-23熊市生存秘籍:如何面对新股超发下的估
  • 10-23下跌已尾声——一个波浪理论的技术推演
  • 10-23熊市有四个典型阶段,现处第三阶段末期
  • 09-25【K线】史上最经典的股票口诀!背起来,
  • 09-25自主芯片和新能源车将是近期的王者
  • 09-25学会量比选股技巧 随便抓一只就能轻松涨
  • 09-25【每日学堂】站在顶尖的游资来看待交易
  • 09-25【K线】一个炒股二十年的老股民的心得分
  • 09-04小散如何在股市赚钱不亏损?获利至今!
  • 09-04教你如何看懂一阴下穿三角压,股票不被
  • 05-11[金印组合]解密一组庄家做多盘口分时形
  • 05-11[金印组合]细谈一套做专业涨停操盘模型
  • 05-11[金印组合]操盘手一招鲜吃遍天神奇手法
  • 05-11[金印组合]揭秘股市看对未必赚钱的真正
  • 05-11[金印组合]大盘暴跌个股主力护盘拨高处
  • 02-15横盘——挖坑——突破上涨
  • 02-15图解跳空双阴线
  • 09-10缩量涨停个股打法 超级短线的快速搏击
  • 09-07缠中说禅的几张图表,股票一定要在盘整
  • 09-06逢现必大跌的九大K线组合形态,高位放量
  • 08-20K线形态出牛股之一:一脚踢出黑马
  • 08-08随着均量线波动的旋律与主力翩翩起舞
  • 08-08短线操作方法之“追涨杀跌”(一)不可
  • 07-21K线买入的10种形态
  • 07-21Gartley形态及蝴蝶形态
  • 07-18短线k线选股
  • 07-15趋势与新高的实战研究
  • 07-15K线之涨停切割线
  • 学了还要学
    炒股知识火热阅读榜
    看了还想看