»查看更多分类股票软件

老鸭头条件选股公式(通达信源码)

发布时间:2013-08-30 19:17:00  点击:

老鸭头条件选股公式(通达信源码)
图形特征:
(1)采用5、10和60参数的价格平均线。当5日、10日均线放量上穿60日平均线后,形成鸭颈部。
(2)
股价回落时的高点形成鸭头顶。
(3)
当股价回落不久,5日、10日均线再次金叉向上形成鸭嘴部。
(4)
鸭鼻孔指的是5日均线死叉10日均线后两线再度金叉时所形成的孔。
市场意义:
(1)
当庄家开始收集筹码,股价缓慢上升,5日、10日均线放量上穿60日平均线,形成鸭颈部。
(2)
当庄家震仓洗筹股价开始回档时,其股价高点形成鸭头顶。
(3)
当庄家再度建仓收集筹码时,股价再次上升,形成鸭嘴部。
操作方法:
(1) 在5日、10日均线放量上穿60日平均线形成鸭颈部时买入。
(2) 在鸭嘴部附近成交量芝麻点一带逢低买入。
(3) 当股价放量冲过鸭头顶瞬间时介入。

源码(通达信):

N:=40;

A1:=BARSLAST(REF(CROSS(MA(C,5),MA(C,10)),1));
A2:=(HHV(C,A1+1)/REF(C,A1+1)-1)*100;
A3:=CROSS(MA(C,5),MA(C,10));
A4:=LLV(V,10)=LLV(V,30) AND EXIST(MA(V,5)>MA(V,10) AND MA(V,10)>MA(V,20),30);
A5:=C/REF(C,A1+1)>1.05;
A2>10 AND A2MA(C,60);


小结:老鸭头是庄家建仓、洗盘、过鸭头顶拉高等一系列行为所形成的经典形态。
鸭头顶离开60日均线要有一点距离,否则说明庄家在这个老鸭头处建仓意愿不强,老鸭头下一定要放量,否则一样说明庄家建仓意愿不强,老鸭头的鸭鼻孔要越小越好,没有的最强!鸭鼻孔下一定要有量芝麻点,否则说明庄家控盘性差。鸭嘴下一定要通气,通气性越高越好!最后就是三张鸭嘴一张,就嘎嘎嘎叫出了长阳线!


以下收藏的条件选股公式供投资:
条件选股公式:D!HMCSF (黑马草上飞) 缺省周期:日线
==============================================================
LCZ:=(C-MA(C,60))/MA(C,60)*100;

A1:=COUNT(MA(C,60)>REF(MA(C,60),1),100)>95;
A2:=COUNT(LCZ<20,100)>95;
A3:=COUNT(C>MA(C,60),100)>80;
A4:=C/REF(C,1)>1.04;
A5:=V/CAPITAL*100>2.8;

ZTJ:=A1 AND A2 AND A3 AND A4 AND A5;
ZTJ AND (REF(BARSLAST(ZTJ),1)>20 OR BARSSINCE( ZTJ)=0);
==============================================================
黑马草上飞:
1、60日价格均线平稳上扬。
2、日K线按照60日均线斜率震荡上行。
3、经过大半年的震荡向上,终于向上突破。
操作:
发出信号后逢低积极介入。
==============================================================

条件选股公式:D!LYT (老鸭头) 缺省周期:日线
==============================================================
MA5 := MA(close,5);
MA10 := MA(close,10);
MA60 := MA(close,60);

pday1 := barslast(cross(ma5,ma60));{5日均线上穿60日均线}
pday2 := barslast(cross(ma10,ma60));{10日均线上穿60日均线,至此形成鸭颈部}
pday3 := barslast(high=hhv(high,pday2));{形成头部,要下跌}
pday4 := barslast(cross(ma10,ma5));{下跌后,5日均线和10日均线死叉}
pday5 := barslast(cross(ma5,ma10));{回落不久,5日均线和10日均线形成金叉,形成嘴部}

a1:= pday1>pday2 and pday2>pday3 and pday3>pday4 and pday4>pday5 and pday5<5;

a2:= count(cross(ma10,ma5),pday2)=1;

A1 AND A2;
==================================================================================
老鸭头:
(1)采用5、10和60周期的价格平均线。当5日、10日均线放量上穿60日平均线后,形成鸭颈部。
(2)股价回落时形成的高点形成鸭头部。
(3)当股价回落不久,5日、10日均线再次金叉向上形成鸭嘴部。
操作:
(1)在5日、10日均线放量上穿60日平均线形成鸭颈部时买入。
(2)在鸭嘴部附近成交量芝麻点一带逢低买入。
(3)当股价放量冲过鸭头顶瞬间时介入。
==============================================================


条件选股公式:D!LZMD (量芝麻点) 缺省周期:日线
==============================================================
V1:=MA(V,40);
HSL:=V/CAPITAL*100;

A1:=COUNT(V/V1<1.3,14)>11;
A2:=CROSS(HSL,2);
A3:=C/REF(C,1)>1.025 AND C>OPEN;

ZTJ:=A1 AND A2 AND A3;

==============================================================
量芝麻点:
成交量连续出现萎缩,在量柱体图上表现为小芝麻点,连续的小芝麻点与40日量平均线形成一个小水坑。
操作建议:
最好K线浅幅回档,且成交量越小越好,当放量上行时买入。
==============================================================


条件选股公式:D!QLQS (青龙取水) 缺省周期:日线
==============================================================
A1:=MIN(MA(C,5),MA(C,10))>MA(C,60) AND CROSS(MA(C,5),MA(C,10));
A2:=MIN(MA(C,5),MA(C,10))/MA(C,60)<1.05;
A3:=COUNT(V6;

A1 AND A2 AND A3;
==============================================================
青龙取水:
1、在5日、10日、60日均线图上,5、10日均线起伏不定,日K线在60日均线上逶迤。
2、龙头回到60日均线附近,犹如青龙取水,同时成交量萎缩
3、然后大涨。
操作:待龙头形成,成交量萎缩又放大后,逢低介入。
==============================================================

条件选股公式:D!QSGT (轻松过头) 缺省周期:日线
==================================================================================
nday := hhvbars(high,120); {120日内最高价的周期数}
nday1:= nday-10; {最高点之后10日}
nday2:= nday+10; {庄家应该在nday1--nday2之间吸纳大部分筹码}

a1 := nday>=30;{确保高点出现的周期数大于30}

a2 := ref(sum(vol,20),nday1) > finance(7) * 0.4; {吸纳40%}

VMA:=MA(Vol,40);{40日量均线}

A3:=COUNT(Vol0.9;{成交量呈现芝麻点}

A4:=Close>=hhv(high,120);{股价在冲击前高位}

A5:=COUNT(Vol<(MA(vol,10)*1.3),10)>8;{近期无明显放量}

A1 AND A2 AND A3 AND A4 AND A5;
==============================================================
轻松过头:
(1)前一个头部下方的成交量巨大,股价筑头后开始回档。
(2)回档完毕后成交量呈量芝麻点,股价再次上扬冲击前一头部。
(3)轻松冲过前一头部并未明显放量。
操作:
(1)在前一头部成交量巨大时跟进。
(2)在回档完毕后成交量呈现芝麻点时逢低吸纳。
(3)最经济、最大利润化的方法是在轻松过头前的一瞬间迅速介入。
(4)前头部价格一般是上升浪的腰部。
==============================================================

条件选股公式:D!SJCJD (三金叉见底) 缺省周期:日线
==============================================================
nday := 5;

down := close/llv(low,60)<=1.2;

pma1 := ma(close,5);
pma2 := ma(close,10);

vma1 := ma(vol,5);
vma2 := ma(vol,10);

diff := ema(close,12) - ema(close,26);
dea := ema(diff,9);

ppday := barslast(cross(pma1,pma2));
vvday := barslast(cross(vma1,vma2));
macdday := barslast(cross(diff,dea));

sjcjd:= if((ppday<=nday and vvday<=nday and macdday<=nday),1,0);

==============================================================
三金叉见底:
(1)当股价长期下跌后开始企稳筑底,而后股价缓慢上升。有时会同时出现5日和10日均价线、5日和10日均量线、MACD的黄金交叉点,这是股价见底回升的信号。
(2)有时会伴随出现两阳夹一阴多方炮、出水芙蓉、量顶天立地和MACD上穿零线等图形。
操作:
(1)当出现三金叉后开始买入股票。
(2)或等股价回档时在10日均线附近逢低吸纳。
==============================================================


条件选股公式:D!SSCJD (三死叉见顶) 缺省周期:日线
==============================================================
nday := 5;

down := hhv(high,20)/high<=1.15;

pma1 := ma(close,5);
pma2 := ma(close,10);

vma1 := ma(vol,5);
vma2 := ma(vol,10);

diff := ema(close,12) - ema(close,26);
dea := ema(diff,9);

ppday := barslast(cross(pma2,pma1));
vvday := barslast(cross(vma2,vma1));
macdday := barslast(cross(dea,diff));

sscjd:= if((ppday<=nday and vvday<=nday and macdday<=nday),1,0);

==============================================================
三死叉见顶:
(1)当股价长期上涨后开始进入头部,而后股价缓慢下跌。有时会同时出现5日和10日均价线、5日和10日均量线、MACD的死亡交叉点,这是股价见顶回落的信号。
(2)有时会伴随出现两阴夹一阳空方炮、断头铡刀MACD下穿零线等图形。
操作:
(1)当出现三死叉后坚决卖出股票。
(2)或等股价反弹到10日均线附近逢高派发。

1
本站提示:股市有风险,入市请慎重,资料由股票下载网整理收集

找不到你要的文章?给我们建议

  1. 股票软件
    股票分析软件
    股票交易软件
    股票行情软件
    指标股票池
    手机炒股软件
    书籍教程
    数据软件
    工具补丁
    大智慧
    通达信
    飞狐
    东方财富通
    操盘手
    指南针
    分析家
    同花顺
    钱龙
    证券之星
    券商股票软件
    特色行情软件
    迷你行情软件
    金融界软件
    美股外盘软件
    大智慧股票池
    通达信股票池
    大智慧L2公式
    通达信公式
    飞狐公式
    同花顺公式
    股票书藉
    视频教程
    金融书籍
    其他书籍
    资讯评测软件
    资金分析软件
    数据接口软件
    江恩波浪软件
    数据下载软件
    软件数据投资
    选股软件
    登录补丁
    其他应用
    股软教程
  2. 股票公式
    通达信公式
    大智慧公式
    飞狐公式
    同花顺公式
    东方财富通公式
    金字塔指标公式
    文华指标公式
    MT4指标
    博易大师指标
    公式教程答疑
  3. 炒股知识
    短线技巧
    软件公式
    炒股视频
    股票入门
    股市实战信息交流
    炒股技巧
    股票基础知识
    技术分析
    炒股一招先
    基本面分析
    股票视频教程
    股票买卖技巧
    k线图分析
    胡立阳教你买股票
    短线炒股技巧
    天狼之眼
    波浪理论技术讲解
    股市赢家杨百万
    股票理论、T0缠论、知识
    经典指标、交易系统
    成交量能、筹码分析
    买卖信号、技术分析
    挖坑、冼盘、吸筹、出货
    均线战法、黄金分割
    经典K线、趋势形态
    牛股黑马、王子理论
    涨停、周线、月线
    止盈、止损、支撑、压力
    案例、波浪、口诀、选股
    分时、盘口、补仓、解套
  4. 技术指标
    DDX
    DDY
    DDZ
    MACD
    KDJ
    CCI
    OBV
    BOLL
    RSI
    VOL
    CR
    WR